aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/mytop/Makefile1
-rw-r--r--databases/phpmyadmin/Makefile1
-rw-r--r--devel/p5-Date-Extract/Makefile2
-rw-r--r--devel/p5-Role-Basic/Makefile1
-rw-r--r--devel/p5-Set-Tiny/Makefile2
-rw-r--r--devel/p5-Symbol-Global-Name/Makefile2
-rw-r--r--mail/p5-Email-Address-List/Makefile2
-rw-r--r--mail/p5-Test-Email/Makefile2
-rw-r--r--mail/sa-utils/Makefile1
-rw-r--r--misc/p5-Business-Hours/Makefile2
-rw-r--r--net/phpldapadmin/Makefile3
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/Makefile2
-rw-r--r--ports-mgmt/wanted-ports/Makefile1
-rw-r--r--www/p5-Plack-Middleware-Test-StashWarnings/Makefile2
-rw-r--r--www/p5-RT-Authen-ExternalAuth/Makefile4
-rw-r--r--www/p5-RT-Extension-LDAPImport/Makefile4
-rw-r--r--www/p5-RT-Extension-MandatoryOnTransition/Makefile6
-rw-r--r--www/p5-RT-Extension-SLA/Makefile4
-rw-r--r--www/p5-RTx-Calendar/Makefile2
-rw-r--r--www/rt40/Makefile4
-rw-r--r--www/rt42/Makefile4
-rw-r--r--x11-fonts/gentium-basic/Makefile26
-rw-r--r--x11-fonts/gentium-plus/Makefile14
23 files changed, 66 insertions, 26 deletions
diff --git a/databases/mytop/Makefile b/databases/mytop/Makefile
index 23b68f0c2138..7f01d62c9581 100644
--- a/databases/mytop/Makefile
+++ b/databases/mytop/Makefile
@@ -14,6 +14,7 @@ RUN_DEPENDS= p5-DBD-mysql>1.0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-DBI>=1.13:${PORTSDIR}/databases/p5-DBI \
p5-Term-ReadKey>=2.10:${PORTSDIR}/devel/p5-Term-ReadKey
+NO_ARCH= yes
CONFLICTS= mariadb-scripts-[0-9]*
USES+= perl5
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index 24e5d3dc9624..76803388ded3 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -10,6 +10,7 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}-all-languages
MAINTAINER= matthew@FreeBSD.org
COMMENT= A set of PHP-scripts to manage MySQL over the web
+NO_ARCH= yes
LICENSE= GPLv2
USE_XZ= yes
diff --git a/devel/p5-Date-Extract/Makefile b/devel/p5-Date-Extract/Makefile
index 0197cc1dceae..c282f1326579 100644
--- a/devel/p5-Date-Extract/Makefile
+++ b/devel/p5-Date-Extract/Makefile
@@ -15,6 +15,8 @@ BUILD_DEPENDS= p5-DateTime-Format-Natural>0:${PORTSDIR}/devel/p5-DateTime-Format
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-MockTime>=0:${PORTSDIR}/devel/p5-Test-MockTime
+NO_ARCH= yes
+
USES= perl5
USE_PERL5= configure
diff --git a/devel/p5-Role-Basic/Makefile b/devel/p5-Role-Basic/Makefile
index 91c0eec4fbc8..cd99e37b16b8 100644
--- a/devel/p5-Role-Basic/Makefile
+++ b/devel/p5-Role-Basic/Makefile
@@ -11,6 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= matthew@FreeBSD.org
COMMENT= Just roles. Nothing else
+NO_ARCH= yes
PORTSCOUT= limit:^0\.[1-9]
USES= perl5
diff --git a/devel/p5-Set-Tiny/Makefile b/devel/p5-Set-Tiny/Makefile
index a20d8753b3b2..d9baefc39d4e 100644
--- a/devel/p5-Set-Tiny/Makefile
+++ b/devel/p5-Set-Tiny/Makefile
@@ -10,6 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= matthew@FreeBSD.org
COMMENT= Simple sets of strings
+NO_ARCH= yes
+
USES= perl5
USE_PERL5= configure
diff --git a/devel/p5-Symbol-Global-Name/Makefile b/devel/p5-Symbol-Global-Name/Makefile
index 39004d0eae9f..7c4c36d2ccf6 100644
--- a/devel/p5-Symbol-Global-Name/Makefile
+++ b/devel/p5-Symbol-Global-Name/Makefile
@@ -10,6 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= matthew@FreeBSD.org
COMMENT= Finds name and type of a global variable
+NO_ARCH= yes
+
USES= perl5
USE_PERL5= configure
diff --git a/mail/p5-Email-Address-List/Makefile b/mail/p5-Email-Address-List/Makefile
index 29ff6d2b4788..0a76a1c388a5 100644
--- a/mail/p5-Email-Address-List/Makefile
+++ b/mail/p5-Email-Address-List/Makefile
@@ -13,6 +13,8 @@ COMMENT= RFC-close address list parsing
BUILD_DEPENDS= p5-Email-Address>0:${PORTSDIR}/mail/p5-Email-Address
RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
+
USES= perl5
USE_PERL5= configure
diff --git a/mail/p5-Test-Email/Makefile b/mail/p5-Test-Email/Makefile
index 468826ee19cf..ef2055f277c2 100644
--- a/mail/p5-Test-Email/Makefile
+++ b/mail/p5-Test-Email/Makefile
@@ -17,6 +17,8 @@ BUILD_DEPENDS= p5-Mail-POP3Client>=2:${PORTSDIR}/mail/p5-Mail-POP3Client \
p5-Test-Simple>=0.7:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
+
USES= perl5
USE_PERL5= configure
diff --git a/mail/sa-utils/Makefile b/mail/sa-utils/Makefile
index d98e5119fbd6..e0b7a0abd2cc 100644
--- a/mail/sa-utils/Makefile
+++ b/mail/sa-utils/Makefile
@@ -16,6 +16,7 @@ RUN_DEPENDS= sa-update:${PORTSDIR}/mail/p5-Mail-SpamAssassin
OPTIONS_DEFINE= SACOMPILE
SACOMPILE_DESC= Enable sa-compile support
+NO_ARCH= yes
NO_BUILD= yes
SUB_FILES= sa-utils
diff --git a/misc/p5-Business-Hours/Makefile b/misc/p5-Business-Hours/Makefile
index 3b7f3f1db8be..208c95743646 100644
--- a/misc/p5-Business-Hours/Makefile
+++ b/misc/p5-Business-Hours/Makefile
@@ -15,6 +15,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>-1.0:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+NO_ARCH= yes
+
USES+= perl5
USE_PERL5= configure
diff --git a/net/phpldapadmin/Makefile b/net/phpldapadmin/Makefile
index 633273bd7d63..c68b94becc62 100644
--- a/net/phpldapadmin/Makefile
+++ b/net/phpldapadmin/Makefile
@@ -9,10 +9,11 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-php5/${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= matthew@FreeBSD.org
-COMMENT= A set of PHP-scripts to administer LDAP over the web
+COMMENT= PHP application to administer LDAP over the web
LICENSE= GPLv2
+NO_ARCH= yes
NO_BUILD= yes
USE_PHP= gettext ldap openssl pcre session xml iconv hash
DEFAULT_PHP_VER= 5
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/Makefile b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
index f41707aebdfa..d11421f216ec 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
@@ -15,6 +15,8 @@ LICENSE= BSD
BUILD_DEPENDS= p5-BerkeleyDB>0:${PORTSDIR}/databases/p5-BerkeleyDB
RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
+
# GraphViz not required for portindex to run or generate GraphViz
# format output: this is only needed to render the output on the same
# machine.
diff --git a/ports-mgmt/wanted-ports/Makefile b/ports-mgmt/wanted-ports/Makefile
index 154a3548bb3e..4b0a6193dc9c 100644
--- a/ports-mgmt/wanted-ports/Makefile
+++ b/ports-mgmt/wanted-ports/Makefile
@@ -13,6 +13,7 @@ COMMENT= Just depend on a configurable, arbitrary set of other ports
LICENSE= BSD
+NO_ARCH= yes
NO_BUILD= yes
SUB_FILES= ${PORTNAME} \
${PORTNAME}.1
diff --git a/www/p5-Plack-Middleware-Test-StashWarnings/Makefile b/www/p5-Plack-Middleware-Test-StashWarnings/Makefile
index 03b9bb0ceb8a..2bcc99a7518b 100644
--- a/www/p5-Plack-Middleware-Test-StashWarnings/Makefile
+++ b/www/p5-Plack-Middleware-Test-StashWarnings/Makefile
@@ -13,6 +13,8 @@ COMMENT= Test your application's warnings
BUILD_DEPENDS= p5-Plack>0:${PORTSDIR}/www/p5-Plack
RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
+
USES= perl5
USE_PERL5= configure
diff --git a/www/p5-RT-Authen-ExternalAuth/Makefile b/www/p5-RT-Authen-ExternalAuth/Makefile
index 918871ebd2f3..77a7808cf49b 100644
--- a/www/p5-RT-Authen-ExternalAuth/Makefile
+++ b/www/p5-RT-Authen-ExternalAuth/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= p5-perl-ldap>0:${PORTSDIR}/net/p5-perl-ldap \
p5-Net-SSLeay>0:${PORTSDIR}/security/p5-Net-SSLeay
RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
+
USES+= perl5
USE_PERL5= configure
@@ -47,7 +49,7 @@ MAN3PREFIX= ${PREFIX}
PLIST_SUB+= RTHOME=share/rt${RT_VER}
# Note: You can install using an arbitrary $PREFIX but only if it
-# matches the $PREFIX used to install www/rt{38,40}. Hence ignore
+# matches the $PREFIX used to install www/rt{38,40,42}. Hence ignore
# $PREFIX in the environment and inherit settings from RT.pm
do-configure:
diff --git a/www/p5-RT-Extension-LDAPImport/Makefile b/www/p5-RT-Extension-LDAPImport/Makefile
index f7b7eb582523..27ed1f998de0 100644
--- a/www/p5-RT-Extension-LDAPImport/Makefile
+++ b/www/p5-RT-Extension-LDAPImport/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= p5-perl-ldap>0:${PORTSDIR}/net/p5-perl-ldap \
p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor
RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
+
USES+= perl5
USE_PERL5= configure
@@ -47,7 +49,7 @@ MAN3PREFIX= ${PREFIX}
PLIST_SUB+= RTHOME=share/rt${RT_VER}
# Note: You can install using an arbitrary $PREFIX but only if it
-# matches the $PREFIX used to install www/rt{38,40}. Hence ignore
+# matches the $PREFIX used to install www/rt{38,40,42}. Hence ignore
# $PREFIX in the environment and inherit settings from RT.pm
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
diff --git a/www/p5-RT-Extension-MandatoryOnTransition/Makefile b/www/p5-RT-Extension-MandatoryOnTransition/Makefile
index 4b74e5420a47..32d1caf9245d 100644
--- a/www/p5-RT-Extension-MandatoryOnTransition/Makefile
+++ b/www/p5-RT-Extension-MandatoryOnTransition/Makefile
@@ -33,13 +33,15 @@ RT_VER= ${opt}
BUILD_DEPENDS= ${LOCALBASE}/bin/rt:${PORTSDIR}/www/rt${RT_VER}
RUN_DEPENDS= ${LOCALBASE}/bin/rt:${PORTSDIR}/www/rt${RT_VER}
-USES= perl5
+NO_ARCH= yes
+
+USES= perl5
USE_PERL5= configure
PLIST_SUB+= RT_VER=${RT_VER}
# Note: You can install using an arbitrary $PREFIX but only if it
-# matches the $PREFIX used to install www/rt{38,40}. Hence ignore
+# matches the $PREFIX used to install www/rt{40,42}. Hence ignore
# $PREFIX in the environment and inherit settings from RT.pm
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
diff --git a/www/p5-RT-Extension-SLA/Makefile b/www/p5-RT-Extension-SLA/Makefile
index e28421d0b51f..787bd45af9e6 100644
--- a/www/p5-RT-Extension-SLA/Makefile
+++ b/www/p5-RT-Extension-SLA/Makefile
@@ -18,6 +18,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
LICENSE= GPLv2
+NO_ARCH= yes
+
USES+= perl5
USE_PERL5= configure
@@ -50,7 +52,7 @@ SUB_LIST+= INITIALDATA=plugins/RT-Extension-SLA/etc/initialdata \
SUB_FILES+= pkg-message
# Note: You can install using an arbitrary $PREFIX but only if it
-# matches the $PREFIX used to install www/rt{38,40}. Hence ignore
+# matches the $PREFIX used to install www/rt{38,40,42}. Hence ignore
# $PREFIX in the environment and inherit settings from RT.pm
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
diff --git a/www/p5-RTx-Calendar/Makefile b/www/p5-RTx-Calendar/Makefile
index 3b6ecdb786db..0d5f9dc2f522 100644
--- a/www/p5-RTx-Calendar/Makefile
+++ b/www/p5-RTx-Calendar/Makefile
@@ -19,6 +19,8 @@ BUILD_DEPENDS= p5-Date-ICal>0:${PORTSDIR}/devel/p5-Date-ICal \
p5-DateTime-Set>0:${PORTSDIR}/devel/p5-DateTime-Set
RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
+
USES+= perl5
USE_PERL5= configure
diff --git a/www/rt40/Makefile b/www/rt40/Makefile
index d946bfa382bf..63d1f9b336b6 100644
--- a/www/rt40/Makefile
+++ b/www/rt40/Makefile
@@ -13,13 +13,15 @@ CONFLICTS= rt-3.8* rt42-4.2* brlcad-[0-9]*
PKGNAMESUFFIX= 40
NEED_ROOT= yes
+NO_ARCH= yes
+
# See doc/web_deployment.pod for info on the choices of webserver /
# webapp combinations. Note: if using apache, apache-2.2+ is
# recommended. For deployment with nginx, use the SPAWN_FCGI method
# or the builtin webserver with a FCGI handler.
#
# The builtin standalone PSGI based webserver is always available, no
-# mater what choice of web deployment platform, or none, that you
+# matter what choice of web deployment platform, or none, that you
# make. Best Practical state that this is really only suitable for
# development usage, although I have heard reports of people using it
# successfully for medium sized deployments. If you only want the
diff --git a/www/rt42/Makefile b/www/rt42/Makefile
index 8a340066e28f..c8e6866b9022 100644
--- a/www/rt42/Makefile
+++ b/www/rt42/Makefile
@@ -12,13 +12,15 @@ COMMENT= RT is an industrial-grade ticketing system written in Perl
CONFLICTS= rt-3.8* rt40-4.0* brlcad-[0-9]*
+NO_ARCH= yes
+
# See doc/web_deployment.pod for info on the choices of webserver /
# webapp combinations. Note: if using apache, apache-2.2+ is
# recommended. For deployment with nginx, use the SPAWN_FCGI method
# or the builtin webserver with a FCGI handler.
#
# The builtin standalone PSGI based webserver is always available, no
-# mater what choice of web deployment platform, or none, that you
+# matter what choice of web deployment platform, or none, that you
# make. Best Practical state that this is really only suitable for
# development usage, although I have heard reports of people using it
# successfully for medium sized deployments. If you only want the
diff --git a/x11-fonts/gentium-basic/Makefile b/x11-fonts/gentium-basic/Makefile
index 2a4fa7b85b65..d886f7525dda 100644
--- a/x11-fonts/gentium-basic/Makefile
+++ b/x11-fonts/gentium-basic/Makefile
@@ -12,26 +12,28 @@ COMMENT= Gentium Basic and Gentium Book Basic TrueType fonts
LICENSE= OFL11
+NO_ARCH= yes
+
USE_TGZ= yes
XORG_CAT= font
FONTLIBPATH= lib/X11/fonts
-FONTROOTDIR= ${STAGEDIR}${PREFIX}/${FONTLIBPATH}
+FONTPATH= ${PREFIX}/${FONTLIBPATH}/${FONTDIR}
INSTALLS_TTF= yes
MEDIA_ID= ${PORTNAME}_${PORTVERSION}_tar
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${DISTNAME:S,.orig,,:S,_,-,}
-PLIST_FILES= ${FONTLIBPATH}/${FONTDIR}/GenBasB.ttf \
- ${FONTLIBPATH}/${FONTDIR}/GenBasBI.ttf \
- ${FONTLIBPATH}/${FONTDIR}/GenBasI.ttf \
- ${FONTLIBPATH}/${FONTDIR}/GenBasR.ttf \
- ${FONTLIBPATH}/${FONTDIR}/GenBkBasB.ttf \
- ${FONTLIBPATH}/${FONTDIR}/GenBkBasBI.ttf \
- ${FONTLIBPATH}/${FONTDIR}/GenBkBasI.ttf \
- ${FONTLIBPATH}/${FONTDIR}/GenBkBasR.ttf
+PLIST_FILES= ${FONTPATH:S,^${PREFIX}/,,}/GenBasB.ttf \
+ ${FONTPATH:S,^${PREFIX}/,,}/GenBasBI.ttf \
+ ${FONTPATH:S,^${PREFIX}/,,}/GenBasI.ttf \
+ ${FONTPATH:S,^${PREFIX}/,,}/GenBasR.ttf \
+ ${FONTPATH:S,^${PREFIX}/,,}/GenBkBasB.ttf \
+ ${FONTPATH:S,^${PREFIX}/,,}/GenBkBasBI.ttf \
+ ${FONTPATH:S,^${PREFIX}/,,}/GenBkBasI.ttf \
+ ${FONTPATH:S,^${PREFIX}/,,}/GenBkBasR.ttf
-SUB_LIST= "FONTPATH=${PREFIX}/${FONTLIBPATH}/${FONTDIR}"
+SUB_LIST= "FONTPATH=${FONTPATH}"
SUB_FILES= pkg-message
DOCSLIST= FONTLOG.txt GENTIUM-FAQ.txt OFL-FAQ.txt
@@ -47,8 +49,8 @@ do-configure:
do-install: install-fonts install-docs
install-fonts:
- ${MKDIR} ${FONTROOTDIR}/${FONTDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.ttf ${FONTROOTDIR}/${FONTDIR}
+ ${MKDIR} ${STAGEDIR}${FONTPATH}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${STAGEDIR}${FONTPATH}
install-docs:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/x11-fonts/gentium-plus/Makefile b/x11-fonts/gentium-plus/Makefile
index b7352ef07963..5e3a425f7c71 100644
--- a/x11-fonts/gentium-plus/Makefile
+++ b/x11-fonts/gentium-plus/Makefile
@@ -11,20 +11,22 @@ COMMENT= Gentium Plus TrueType font collection
LICENSE= OFL11
+NO_ARCH= yes
+
USE_ZIP= yes
XORG_CAT= font
FONTLIBPATH= lib/X11/fonts
-FONTROOTDIR= ${STAGEDIR}${PREFIX}/${FONTLIBPATH}
+FONTPATH= ${PREFIX}/${FONTLIBPATH}/${FONTDIR}
INSTALLS_TTF= yes
MEDIA_ID= ${DISTNAME}${EXTRACT_SUFX}
NO_BUILD= yes
USE_TGZ= yes #prevent bsd.xorg.mk from setting USE_BZIP
-PLIST_FILES= ${FONTLIBPATH}/${FONTDIR}/${PORTNAME}-I.ttf \
- ${FONTLIBPATH}/${FONTDIR}/${PORTNAME}-R.ttf
+PLIST_FILES= ${FONTPATH:S,^${PREFIX}/,,}/${PORTNAME}-I.ttf \
+ ${FONTPATH:S,^${PREFIX}/,,}/${PORTNAME}-R.ttf
-SUB_LIST= "FONTPATH=${PREFIX}$FONTLIBPATH}/${FONTDIR}"
+SUB_LIST= "FONTPATH=${FONTPATH}"
SUB_FILES= pkg-message
DOCSLIST= FONTLOG.txt GENTIUM-FAQ.txt OFL-FAQ.txt OFL.txt README.txt \
@@ -41,8 +43,8 @@ do-configure:
do-install: install-fonts install-docs
install-fonts:
- ${MKDIR} ${FONTROOTDIR}/${FONTDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.ttf ${FONTROOTDIR}/${FONTDIR}
+ ${MKDIR} ${STAGEDIR}${FONTPATH}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${STAGEDIR}${FONTPATH}
install-docs:
.if ${PORT_OPTIONS:MDOCS}