aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/ganglia-webfrontend/Makefile11
-rw-r--r--sysutils/ganglia-webfrontend/distinfo4
-rw-r--r--sysutils/ganglia-webfrontend/files/patch-conf.php20
-rw-r--r--sysutils/ganglia-webfrontend/files/patch-conf.php.in14
-rw-r--r--sysutils/ganglia-webfrontend/pkg-plist3
5 files changed, 25 insertions, 27 deletions
diff --git a/sysutils/ganglia-webfrontend/Makefile b/sysutils/ganglia-webfrontend/Makefile
index b48441a510e9..e8f34c7fac12 100644
--- a/sysutils/ganglia-webfrontend/Makefile
+++ b/sysutils/ganglia-webfrontend/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= webfrontend
-PORTVERSION= 3.1.1
-PORTREVISION= 3
+PORTVERSION= 3.1.7
CATEGORIES= sysutils net parallel www
MASTER_SITES= SF/ganglia/ganglia%20monitoring%20core/${PORTVERSION}%20%28Wien%29
PKGNAMEPREFIX= ganglia-
@@ -28,6 +27,7 @@ SUB_LIST+= WEBFRONTDIR="${WEBFRONTDIR}"
PLIST_SUB+= WEBFRONTDIR="${WEBFRONTDIR}"
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= GANGLIA_ACK_SYSCONFDIR=1
CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}
USE_PHP= gd pcre xml ctype
@@ -45,7 +45,9 @@ PKGOPTS= ${FILESDIR}/pkg-opts
EXCEPTFILES= AUTHORS \
ChangeLog \
COPYING \
+ Makefile \
Makefile.am \
+ Makefile.in \
addons \
webfrontend.spec \
version.php.in
@@ -65,9 +67,10 @@ post-extract:
.endif
post-patch:
- @ ${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/conf.php
+ @ ${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/conf.php.in
do-build:
+ @cd ${WRKSRC} && make install
@${MKDIR} -m 0755 ${TMP_WEBFRONTDIR}
@cd ${WRKSRC} && ${FIND} * \( -name conf.php\* \
${EXCEPTFILES:S/^/-o -name /} -o -name \*.orig \) \
@@ -87,7 +90,7 @@ post-install:
@${CAT} ${PKGMESSAGE}
build-plist:
- ${RM} ${PLIST}
+ @${RM} ${PLIST}
@${ECHO_CMD} '@unexec cmp -s %D/%%WEBFRONTDIR%%/conf.php %D/%%WEBFRONTDIR%%/conf.php.sample && rm -f %D/%%WEBFRONTDIR%%/conf.php' >> ${PLIST}
@${FIND} ${TMP_WEBFRONTDIR}/* -type f | \
${SED} -e 's|${TMP_WEBFRONTDIR}|%%WEBFRONTDIR%%|' | \
diff --git a/sysutils/ganglia-webfrontend/distinfo b/sysutils/ganglia-webfrontend/distinfo
index fa4937d6da16..87fc48a1a64c 100644
--- a/sysutils/ganglia-webfrontend/distinfo
+++ b/sysutils/ganglia-webfrontend/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ganglia-3.1.1.tar.gz) = cc6955f0b086f40dc646e3d0d9f152854d1dcd19dea81b9bff16b38f3819f75c
-SIZE (ganglia-3.1.1.tar.gz) = 1152883
+SHA256 (ganglia-3.1.7.tar.gz) = bb1a4953d72e7dace76010a30d6d332e4ac0991d1371dbbcbcc7b048e0a7e4bf
+SIZE (ganglia-3.1.7.tar.gz) = 1278023
diff --git a/sysutils/ganglia-webfrontend/files/patch-conf.php b/sysutils/ganglia-webfrontend/files/patch-conf.php
deleted file mode 100644
index 7a58704aab11..000000000000
--- a/sysutils/ganglia-webfrontend/files/patch-conf.php
+++ /dev/null
@@ -1,20 +0,0 @@
-
-$FreeBSD$
-
---- conf.php.orig
-+++ conf.php
-@@ -18,12 +18,12 @@
- #
-
- # Where gmetad stores the rrd archives.
--$gmetad_root = "/var/lib/ganglia";
-+$gmetad_root = "/var/db/ganglia";
- $rrds = "$gmetad_root/rrds";
-
- # Leave this alone if rrdtool is installed in $gmetad_root,
- # otherwise, change it if it is installed elsewhere (like /usr/bin)
--define("RRDTOOL", "/usr/bin/rrdtool");
-+define("RRDTOOL", "%%LOCALBASE%%/bin/rrdtool");
-
- #
- # If you want to grab data from a different ganglia source specify it here.
diff --git a/sysutils/ganglia-webfrontend/files/patch-conf.php.in b/sysutils/ganglia-webfrontend/files/patch-conf.php.in
new file mode 100644
index 000000000000..2b2961c12a0e
--- /dev/null
+++ b/sysutils/ganglia-webfrontend/files/patch-conf.php.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- conf.php.in.orig
++++ conf.php.in
+@@ -23,7 +23,7 @@
+
+ # Leave this alone if rrdtool is installed in $gmetad_root,
+ # otherwise, change it if it is installed elsewhere (like /usr/bin)
+-define("RRDTOOL", "/usr/bin/rrdtool");
++define("RRDTOOL", "%%LOCALBASE%%/bin/rrdtool");
+
+ # If rrdcached is being used, this argument must specify the
+ # socket to use.
diff --git a/sysutils/ganglia-webfrontend/pkg-plist b/sysutils/ganglia-webfrontend/pkg-plist
index bdd6e17709bc..ef21759f9626 100644
--- a/sysutils/ganglia-webfrontend/pkg-plist
+++ b/sysutils/ganglia-webfrontend/pkg-plist
@@ -4,6 +4,7 @@
%%WEBFRONTDIR%%/cluster_legend.html
%%WEBFRONTDIR%%/cluster_view.php
%%WEBFRONTDIR%%/conf.php.sample
+%%WEBFRONTDIR%%/eval_config.php
%%WEBFRONTDIR%%/footer.php
%%WEBFRONTDIR%%/functions.php
%%WEBFRONTDIR%%/ganglia.php
@@ -64,5 +65,5 @@
@dirrm %%WEBFRONTDIR%%/templates/default
@dirrm %%WEBFRONTDIR%%/templates
@dirrm %%WEBFRONTDIR%%/graph.d
-@dirrmtry %%WEBFRONTDIR%%
+@dirrmtry /bin/rmdir %D/%%WEBFRONTDIR%%
@unexec (test -d %D/%%WEBFRONTDIR%% && (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove %D/%%WEBFRONTDIR%% and its contents manually.")) || true