aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/maxima/Makefile32
-rw-r--r--math/maxima/distinfo4
-rw-r--r--math/maxima/files/patch-doc_info_Makefile.in (renamed from math/maxima/files/patch-doc_info_Makefile.am)0
-rw-r--r--math/maxima/pkg-plist12
4 files changed, 35 insertions, 13 deletions
diff --git a/math/maxima/Makefile b/math/maxima/Makefile
index be1dec5deea3..bd9336887c48 100644
--- a/math/maxima/Makefile
+++ b/math/maxima/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= maxima
-PORTVERSION= 5.23.2
+PORTVERSION= 5.24.0
CATEGORIES= math lisp tk
MASTER_SITES= SF/maxima/Maxima-source/${PORTVERSION}-source
@@ -23,7 +23,8 @@ LICENSE= GPLv2
USE_TK = 84+
USE_GMAKE= yes
USE_PERL5_BUILD= yes
-USE_AUTOTOOLS= aclocal autoconf
+USE_PYTHON_BUILD= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} \
--with-posix-shell=${LOCALBASE}/bin/bash \
--with-wish=${WISH} \
@@ -67,7 +68,17 @@ BINDIRECTORY= binary-gcl
PLIST_SUB+= LISPBINARY="@comment "
MAXIMABINARY= maxima
.elif defined(WITHOUT_CLISP) && defined(WITHOUT_CMUCL) && defined(WITHOUT_GCL) && defined(WITH_SBCL)
+. if ${ARCH} == "i386"
+DYNAMIC_SPACE_SIZE?= 512
+. endif
+. if defined(DYNAMIC_SPACE_SIZE)
+MAXIMA_LISP_OPTIONS+= --dynamic-space-size ${DYNAMIC_SPACE_SIZE}
+. endif
+. if defined(MAXIMA_LISP_OPTIONS) && !empty(MAXIMA_LISP_OPTIONS)
+LISPSELECT= --with-sbcl="sbcl ${MAXIMA_LISP_OPTIONS}"
+. else
LISPSELECT= --enable-sbcl
+. endif
LISPPORT= sbcl:${PORTSDIR}/lang/sbcl
BINDIRECTORY= binary-sbcl
#LISPBINARY is null so fudge this so deinstall works cleanly
@@ -79,12 +90,17 @@ IGNORE= define only one lisp
post-patch:
${FIND} -X ${WRKSRC}/archive ${WRKSRC}/interfaces/xmaxima \
- -name "Makefile*" | ${XARGS} ${REINPLACE_CMD} -e "s;tclsh;${TCLSH};g"
- ${REINPLACE_CMD} -e "s;/usr/;${LOCALBASE}/;g" ${WRKSRC}/src/intl.lisp
- ( cd ${WRKSRC}/doc/info ; ${LOCALBASE}/bin/bash ./fix_crlf ; \
- ${LOCALBASE}/bin/bash ./fix_tab )
+ -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e "s;tclsh;${TCLSH};g"
+ ${REINPLACE_CMD} -e "s;/usr;${LOCALBASE};g" ${WRKSRC}/src/intl.lisp
+ (cd ${WRKSRC}/doc/info ; ${LOCALBASE}/bin/bash ./fix_crlf ; \
+ ${LOCALBASE}/bin/bash ./fix_tab)
+.if defined(MAXIMA_LISP_OPTIONS) && !empty(MAXIMA_LISP_OPTIONS)
+ ${REINPLACE_CMD} -e 's;"@SBCL_NAME@";@SBCL_NAME@;' \
+ ${WRKSRC}/src/maxima.in
+.endif
-test: build
- ${LOCALBASE}/bin/bash ${WRKSRC}/maxima-local --batch-string='run_testsuite();'
+test check: build
+ (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} check)
.include <bsd.port.post.mk>
diff --git a/math/maxima/distinfo b/math/maxima/distinfo
index b30d48b8cf6b..b2f0af0ab504 100644
--- a/math/maxima/distinfo
+++ b/math/maxima/distinfo
@@ -1,2 +1,2 @@
-SHA256 (maxima-5.23.2.tar.gz) = 7bea62518135caf9ee9afccc1fb9fbc525c9b6bfb8d0614b5bbe4a51e9a1ce74
-SIZE (maxima-5.23.2.tar.gz) = 21963705
+SHA256 (maxima-5.24.0.tar.gz) = 58eb35806741c3388966a51ccecb7bd82e9a773a06d57276c6bc43e3c4ceec8c
+SIZE (maxima-5.24.0.tar.gz) = 25422077
diff --git a/math/maxima/files/patch-doc_info_Makefile.am b/math/maxima/files/patch-doc_info_Makefile.in
index 25d0eab08818..25d0eab08818 100644
--- a/math/maxima/files/patch-doc_info_Makefile.am
+++ b/math/maxima/files/patch-doc_info_Makefile.in
diff --git a/math/maxima/pkg-plist b/math/maxima/pkg-plist
index 3da0051fdbf9..040de14d2936 100644
--- a/math/maxima/pkg-plist
+++ b/math/maxima/pkg-plist
@@ -113,6 +113,9 @@ libexec/maxima/%%PORTVERSION%%/mgnuplot
%%DATADIR%%/%%PORTVERSION%%/doc/html/maxima.html
%%DATADIR%%/%%PORTVERSION%%/doc/html/maxima_1.html
%%DATADIR%%/%%PORTVERSION%%/doc/html/maxima_10.html
+%%DATADIR%%/%%PORTVERSION%%/doc/html/maxima_100.html
+%%DATADIR%%/%%PORTVERSION%%/doc/html/maxima_101.html
+%%DATADIR%%/%%PORTVERSION%%/doc/html/maxima_102.html
%%DATADIR%%/%%PORTVERSION%%/doc/html/maxima_11.html
%%DATADIR%%/%%PORTVERSION%%/doc/html/maxima_12.html
%%DATADIR%%/%%PORTVERSION%%/doc/html/maxima_13.html
@@ -497,9 +500,7 @@ libexec/maxima/%%PORTVERSION%%/mgnuplot
%%DATADIR%%/%%PORTVERSION%%/share/contrib/ezunits/physical_constants.mac
%%DATADIR%%/%%PORTVERSION%%/share/contrib/ezunits/rtestezunits.mac
%%DATADIR%%/%%PORTVERSION%%/share/contrib/f90.lisp
-%%DATADIR%%/%%PORTVERSION%%/share/contrib/finance/finance.es.texi
%%DATADIR%%/%%PORTVERSION%%/share/contrib/finance/finance.mac
-%%DATADIR%%/%%PORTVERSION%%/share/contrib/finance/finance.texi
%%DATADIR%%/%%PORTVERSION%%/share/contrib/floatproperties.lisp
%%DATADIR%%/%%PORTVERSION%%/share/contrib/format/README
%%DATADIR%%/%%PORTVERSION%%/share/contrib/format/autoload-m.macsyma
@@ -517,7 +518,6 @@ libexec/maxima/%%PORTVERSION%%/mgnuplot
%%DATADIR%%/%%PORTVERSION%%/share/contrib/fourier_elim/fourier_elim.lisp
%%DATADIR%%/%%PORTVERSION%%/share/contrib/fourier_elim/rtest_fourier_elim.mac
%%DATADIR%%/%%PORTVERSION%%/share/contrib/fractals/fractals.mac
-%%DATADIR%%/%%PORTVERSION%%/share/contrib/fractals/fractals.texi
%%DATADIR%%/%%PORTVERSION%%/share/contrib/fractals/rtest_fractals.mac
%%DATADIR%%/%%PORTVERSION%%/share/contrib/fresnel/d78.mac
%%DATADIR%%/%%PORTVERSION%%/share/contrib/fresnel/fg.mac
@@ -664,6 +664,7 @@ libexec/maxima/%%PORTVERSION%%/mgnuplot
%%DATADIR%%/%%PORTVERSION%%/share/contrib/noninteractive/asksign1.lisp
%%DATADIR%%/%%PORTVERSION%%/share/contrib/noninteractive/noninteractive.lisp
%%DATADIR%%/%%PORTVERSION%%/share/contrib/noninteractive/noninteractive.mac
+%%DATADIR%%/%%PORTVERSION%%/share/contrib/noninteractive/rtest_noninteractive.mac
%%DATADIR%%/%%PORTVERSION%%/share/contrib/nset/README
%%DATADIR%%/%%PORTVERSION%%/share/contrib/nset/announce-1.2.txt
%%DATADIR%%/%%PORTVERSION%%/share/contrib/nset/changes_1.0_to_1.2.txt
@@ -874,16 +875,20 @@ libexec/maxima/%%PORTVERSION%%/mgnuplot
%%DATADIR%%/%%PORTVERSION%%/share/diffequations/pivtr.mac
%%DATADIR%%/%%PORTVERSION%%/share/diffequations/pmain.mac
%%DATADIR%%/%%PORTVERSION%%/share/draw/draw.lisp
+%%DATADIR%%/%%PORTVERSION%%/share/draw/drawutils.mac
+%%DATADIR%%/%%PORTVERSION%%/share/draw/drawutils.texi
%%DATADIR%%/%%PORTVERSION%%/share/draw/grcommon.lisp
%%DATADIR%%/%%PORTVERSION%%/share/draw/implicit3d.lisp
%%DATADIR%%/%%PORTVERSION%%/share/draw/picture.lisp
%%DATADIR%%/%%PORTVERSION%%/share/draw/rtest_draw.mac
+%%DATADIR%%/%%PORTVERSION%%/share/draw/vtk.lisp
%%DATADIR%%/%%PORTVERSION%%/share/draw/wbd.lisp
%%DATADIR%%/%%PORTVERSION%%/share/draw/worldmap.mac
%%DATADIR%%/%%PORTVERSION%%/share/dynamics/complex_dynamics.lisp
%%DATADIR%%/%%PORTVERSION%%/share/dynamics/dynamics.mac
%%DATADIR%%/%%PORTVERSION%%/share/dynamics/plotdf.lisp
%%DATADIR%%/%%PORTVERSION%%/share/dynamics/rtest_dynamics.mac
+%%DATADIR%%/%%PORTVERSION%%/share/dynamics/visualization.lisp
%%DATADIR%%/%%PORTVERSION%%/share/hypergeometric/abramowitz_id.mac
%%DATADIR%%/%%PORTVERSION%%/share/hypergeometric/hypergeometric.lisp
%%DATADIR%%/%%PORTVERSION%%/share/hypergeometric/hypergeometric_mac.mac
@@ -976,6 +981,7 @@ libexec/maxima/%%PORTVERSION%%/mgnuplot
%%DATADIR%%/%%PORTVERSION%%/share/lapack/blas/ztrmv.lisp
%%DATADIR%%/%%PORTVERSION%%/share/lapack/blas/ztrsm.lisp
%%DATADIR%%/%%PORTVERSION%%/share/lapack/blas/ztrsv.lisp
+%%DATADIR%%/%%PORTVERSION%%/share/lapack/dgemm.lisp
%%DATADIR%%/%%PORTVERSION%%/share/lapack/dgesv.lisp
%%DATADIR%%/%%PORTVERSION%%/share/lapack/eigensys.lisp
%%DATADIR%%/%%PORTVERSION%%/share/lapack/lapack-lisp.system