aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/wxmaxima/Makefile1
-rw-r--r--math/wxmaxima/files/patch-src_wxMaxima.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/math/wxmaxima/Makefile b/math/wxmaxima/Makefile
index 366d176d3bd0..b72a7a02e014 100644
--- a/math/wxmaxima/Makefile
+++ b/math/wxmaxima/Makefile
@@ -1,6 +1,7 @@
PORTNAME= wxmaxima
PORTVERSION= 23.02.1
DISTVERSIONPREFIX= Version-
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= salvadore@FreeBSD.org
diff --git a/math/wxmaxima/files/patch-src_wxMaxima.cpp b/math/wxmaxima/files/patch-src_wxMaxima.cpp
new file mode 100644
index 000000000000..72a03619f620
--- /dev/null
+++ b/math/wxmaxima/files/patch-src_wxMaxima.cpp
@@ -0,0 +1,11 @@
+--- src/wxMaxima.cpp.orig 2023-02-04 19:03:25 UTC
++++ src/wxMaxima.cpp
+@@ -3289,8 +3289,6 @@ void wxMaxima::VariableActionMaximaHtmldir(const wxStr
+ wxLogMessage(wxString::Format(_("Maxima's HTML manuals are in directory %s"),
+ dir_canonical.utf8_str()));
+ m_worksheet->SetMaximaDocDir(dir_canonical);
+- m_worksheet->LoadHelpFileAnchors(dir_canonical,
+- m_worksheet->GetMaximaVersion());
+ }
+ void wxMaxima::GnuplotCommandName(wxString gnuplot) {
+ m_gnuplotcommand = gnuplot;