aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--games/Makefile1
-rw-r--r--games/galaxymage/Makefile59
-rw-r--r--games/galaxymage/distinfo2
-rw-r--r--games/galaxymage/files/patch-GalaxyMage.py11
-rw-r--r--games/galaxymage/files/patch-src_Resources.py21
-rw-r--r--games/galaxymage/files/patch-src_Translate.py11
-rw-r--r--games/galaxymage/pkg-descr17
-rw-r--r--games/galaxymage/pkg-plist20
9 files changed, 1 insertions, 142 deletions
diff --git a/MOVED b/MOVED
index 9ec175bde511..742667d130e5 100644
--- a/MOVED
+++ b/MOVED
@@ -7822,3 +7822,4 @@ graphics/skencil||2015-08-08|Has expired: Project is abandoned and was overtaken
www/ismail||2015-08-08|Has expired: Development has been discontinued for many years
sysutils/rubygem-bundler17||2015-08-13|Has expired: not used by other ports anymore
sysutils/fpkg||2015-08-15|Has expired: Does not support pkg(8)
+games/galaxymage||2015-08-16|Has expired: Runtime broken and abandoned upstream
diff --git a/games/Makefile b/games/Makefile
index 481ffe79b647..f8c3c9183115 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -307,7 +307,6 @@
SUBDIR += fxsudoku
SUBDIR += galaxis
SUBDIR += galaxyhack
- SUBDIR += galaxymage
SUBDIR += garith
SUBDIR += gbottler
SUBDIR += gbrainy
diff --git a/games/galaxymage/Makefile b/games/galaxymage/Makefile
deleted file mode 100644
index 8952a03a060a..000000000000
--- a/games/galaxymage/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-# $FreeBSD$
-
-PORTNAME= galaxymage
-PORTVERSION= 0.3.0
-PORTREVISION= 10
-CATEGORIES= games python
-MASTER_SITES= http://download.gna.org/tactics/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Open source tactical and strategic RPG
-
-LICENSE= GPLv2 # or later
-LICENSE_FILE= ${WRKSRC}/COPYRIGHT.txt
-
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Numeric/_numpy.so:${PORTSDIR}/math/py-numeric \
- ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game \
- ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl
-
-BROKEN= Does not start
-DEPRECATED= Runtime broken and abandoned upstream
-EXPIRATION_DATE= 2015-08-16
-
-USES= gettext python:run twisted
-NO_BUILD= yes
-
-PORTDATA= *
-PORTDOCS= *
-
-OPTIONS_DEFINE= DOCS
-
-post-configure:
- @${REINPLACE_CMD} -e 's@%%DATADIR%%@${DATADIR}@g' ${WRKSRC}/GalaxyMage.py ${WRKSRC}/src/Resources.py
- @${REINPLACE_CMD} -e 's@%%LOCALBASE%%@${LOCALBASE}@g' ${WRKSRC}/src/Translate.py
-
-do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/GalaxyMage.py ${STAGEDIR}${PREFIX}/bin/GalaxyMage
- @${MKDIR} ${STAGEDIR}${DATADIR}
-.for DIRE in src data
- @cd ${WRKSRC}/${DIRE} && \
- ${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${DATADIR}/{}" \; && \
- ${FIND} -E * -type f -iregex ".*\.(py|pyc|txt|TXT|ogg|wav|png|ttf|conf)" -exec ${INSTALL_DATA} "{}" \
- "${STAGEDIR}${DATADIR}/{}" \;
-.endfor
-
-.for FILE in de en fr nl sp
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${FILE}/LC_MESSAGES && \
- ${INSTALL_DATA} ${WRKSRC}/locale/${FILE}/LC_MESSAGES/* \
- ${STAGEDIR}${PREFIX}/share/locale/${FILE}/LC_MESSAGES
-.endfor
-
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC}/doc && \
- ${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${DOCSDIR}/{}" \; && \
- ${FIND} -E * -type f -iregex ".*\.(html|css|txt|png)" -exec ${INSTALL_DATA} "{}" \
- "${STAGEDIR}${DOCSDIR}/{}" \;
- @${INSTALL_DATA} ${WRKSRC}/CREDITS.txt ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/games/galaxymage/distinfo b/games/galaxymage/distinfo
deleted file mode 100644
index 08ae333fdcca..000000000000
--- a/games/galaxymage/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (galaxymage-0.3.0.tar.gz) = 33461a813729a484be2bed3a7d8684c2f984b2be2c2f4efeed1f5b5a33616aaf
-SIZE (galaxymage-0.3.0.tar.gz) = 9645868
diff --git a/games/galaxymage/files/patch-GalaxyMage.py b/games/galaxymage/files/patch-GalaxyMage.py
deleted file mode 100644
index 746707436f61..000000000000
--- a/games/galaxymage/files/patch-GalaxyMage.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- GalaxyMage.py.old Mon Jan 30 20:13:39 2006
-+++ GalaxyMage.py Mon Jan 30 20:13:51 2006
-@@ -23,7 +23,7 @@
- import os, sys
- if os.path.isdir(sys.path[0]):
- os.chdir(sys.path[0])
--sys.path.append("src")
-+sys.path.append("%%DATADIR%%")
-
- import Main
-
diff --git a/games/galaxymage/files/patch-src_Resources.py b/games/galaxymage/files/patch-src_Resources.py
deleted file mode 100644
index 89c5b5f6cf2e..000000000000
--- a/games/galaxymage/files/patch-src_Resources.py
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/Resources.py Mon Jan 30 20:17:48 2006
-+++ src/Resources.py Mon Jan 30 20:18:40 2006
-@@ -37,15 +37,15 @@
- sep = r'\\'
- base = re.sub(r'/', sep, base)
- name = re.sub(r'/', sep, name)
-- result = os.path.join("data", campaign, base, name)
-+ result = os.path.join("%%DATADIR%%", campaign, base, name)
- if os.path.exists(result):
- logger.debug('found ' + result)
- return result
-- result = os.path.join("data", "extra", base, name)
-+ result = os.path.join("%%DATADIR%%", "extra", base, name)
- if os.path.exists(result):
- logger.debug('found ' + result)
- return result
-- result = os.path.join("data", "core", base, name)
-+ result = os.path.join("%%DATADIR%%", "core", base, name)
- if os.path.exists(result):
- logger.debug('found ' + result)
- return result
diff --git a/games/galaxymage/files/patch-src_Translate.py b/games/galaxymage/files/patch-src_Translate.py
deleted file mode 100644
index f6d7d0e79781..000000000000
--- a/games/galaxymage/files/patch-src_Translate.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Translate.py Mon Jan 30 20:20:01 2006
-+++ src/Translate.py Mon Jan 30 20:21:30 2006
-@@ -4,7 +4,7 @@
- class Translate:
-
- def getLanguageDict(self,lang):
-- return gettext.translation('GalaxyMage',os.path.join(os.getcwd(),'locale'), languages=[lang])
-+ return gettext.translation('GalaxyMage',os.path.join('%%LOCALBASE%%/share/locale'), languages=[lang])
-
- def __init__(self):
- #fill our language dictionnary with each language
diff --git a/games/galaxymage/pkg-descr b/games/galaxymage/pkg-descr
deleted file mode 100644
index 9f23e6027c60..000000000000
--- a/games/galaxymage/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-GalaxyMage is a free, open-source tactical/strategic RPG for Windows,
-Linux, FreeBSD and Macintosh.
-
-A tactical RPG is a type of role-playing game where turn-based
-battles are fought on a 3D map. Examples of commercial tactical
-RPGs include Final Fantasy Tactics, Vandal Hearts, and Disgaea:
-Hour of Darkness.
-
-Our goal is to make GalaxyMage a game that is relatively simple to
-pick up and play -- you can dive right in without getting bogged
-down in the details of the battle mechanics -- but to also allow
-for a lot of character development and customization. We also intend
-to create a unique, advanced AI system that allows enemy units to
-work together as a team and employ a wide variety of strategies.
-And eventually, we plan on adding networked multiplayer support.
-
-WWW: http://www.galaxymage.org
diff --git a/games/galaxymage/pkg-plist b/games/galaxymage/pkg-plist
deleted file mode 100644
index 2e46ce4a86a1..000000000000
--- a/games/galaxymage/pkg-plist
+++ /dev/null
@@ -1,20 +0,0 @@
-bin/GalaxyMage
-share/locale/de/LC_MESSAGES/GalaxyMage.po
-share/locale/en/LC_MESSAGES/GalaxyMage.mo
-share/locale/en/LC_MESSAGES/GalaxyMage.pot
-share/locale/fr/LC_MESSAGES/GalaxyMage.mo
-share/locale/fr/LC_MESSAGES/GalaxyMage.pot
-share/locale/nl/LC_MESSAGES/GalaxyMage.mo
-share/locale/nl/LC_MESSAGES/GalaxyMage.po
-share/locale/sp/LC_MESSAGES/GalaxyMage.mo
-share/locale/sp/LC_MESSAGES/GalaxyMage.pot
-@dir %%DATADIR%%/test/data/core/units
-@dir %%DATADIR%%/test/data/core/textures
-@dir %%DATADIR%%/test/data/core/text
-@dir %%DATADIR%%/test/data/core/sounds
-@dir %%DATADIR%%/test/data/core/scenarios
-@dir %%DATADIR%%/test/data/core/music
-@dir %%DATADIR%%/test/data/core/maps
-@dir %%DATADIR%%/test/data/core/items
-@dir %%DATADIR%%/test/data/core/images
-@dir %%DATADIR%%/test/data/core/fonts