aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/py-urllib3/Makefile16
-rw-r--r--net/py-urllib3/distinfo6
-rw-r--r--net/py-urllib3/pkg-descr15
3 files changed, 23 insertions, 14 deletions
diff --git a/net/py-urllib3/Makefile b/net/py-urllib3/Makefile
index 68fdaa9b5999..974fb9ed2f68 100644
--- a/net/py-urllib3/Makefile
+++ b/net/py-urllib3/Makefile
@@ -2,24 +2,24 @@
# $FreeBSD$
PORTNAME= urllib3
-PORTVERSION= 1.20
+PORTVERSION= 1.21
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
-COMMENT= Enhance HTTP Python's standard library
+COMMENT= HTTP library with thread-safe connection pooling, file post, and more
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pysocks>=1.5.7:net/py-pysocks \
- ${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py-cryptography \
- ${PYTHON_PKGNAMEPREFIX}openssl>=16.0:security/py-openssl \
- ${PYTHON_PKGNAMEPREFIX}idna>=2.0:dns/py-idna
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}idna>=2.0:dns/py-idna \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=16.0:security/py-openssl \
+ ${PYTHON_PKGNAMEPREFIX}pysocks>=1.5.7:net/py-pysocks
-USES= python
-USE_PYTHON= distutils autoplist
+USES= python
+USE_PYTHON= autoplist distutils
NO_ARCH= yes
SUB_FILES= pkg-message
diff --git a/net/py-urllib3/distinfo b/net/py-urllib3/distinfo
index 39dacf5a6a42..73ccf61b692e 100644
--- a/net/py-urllib3/distinfo
+++ b/net/py-urllib3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1484903509
-SHA256 (urllib3-1.20.tar.gz) = 97ef2b6e2878d84c0126b9f4e608e37a951ca7848e4855a7f7f4437d5c34a72f
-SIZE (urllib3-1.20.tar.gz) = 201873
+TIMESTAMP = 1493220249
+SHA256 (urllib3-1.21.tar.gz) = d0f08f1472754890c8b228106eb831a7a68c93565bd0818936c30bb839913647
+SIZE (urllib3-1.21.tar.gz) = 223387
diff --git a/net/py-urllib3/pkg-descr b/net/py-urllib3/pkg-descr
index 7d037dcc1191..826f9b78b36b 100644
--- a/net/py-urllib3/pkg-descr
+++ b/net/py-urllib3/pkg-descr
@@ -1,4 +1,13 @@
-Urllib3 is an HTTP library with thread-safe connection pooling, and file
-post.
+urllib3 is a powerful, sanity-friendly HTTP client for Python. Much of the
+Python ecosystem already uses urllib3 and you should too. urllib3 brings many
+critical features that are missing from the Python standard libraries:
+- Thread safety.
+- Connection pooling.
+- Client-side SSL/TLS verification.
+- File uploads with multipart encoding.
+- Helpers for retrying requests and dealing with HTTP redirects.
+- Support for gzip and deflate encoding.
+- Proxy support for HTTP and SOCKS.
+- 100% test coverage.
-WWW: https://github.com/shazow/urllib3/
+WWW: https://pypi.python.org/pypi/urllib3