aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING11
-rw-r--r--dns/mydns-ng/Makefile57
-rw-r--r--dns/mydns-ng/pkg-descr2
3 files changed, 38 insertions, 32 deletions
diff --git a/UPDATING b/UPDATING
index cb809af3cabd..a66db6784b5f 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,17 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20140724:
+ AFFECTS: users of dns/mydns-ng
+ AUTHOR: danilo@FreeBSD.org
+
+ The dns/mydns-ng port no longer has the suffix (-mysql|-pgsql). Before
+ you update this port the old one must be removed:
+
+ pkg remove mydns-ng-mysql
+ or
+ pkg remove mysql-ng-pgsql
+
20140723:
AFFECTS: users of devel/libevent
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
index 467c50fda562..4c003300da9c 100644
--- a/dns/mydns-ng/Makefile
+++ b/dns/mydns-ng/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mydns-ng
PORTVERSION= 1.2.8.31
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= dns databases
MASTER_SITES= SF/${PORTNAME}/mydns/${PORTVERSION}
DISTNAME= mydns-${PORTVERSION}
@@ -11,6 +11,8 @@ DISTNAME= mydns-${PORTVERSION}
MAINTAINER= gaod@hychen.org
COMMENT= Next Generation DNS Server for sql based DNS services
+LICENSE= GPLv2
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc
USES= iconv
@@ -20,42 +22,35 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
INFO= mydns
DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART.mysql QUICKSTART.postgres README TODO
-OPTIONS_DEFINE= DOCS PGSQL ALIAS SSL NLS
-OPTIONS_DEFAULT= ALIAS
+OPTIONS_DEFINE= DOCS ALIAS SSL NLS
+OPTIONS_SINGLE= DATABASE
+OPTIONS_SINGLE_DATABASE= PGSQL MYSQL
+OPTIONS_DEFAULT= ALIAS MYSQL
ALIAS_DESC= Server side aliasas
ALIAS_CONFIGURE_ENABLE= alias
+OPTIONS_SUB= yes
+
+ALIAS_CONFIGURE_ENABLE= alias
-.include <bsd.port.options.mk>
+SSL_USE= OPENSSL=yes
+SSL_CONFIGURE_ON= --with-openssl \
+ --with-openssl-include=${OPENSSLINC} \
+ --with-openssl-lib=${OPENSSLLIB}
-.if ${PORT_OPTIONS:MSSL}
-USE_OPENSSL=yes
-CONFIGURE_ARGS+=--with-openssl \
- --with-openssl-include=${OPENSSLINC} \
- --with-openssl-lib=${OPENSSLLIB}
-.endif
+PGSQL_USE= PGSQL=yes
+PGSQL_CONFIGURE_ON= --with-pgsql \
+ --with-pgsql-include=${LOCALBASE}/include \
+ --with-pgsql-lib=${LOCALBASE}/lib
+PGSQL_CONFIGURE_OFF= --without-pgsql
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-CONFIGURE_ARGS+=--without-mysql \
- --with-pgsql-include=${LOCALBASE}/include \
- --with-pgsql-lib=${LOCALBASE}/lib
-PKGNAMESUFFIX= -pgsql
-.else
-CONFIGURE_ARGS+=--without-pgsql \
- --with-mysql-include=${LOCALBASE}/include/mysql \
- --with-mysql-lib=${LOCALBASE}/lib/mysql
-PKGNAMESUFFIX= -mysql
-USE_MYSQL= yes
-.endif
+MYSQL_USE= MYSQL=yes
+MYSQL_CONFIGURE_ON= --with-mysql \
+ --with-mysql-include=${LOCALBASE}/include/mysql \
+ --with-mysql-lib=${LOCALBASE}/lib/mysql
+MYSQL_CONFIGURE_OFF= --without-mysql
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-CONFIGURE_ARGS+=--with-included-gettext
-USES+= gettext
-PLIST_SUB+= NLS=""
-.endif
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/contrib
diff --git a/dns/mydns-ng/pkg-descr b/dns/mydns-ng/pkg-descr
index da174e146309..e4f596918c6e 100644
--- a/dns/mydns-ng/pkg-descr
+++ b/dns/mydns-ng/pkg-descr
@@ -10,4 +10,4 @@ produced by Don Moore.
- 12-May-2004 Don Moore <bboy@bboy.net>
- 23-January-2009 Howard Wilkinsin <howard@cohtech.com>
-WWW: http://sourceforge.net/projects/mydns-ng/
+WWW: http://sourceforge.net/projects/mydns-ng/