aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/postfix-current/Makefile25
-rw-r--r--mail/postfix/Makefile27
-rw-r--r--mail/postfix1/Makefile7
-rw-r--r--mail/postfix21/scripts/configure.postfix17
-rw-r--r--mail/postfix22/scripts/configure.postfix14
-rw-r--r--mail/postfix23/Makefile27
-rw-r--r--mail/postfix24/Makefile27
-rw-r--r--mail/postfix25/Makefile27
-rw-r--r--mail/postfix26/Makefile27
-rw-r--r--mail/postfix27/Makefile27
-rw-r--r--mail/postfix28/Makefile27
11 files changed, 25 insertions, 227 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 666aa662c3a9..f9948db705b7 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -30,7 +30,6 @@ USE_RC_SUBR= postfix.sh
OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
- SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" off \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" off \
DOVECOT "Dovecot SASL authentication method" off \
SASLKRB "If your SASL req. Kerberos select this option" off \
@@ -91,17 +90,8 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
POSTFIX_CCARGS+= -DNO_PCRE
.endif
-.if defined(WITH_SASL)
-.if defined(WITH_SASL2) || defined(WITH_DOVECOT)
-BROKEN= Select only one SASL authentication method
-.endif
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl1
-POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
-.endif
-
.if defined(WITH_SASL2)
-.if defined(WITH_SASL) || defined(WITH_DOVECOT)
+.if defined(WITH_DOVECOT)
BROKEN= Select only one SASL authentication method
.endif
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
@@ -110,7 +100,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
.if defined(WITH_DOVECOT)
-.if defined(WITH_SASL) || defined(WITH_SASL2)
+.if defined(WITH_SASL2)
BROKEN= Select only one SASL authentication method
.endif
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
@@ -204,17 +194,6 @@ READMEDIR=${PREFIX}/share/doc/postfix
SUB_LIST+= REQUIRE="${_REQUIRE}"
pre-patch:
-.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-.endif
.if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
@if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
${ECHO_MSG}; \
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 0bd2cf01c268..4b344d2e7ccb 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -32,7 +32,7 @@ USE_RC_SUBR= postfix.sh
# back compat pull in settings from POSTFIX_OPTIONS for convenience when
# make config is run (happens first time port is built, too)
-.for o in SASL SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
+.for o in SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
STATUS_${o}=off
.endfor
.if defined(POSTFIX_OPTIONS)
@@ -42,7 +42,6 @@ STATUS_${o}=on
.endif
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
- SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" ${STATUS_SASL} \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" ${STATUS_SASL2} \
DOVECOT "Dovecot SASL authentication method" off \
SASLKRB "If your SASL req. Kerberos select this option" ${STATUS_SASLKRB} \
@@ -104,17 +103,8 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
POSTFIX_CCARGS+= -DNO_PCRE
.endif
-.if defined(WITH_SASL)
-.if defined(WITH_SASL2) || defined(WITH_DOVECOT)
-BROKEN= Select only one SASL authentication method
-.endif
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl1
-POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
-.endif
-
.if defined(WITH_SASL2)
-.if defined(WITH_SASL) || defined(WITH_DOVECOT)
+.if defined(WITH_DOVECOT)
BROKEN= Select only one SASL authentication method
.endif
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
@@ -123,7 +113,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
.if defined(WITH_DOVECOT)
-.if defined(WITH_SASL) || defined(WITH_SASL2)
+.if defined(WITH_SASL2)
BROKEN= Select only one SASL authentication method
.endif
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
@@ -237,17 +227,6 @@ pre-patch:
@sleep 10
.endif
-.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-.endif
.if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
@if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
${ECHO_MSG}; \
diff --git a/mail/postfix1/Makefile b/mail/postfix1/Makefile
index 1d3c66e69b51..485dfe3ccbcf 100644
--- a/mail/postfix1/Makefile
+++ b/mail/postfix1/Makefile
@@ -35,7 +35,6 @@ USE_RC_SUBR= postfix.sh
PATCH_STRIP= -p1
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
- SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" off \
TLS "Enable SSL and TLS support" off \
DB3 "Berkeley DB3 (required if SASL built with DB3)" off \
MYSQL "MySQL maps lookups" off \
@@ -80,12 +79,6 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
POSTFIX_CCARGS+= -DNO_PCRE
.endif
-.if defined(WITH_SASL)
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I${LOCALBASE}/include
-POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
-.endif
-
.if defined(WITH_TLS)
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
MAN8+= tlsmgr.8
diff --git a/mail/postfix21/scripts/configure.postfix b/mail/postfix21/scripts/configure.postfix
index 9711c83836c6..509dbf78fad4 100644
--- a/mail/postfix21/scripts/configure.postfix
+++ b/mail/postfix21/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix21/scripts/Attic/configure.postfix,v 1.64 2006-10-07 18:23:11 mnag Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix21/scripts/Attic/configure.postfix,v 1.65 2007-04-14 16:45:08 mnag Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -20,7 +20,6 @@ if [ -z "${BATCH}" ]; then
--checklist "\n\
Please select desired options:" -1 -1 16 \
NOPCRE "DISABLE Perl Compatible Regular Expressions" "$status_NOPCRE" \
-SASL "Cyrus SASLv1 (Simple Authentication and Security Layer)" "$status_SASL" \
SASL2 "Cyrus SASLv2 (Simple Authentication and Security Layer)" "$status_SASL2" \
SASLKRB "If your SASL requires Kerberos select this option" "$status_SASLKRB" \
SASLKRB5 "If your SASL requires Kerberos5 select this option" "$status_SASLKRB5" \
@@ -74,20 +73,6 @@ while [ "$1" ]; do
echo "NOPCRE_SUFFIX= +nopcre"
SUB_NOPCRE=""
;;
- SASL)
- echo "LIB_DEPENDS+= sasl.8:\${PORTSDIR}/security/cyrus-sasl"
- echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include -I\${LOCALBASE}/include/sasl1"
- echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lsasl -lpam -lcrypt"
- echo "SASL_SUFFIX= +sasl"
- if [ -f ${PREFIX}/lib/libsasl.a ]; then
- if nm ${PREFIX}/lib/libsasl.a | grep -wq "mysql_verify_password"; then
- echo "USE_MYSQL=YES"
- echo "POSTFIX_CCARGS+= -DHAS_MYSQL -I\${LOCALBASE}/include/mysql"
- echo "POSTFIX_AUXLIBS+= \${LOCALBASE}/lib/mysql/libmysqlclient.a -lm -lz"
- fi
- fi
- SUB_SASL=""
- ;;
SASL2)
echo "LIB_DEPENDS+= sasl2.2:\${PORTSDIR}/security/cyrus-sasl2"
echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include -I\${LOCALBASE}/include/sasl"
diff --git a/mail/postfix22/scripts/configure.postfix b/mail/postfix22/scripts/configure.postfix
index 59a10a83dc66..72fe0afd9e5d 100644
--- a/mail/postfix22/scripts/configure.postfix
+++ b/mail/postfix22/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.75 2006-04-22 14:04:52 mnag Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.76 2007-04-14 16:45:08 mnag Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -20,7 +20,6 @@ if [ -z "${BATCH}" ]; then
--checklist "\n\
Please select desired options:" -1 -1 16 \
NOPCRE "DISABLE Perl Compatible Regular Expressions" "$status_NOPCRE" \
-SASL "Cyrus SASLv1 (Simple Authentication and Security Layer)" "$status_SASL" \
SASL2 "Cyrus SASLv2 (Simple Authentication and Security Layer)" "$status_SASL2" \
SASLKRB "If your SASL requires Kerberos select this option" "$status_SASLKRB" \
SASLKRB5 "If your SASL requires Kerberos5 select this option" "$status_SASLKRB5" \
@@ -70,17 +69,6 @@ while [ "$1" ]; do
echo "NOPCRE_SUFFIX= +nopcre"
SUB_NOPCRE=""
;;
- SASL)
- echo "LIB_DEPENDS+= sasl.8:\${PORTSDIR}/security/cyrus-sasl"
- echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include -I\${LOCALBASE}/include/sasl1"
- echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lsasl -lpam -lcrypt"
- echo "SASL_SUFFIX= +sasl"
- if [ -f ${LOCALBASE}/lib/libsasl.a ]; then
- if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | grep -wq "mysql_init"; then
- SASL_USE_MYSQL="YES"
- fi
- fi
- ;;
SASL2)
echo "LIB_DEPENDS+= sasl2.2:\${PORTSDIR}/security/cyrus-sasl2"
echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include -I\${LOCALBASE}/include/sasl"
diff --git a/mail/postfix23/Makefile b/mail/postfix23/Makefile
index 7fba416cb363..149602d2f90e 100644
--- a/mail/postfix23/Makefile
+++ b/mail/postfix23/Makefile
@@ -32,7 +32,7 @@ USE_RC_SUBR= postfix.sh
# back compat pull in settings from POSTFIX_OPTIONS for convenience when
# make config is run (happens first time port is built, too)
-.for o in SASL SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
+.for o in SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
STATUS_${o}=off
.endfor
.if defined(POSTFIX_OPTIONS)
@@ -42,7 +42,6 @@ STATUS_${o}=on
.endif
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
- SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" ${STATUS_SASL} \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" ${STATUS_SASL2} \
DOVECOT "Dovecot SASL authentication method" off \
SASLKRB "If your SASL req. Kerberos select this option" ${STATUS_SASLKRB} \
@@ -103,17 +102,8 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
POSTFIX_CCARGS+= -DNO_PCRE
.endif
-.if defined(WITH_SASL)
-.if defined(WITH_SASL2) || defined(WITH_DOVECOT)
-BROKEN= Select only one SASL authentication method
-.endif
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl1
-POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
-.endif
-
.if defined(WITH_SASL2)
-.if defined(WITH_SASL) || defined(WITH_DOVECOT)
+.if defined(WITH_DOVECOT)
BROKEN= Select only one SASL authentication method
.endif
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
@@ -122,7 +112,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
.if defined(WITH_DOVECOT)
-.if defined(WITH_SASL) || defined(WITH_SASL2)
+.if defined(WITH_SASL2)
BROKEN= Select only one SASL authentication method
.endif
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
@@ -236,17 +226,6 @@ pre-patch:
@sleep 10
.endif
-.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-.endif
.if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
@if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
${ECHO_MSG}; \
diff --git a/mail/postfix24/Makefile b/mail/postfix24/Makefile
index 0bd2cf01c268..4b344d2e7ccb 100644
--- a/mail/postfix24/Makefile
+++ b/mail/postfix24/Makefile
@@ -32,7 +32,7 @@ USE_RC_SUBR= postfix.sh
# back compat pull in settings from POSTFIX_OPTIONS for convenience when
# make config is run (happens first time port is built, too)
-.for o in SASL SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
+.for o in SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
STATUS_${o}=off
.endfor
.if defined(POSTFIX_OPTIONS)
@@ -42,7 +42,6 @@ STATUS_${o}=on
.endif
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
- SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" ${STATUS_SASL} \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" ${STATUS_SASL2} \
DOVECOT "Dovecot SASL authentication method" off \
SASLKRB "If your SASL req. Kerberos select this option" ${STATUS_SASLKRB} \
@@ -104,17 +103,8 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
POSTFIX_CCARGS+= -DNO_PCRE
.endif
-.if defined(WITH_SASL)
-.if defined(WITH_SASL2) || defined(WITH_DOVECOT)
-BROKEN= Select only one SASL authentication method
-.endif
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl1
-POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
-.endif
-
.if defined(WITH_SASL2)
-.if defined(WITH_SASL) || defined(WITH_DOVECOT)
+.if defined(WITH_DOVECOT)
BROKEN= Select only one SASL authentication method
.endif
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
@@ -123,7 +113,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
.if defined(WITH_DOVECOT)
-.if defined(WITH_SASL) || defined(WITH_SASL2)
+.if defined(WITH_SASL2)
BROKEN= Select only one SASL authentication method
.endif
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
@@ -237,17 +227,6 @@ pre-patch:
@sleep 10
.endif
-.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-.endif
.if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
@if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
${ECHO_MSG}; \
diff --git a/mail/postfix25/Makefile b/mail/postfix25/Makefile
index 0bd2cf01c268..4b344d2e7ccb 100644
--- a/mail/postfix25/Makefile
+++ b/mail/postfix25/Makefile
@@ -32,7 +32,7 @@ USE_RC_SUBR= postfix.sh
# back compat pull in settings from POSTFIX_OPTIONS for convenience when
# make config is run (happens first time port is built, too)
-.for o in SASL SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
+.for o in SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
STATUS_${o}=off
.endfor
.if defined(POSTFIX_OPTIONS)
@@ -42,7 +42,6 @@ STATUS_${o}=on
.endif
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
- SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" ${STATUS_SASL} \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" ${STATUS_SASL2} \
DOVECOT "Dovecot SASL authentication method" off \
SASLKRB "If your SASL req. Kerberos select this option" ${STATUS_SASLKRB} \
@@ -104,17 +103,8 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
POSTFIX_CCARGS+= -DNO_PCRE
.endif
-.if defined(WITH_SASL)
-.if defined(WITH_SASL2) || defined(WITH_DOVECOT)
-BROKEN= Select only one SASL authentication method
-.endif
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl1
-POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
-.endif
-
.if defined(WITH_SASL2)
-.if defined(WITH_SASL) || defined(WITH_DOVECOT)
+.if defined(WITH_DOVECOT)
BROKEN= Select only one SASL authentication method
.endif
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
@@ -123,7 +113,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
.if defined(WITH_DOVECOT)
-.if defined(WITH_SASL) || defined(WITH_SASL2)
+.if defined(WITH_SASL2)
BROKEN= Select only one SASL authentication method
.endif
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
@@ -237,17 +227,6 @@ pre-patch:
@sleep 10
.endif
-.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-.endif
.if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
@if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
${ECHO_MSG}; \
diff --git a/mail/postfix26/Makefile b/mail/postfix26/Makefile
index 0bd2cf01c268..4b344d2e7ccb 100644
--- a/mail/postfix26/Makefile
+++ b/mail/postfix26/Makefile
@@ -32,7 +32,7 @@ USE_RC_SUBR= postfix.sh
# back compat pull in settings from POSTFIX_OPTIONS for convenience when
# make config is run (happens first time port is built, too)
-.for o in SASL SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
+.for o in SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
STATUS_${o}=off
.endfor
.if defined(POSTFIX_OPTIONS)
@@ -42,7 +42,6 @@ STATUS_${o}=on
.endif
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
- SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" ${STATUS_SASL} \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" ${STATUS_SASL2} \
DOVECOT "Dovecot SASL authentication method" off \
SASLKRB "If your SASL req. Kerberos select this option" ${STATUS_SASLKRB} \
@@ -104,17 +103,8 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
POSTFIX_CCARGS+= -DNO_PCRE
.endif
-.if defined(WITH_SASL)
-.if defined(WITH_SASL2) || defined(WITH_DOVECOT)
-BROKEN= Select only one SASL authentication method
-.endif
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl1
-POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
-.endif
-
.if defined(WITH_SASL2)
-.if defined(WITH_SASL) || defined(WITH_DOVECOT)
+.if defined(WITH_DOVECOT)
BROKEN= Select only one SASL authentication method
.endif
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
@@ -123,7 +113,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
.if defined(WITH_DOVECOT)
-.if defined(WITH_SASL) || defined(WITH_SASL2)
+.if defined(WITH_SASL2)
BROKEN= Select only one SASL authentication method
.endif
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
@@ -237,17 +227,6 @@ pre-patch:
@sleep 10
.endif
-.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-.endif
.if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
@if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
${ECHO_MSG}; \
diff --git a/mail/postfix27/Makefile b/mail/postfix27/Makefile
index 0bd2cf01c268..4b344d2e7ccb 100644
--- a/mail/postfix27/Makefile
+++ b/mail/postfix27/Makefile
@@ -32,7 +32,7 @@ USE_RC_SUBR= postfix.sh
# back compat pull in settings from POSTFIX_OPTIONS for convenience when
# make config is run (happens first time port is built, too)
-.for o in SASL SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
+.for o in SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
STATUS_${o}=off
.endfor
.if defined(POSTFIX_OPTIONS)
@@ -42,7 +42,6 @@ STATUS_${o}=on
.endif
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
- SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" ${STATUS_SASL} \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" ${STATUS_SASL2} \
DOVECOT "Dovecot SASL authentication method" off \
SASLKRB "If your SASL req. Kerberos select this option" ${STATUS_SASLKRB} \
@@ -104,17 +103,8 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
POSTFIX_CCARGS+= -DNO_PCRE
.endif
-.if defined(WITH_SASL)
-.if defined(WITH_SASL2) || defined(WITH_DOVECOT)
-BROKEN= Select only one SASL authentication method
-.endif
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl1
-POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
-.endif
-
.if defined(WITH_SASL2)
-.if defined(WITH_SASL) || defined(WITH_DOVECOT)
+.if defined(WITH_DOVECOT)
BROKEN= Select only one SASL authentication method
.endif
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
@@ -123,7 +113,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
.if defined(WITH_DOVECOT)
-.if defined(WITH_SASL) || defined(WITH_SASL2)
+.if defined(WITH_SASL2)
BROKEN= Select only one SASL authentication method
.endif
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
@@ -237,17 +227,6 @@ pre-patch:
@sleep 10
.endif
-.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-.endif
.if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
@if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
${ECHO_MSG}; \
diff --git a/mail/postfix28/Makefile b/mail/postfix28/Makefile
index 0bd2cf01c268..4b344d2e7ccb 100644
--- a/mail/postfix28/Makefile
+++ b/mail/postfix28/Makefile
@@ -32,7 +32,7 @@ USE_RC_SUBR= postfix.sh
# back compat pull in settings from POSTFIX_OPTIONS for convenience when
# make config is run (happens first time port is built, too)
-.for o in SASL SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
+.for o in SASL2 SASLKRB SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
STATUS_${o}=off
.endfor
.if defined(POSTFIX_OPTIONS)
@@ -42,7 +42,6 @@ STATUS_${o}=on
.endif
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
- SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" ${STATUS_SASL} \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" ${STATUS_SASL2} \
DOVECOT "Dovecot SASL authentication method" off \
SASLKRB "If your SASL req. Kerberos select this option" ${STATUS_SASLKRB} \
@@ -104,17 +103,8 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
POSTFIX_CCARGS+= -DNO_PCRE
.endif
-.if defined(WITH_SASL)
-.if defined(WITH_SASL2) || defined(WITH_DOVECOT)
-BROKEN= Select only one SASL authentication method
-.endif
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl1
-POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
-.endif
-
.if defined(WITH_SASL2)
-.if defined(WITH_SASL) || defined(WITH_DOVECOT)
+.if defined(WITH_DOVECOT)
BROKEN= Select only one SASL authentication method
.endif
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
@@ -123,7 +113,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
.if defined(WITH_DOVECOT)
-.if defined(WITH_SASL) || defined(WITH_SASL2)
+.if defined(WITH_SASL2)
BROKEN= Select only one SASL authentication method
.endif
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
@@ -237,17 +227,6 @@ pre-patch:
@sleep 10
.endif
-.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-.endif
.if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
@if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
${ECHO_MSG}; \