aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING9
-rw-r--r--www/apache22/Makefile6
-rw-r--r--www/apache22/Makefile.doc26
-rw-r--r--www/apache22/Makefile.modules55
-rw-r--r--www/apache22/distinfo9
-rw-r--r--www/apache22/files/patch-docs_conf_httpd.conf.in26
-rw-r--r--www/apache22/files/patch-srclib-apr-network_io-unix-multicast.c23
7 files changed, 58 insertions, 96 deletions
diff --git a/UPDATING b/UPDATING
index ee471e5d0f7d..8ab735fe2231 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,15 @@ You should get into the habit of checking this file for changes each
time you update your ports collection, before attempting any port
upgrades.
+20080120:
+ AFFECTS: users of www/apache22
+ AUTHOR: clement@FreeBSD.org
+
+ BDB framework provided by bsd.databases.mk is now used by www/apache22
+ port. WITH_BERKELEYDB knob is deprecated in favor of WITH_BDB and
+ WITH_BDB_VER/WITH_BDB_BASE, see documentation for more details.
+ ('make show-options').
+
20080118:
AFFECTS: users of net/freeradius
AUTHOR: David Wood <david@wood2.org.uk>
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 09c371e3f38c..58c47ea5ef5e 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= apache
-PORTVERSION= 2.2.6
-PORTREVISION= 3
+PORTVERSION= 2.2.8
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
@@ -60,7 +59,8 @@ OPTIONS= \
PGSQL "Enable PostgreSQL support for apr-dbd" Off \
SQLITE "Enable SQLite support for apr-dbd" Off \
IPV6 "Enable IPv6 support" On \
- PCRE_FROM_PORTS "Use devel/pcre instead of bundled one" Off
+ PCRE_FROM_PORTS "Use devel/pcre instead of bundled one" Off \
+ BDB "Enable BerkeleyDB dbm" Off
.include "${APACHEDIR}/Makefile.options"
.endif
diff --git a/www/apache22/Makefile.doc b/www/apache22/Makefile.doc
index 3bb566c0ab84..602502d384c1 100644
--- a/www/apache22/Makefile.doc
+++ b/www/apache22/Makefile.doc
@@ -9,11 +9,16 @@
#
## Available knobs:
+## WITHOUT_APACHE_OPTIONS: Don't use OPTIONS and will allow you to use
+## those knobs directly to select modules.
+## Knobs with (*) are working only if
+## WITHOUT_APACHE_OPTIONS is defined.
+##
## By default, modules are compiled as dynamically loadable modules (DSO).
##
## Modules knobs philosophy:
## Modules are split in categories, "make show-categories" shows you
-## which modules they contain. You can enable/disable/customize a category:
+## which modules they contain. You can enable/disable/customize a category (*):
## - To enable a category: WITH_<CATEGORY>_MODULES=yes
## [WITH_PROXY_MODULES=yes]
## - To disable a category: WITHOUT_<CATEGORY>_MODULES=yes
@@ -34,24 +39,25 @@
## WITH_IPV6_V6ONLY: Don't allow IPv6 sockets to handle IPv4
## connections
## WITHOUT_SSL: Disable SSL support
-## WITH_THREADS: Enable threads support !! USE IT WITH CARE !!
+## WITH_THREADS: Enable threads support
## WITH_DBM: Choose your DBM: bdb (Berkeley DB), gdbm or
## ndbm (default)
-## WITH_BERKELEYDB: Choose your BerkeleyDB version: db2, db3,
-## db4, db41, db42, db43, db44, db45, db46
-## or FreeBSD (1.85, default)
+## WITH_BDB: Define to select bdb via bsd.databases.mk
+## desired version may be set with
+## WITH_BDB_VER or APACHE22_WITH_BDB_VER
+## WITH_BDB_BASE: Define to use bdb from base (1.85)
## WITH_STATIC_SUPPORT: Build statically linked support binaries
## WITH_STATIC_APACHE: Build a static version of httpd (implies
## WITH_STATIC_MODULES)
## WITH_ALL_STATIC_MODULES: All modules will be statically linked.
-## WITH_STATIC_MODULES: List of modules to build modules statics
+## WITH_STATIC_MODULES (*): List of modules to build modules statics
## (usefull for slave ports)
## (They must be already enabled (i.e.
## WITH_MODULES or with default configuration
## use 'make show-modules', to check if they are
## enabled)
-## WITH_MODULES: List of modules you choose
-## WITHOUT_MODULES: Disable selected modules
+## WITH_MODULES (*): List of modules you choose
+## WITHOUT_MODULES (*): Disable selected modules
## WITH_SUEXEC: Enable suExec support
## SUEXEC_DOCROOT: SuExec root directory
## SUEXEC_USERDIR: User subdirectory (default public_html)
@@ -70,14 +76,14 @@
##
## Optionnal patches:
## WITH_EXPERIMENTAL_PATCHES Add performance patches (generally backported
-## from apr/httpd CVS)
+## from apr/httpd SVN repositories)
##
## Available make targets:
## show-options: prints this message
## show-modules: prints list of available modules
## show-categories: prints list of modules sorted by category
##
-## Examples:
+## Examples (*):
## make WITH_STATIC_MODULES="ssl rewrite include" WITH_EXPERIMENTAL_MODULES=yes \
## WITH_CUSTOM_AUTH="auth auth_dbm"
## make WITHOUT_MODULES="access speling status" WITH_PROXY_MODULES=yes
diff --git a/www/apache22/Makefile.modules b/www/apache22/Makefile.modules
index 0cc0b4698221..b4e5334f70c2 100644
--- a/www/apache22/Makefile.modules
+++ b/www/apache22/Makefile.modules
@@ -76,11 +76,18 @@ PLIST_SUB+= PREFORK="@comment " WORKER="@comment " EVENT="@comment "
# xDBM section
#
-.if !defined(WITH_DBM) && defined(WITH_BERKELEYDB)
+.if !defined(WITH_DBM)
+. if defined(WITH_BDB) || defined(WITH_BDB_BASE) || defined(WITH_BERKELEYDB)
WITH_DBM=bdb
+. endif
.endif
-.if defined(WITH_DBM) && !defined(WITH_BERKELEYDB)
-WITH_BERKELEYDB= FreeBSD
+
+.if defined(WITH_BERKELEYDB)
+. if ${WITH_BERKELEYDB} == "FreeBSD"
+ WITH_BDB_BASE=YES
+. else
+ WITH_BDB_VER=${WITH_BERKELEYDB:S/db//}
+. endif
.endif
.if defined(WITH_DBM)
@@ -90,47 +97,13 @@ CONFIGURE_ARGS+= --with-dbm=sdbm
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+= --with-gdbm=${LOCALBASE}
. elif ${WITH_DBM:L} == "db" || ${WITH_DBM:L} == "bdb"
-. if ${WITH_BERKELEYDB} == "FreeBSD"
+. if defined(WITH_BDB_BASE)
CONFIGURE_ARGS+= --with-dbm=db185 \
--with-berkeley-db=/usr
-. elif ${WITH_BERKELEYDB} == "db2"
-LIB_DEPENDS+= db2:${PORTSDIR}/databases/db2
-CONFIGURE_ARGS+= --with-dbm=db2 \
- --with-berkeley-db=${LOCALBASE}
-. elif ${WITH_BERKELEYDB} == "db3"
-LIB_DEPENDS+= db3:${PORTSDIR}/databases/db3
-CONFIGURE_ARGS+= --with-dbm=db3 \
- --with-berkeley-db=${LOCALBASE}
-. elif ${WITH_BERKELEYDB} == "db4"
-LIB_DEPENDS+= db4:${PORTSDIR}/databases/db4
-CONFIGURE_ARGS+= --with-dbm=db4 \
- --with-berkeley-db=${LOCALBASE}
-. elif ${WITH_BERKELEYDB} == "db41"
-LIB_DEPENDS+= db41:${PORTSDIR}/databases/db41
-CONFIGURE_ARGS+= --with-dbm=db41 \
+. else
+USE_BDB= yes
+CONFIGURE_ARGS+= --with-dbm=db${BDB_VER:S/40/4/} \
--with-berkeley-db=${LOCALBASE}
-. elif ${WITH_BERKELEYDB} == "db42"
-LIB_DEPENDS+= db-4.2:${PORTSDIR}/databases/db42
-CONFIGURE_ARGS+= --with-dbm=db42 \
- --with-berkeley-db=${LOCALBASE}/include:${LOCALBASE}/lib/db42
-. elif ${WITH_BERKELEYDB} == "db43"
-LIB_DEPENDS+= db-4.3:${PORTSDIR}/databases/db43
-CONFIGURE_ARGS+= --with-dbm=db43 \
- --with-berkeley-db=${LOCALBASE}/include:${LOCALBASE}/lib/db43
-. elif ${WITH_BERKELEYDB} == "db44"
-LIB_DEPENDS+= db-4.4:${PORTSDIR}/databases/db44
-CONFIGURE_ARGS+= --with-dbm=db44 \
- --with-berkeley-db=${LOCALBASE}/include:${LOCALBASE}/lib/db44
-. elif ${WITH_BERKELEYDB} == "db45"
-LIB_DEPENDS+= db-4.5:${PORTSDIR}/databases/db45
-CONFIGURE_ARGS+= --with-dbm=db45 \
- --with-berkeley-db=${LOCALBASE}/include:${LOCALBASE}/lib/db45
-. elif ${WITH_BERKELEYDB} == "db46"
-LIB_DEPENDS+= db-4.6:${PORTSDIR}/databases/db46
-CONFIGURE_ARGS+= --with-dbm=db46 \
- --with-berkeley-db=${LOCALBASE}/include:${LOCALBASE}/lib/db46
-. else
-IGNORE= "Unknown Berkeley DB version"
. endif
. else
IGNORE= "Unknown DBM"
diff --git a/www/apache22/distinfo b/www/apache22/distinfo
index 2da41d6f245f..a703e0ebea62 100644
--- a/www/apache22/distinfo
+++ b/www/apache22/distinfo
@@ -1,6 +1,3 @@
-MD5 (apache22/httpd-2.2.6.tar.bz2) = 203bea91715064f0c787f6499d33a377
-SHA256 (apache22/httpd-2.2.6.tar.bz2) = f27cd9df50a2acd9df8f37520f62f6ce51758689d425ead5883e75ff5ed6548c
-SIZE (apache22/httpd-2.2.6.tar.bz2) = 4717066
-MD5 (apache22/apr_dbd_mysql.rev-93.c) = a9914273d9f27b3c1fbf9bb50e10627f
-SHA256 (apache22/apr_dbd_mysql.rev-93.c) = 79893740a58c96fba6e04f800e950ec42d8128e034056ff8a5770e0d3acc4919
-SIZE (apache22/apr_dbd_mysql.rev-93.c) = 49110
+MD5 (apache22/httpd-2.2.8.tar.bz2) = 76d2598a4797163d07cd50e5304aa7cd
+SHA256 (apache22/httpd-2.2.8.tar.bz2) = 2ad8d0db1e478838ba88a0ddaf538c7150027d937b017739fdcb3fabb96ebd39
+SIZE (apache22/httpd-2.2.8.tar.bz2) = 4799055
diff --git a/www/apache22/files/patch-docs_conf_httpd.conf.in b/www/apache22/files/patch-docs_conf_httpd.conf.in
index 728ed64ecc5f..8067ad7cbd1b 100644
--- a/www/apache22/files/patch-docs_conf_httpd.conf.in
+++ b/www/apache22/files/patch-docs_conf_httpd.conf.in
@@ -1,5 +1,5 @@
---- docs/conf/httpd.conf.in.orig Sun Oct 30 19:33:41 2005
-+++ docs/conf/httpd.conf.in Sun Oct 30 19:37:09 2005
+--- docs/conf/httpd.conf.in.orig 2007-12-21 12:43:00.000000000 +0100
++++ docs/conf/httpd.conf.in 2008-01-19 21:36:47.000000000 +0100
@@ -63,8 +63,8 @@
# It is usually good practice to create a dedicated user and group for
# running httpd, as with most system services.
@@ -8,10 +8,10 @@
-Group daemon
+User %%WWWOWN%%
+Group %%WWWGRP%%
+
</IfModule>
</IfModule>
-
-@@ -112,7 +112,6 @@
+@@ -113,7 +113,6 @@
# features.
#
<Directory />
@@ -19,32 +19,32 @@
AllowOverride None
Order deny,allow
Deny from all
-@@ -182,7 +181,7 @@
+@@ -184,7 +183,7 @@
# logged here. If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
--ErrorLog @rel_logfiledir@/error_log
-+ErrorLog @rel_logfiledir@/httpd-error.log
+-ErrorLog "@rel_logfiledir@/error_log"
++ErrorLog "@rel_logfiledir@/httpd-error.log"
#
# LogLevel: Control the number of messages logged to the error_log.
-@@ -211,13 +210,13 @@
+@@ -213,13 +212,13 @@
# define per-<VirtualHost> access logfiles, transactions will be
# logged therein and *not* in this file.
#
-- CustomLog @rel_logfiledir@/access_log common
-+ #CustomLog @rel_logfiledir@/httpd-access.log common
+- CustomLog "@rel_logfiledir@/access_log" common
++ #CustomLog "@rel_logfiledir@/httpd-access.log" common
#
# If you prefer a logfile with access, agent, and referer information
# (Combined Logfile Format) you can use the following directive.
#
-- #CustomLog @rel_logfiledir@/access_log combined
-+ CustomLog @rel_logfiledir@/httpd-access.log combined
+- #CustomLog "@rel_logfiledir@/access_log" combined
++ CustomLog "@rel_logfiledir@/httpd-access.log" combined
</IfModule>
<IfModule alias_module>
-@@ -412,3 +411,5 @@
+@@ -408,3 +407,5 @@
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
</IfModule>
diff --git a/www/apache22/files/patch-srclib-apr-network_io-unix-multicast.c b/www/apache22/files/patch-srclib-apr-network_io-unix-multicast.c
deleted file mode 100644
index fe186cba42fb..000000000000
--- a/www/apache22/files/patch-srclib-apr-network_io-unix-multicast.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- srclib/apr/network_io/unix/multicast.c.orig 2007-08-05 00:58:21.000000000 +0300
-+++ srclib/apr/network_io/unix/multicast.c 2007-08-05 00:59:51.000000000 +0300
-@@ -57,11 +57,10 @@
- }
- }
-
--#if APR_HAVE_IPV6
- static unsigned int find_if_index(const apr_sockaddr_t *iface)
- {
- unsigned int index = 0;
--#ifdef HAVE_GETIFADDRS
-+#if defined(HAVE_GETIFADDRS) && APR_HAVE_IPV6
- struct ifaddrs *ifp, *ifs;
-
- /**
-@@ -92,6 +91,7 @@
- return index;
- }
-
-+#if APR_HAVE_IPV6
- static void fill_mip_v6(struct ipv6_mreq *mip, const apr_sockaddr_t *mcast,
- const apr_sockaddr_t *iface)
- {