aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/gnuradio/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index fe6c9e0286c5..4521b2eb15cc 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -38,6 +38,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= iconv cmake:outsource perl5 python:2.7 shebangfix
SHEBANG_FILES= grc/freedesktop/grc_setup_freedesktop.in
+CMAKE_ENV+= LD_PRELOAD="${GCC_LIBS}/libstdc++.so:${GCC_LIBS}/libgcc_s.so.1"
CMAKE_ARGS+= -DSWIG_EXECUTABLE:STRING="${LOCALBASE}/bin/swig2.0"
CMAKE_ARGS+= -DICONV_PREFIX:STRING="${ICONV_PREFIX}" \
-DICONV_LIB:STRING="X${ICONV_LIB}" \
@@ -62,6 +63,8 @@ USRP_DESC= Include USRP support (UHD) from Ettus
TESTING_DESC= Include testing support
PLIST_SUB+= PORTVERSION=${PORTVERSION}
+VP= ${GCC_DEFAULT:S/.//}
+GCC_LIBS= ${LOCALBASE}/lib/gcc${VP}
.include <bsd.port.pre.mk>