aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Portability-Files/Makefile26
-rw-r--r--devel/p5-Test-Portability-Files/distinfo3
-rw-r--r--devel/p5-Test-Portability-Files/pkg-descr4
-rw-r--r--devel/p5-Test-Portability-Files/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bdbfddfbfd8c..c2058ead319d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1626,6 +1626,7 @@
SUBDIR += p5-Test-Parser
SUBDIR += p5-Test-Pod
SUBDIR += p5-Test-Pod-Coverage
+ SUBDIR += p5-Test-Portability-Files
SUBDIR += p5-Test-RandomResults
SUBDIR += p5-Test-Reporter
SUBDIR += p5-Test-Script
diff --git a/devel/p5-Test-Portability-Files/Makefile b/devel/p5-Test-Portability-Files/Makefile
new file mode 100644
index 000000000000..905579f998a7
--- /dev/null
+++ b/devel/p5-Test-Portability-Files/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Test-Portability-Files
+# Date created: 2008-02-08
+# Whom: Felippe de Meirelles Motta <lippemail@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Portability-Files
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lippemail@gmail.com
+COMMENT= Test::Portability::Files Check file names portability
+
+BUILD_DEPENDS+= ${SITE_PERL}/Test/Builder.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Portability::Files.3
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Portability-Files/distinfo b/devel/p5-Test-Portability-Files/distinfo
new file mode 100644
index 000000000000..f4a083a0828d
--- /dev/null
+++ b/devel/p5-Test-Portability-Files/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Portability-Files-0.05.tar.gz) = 2ede77af4d3b82ffb39cd28fda6857e5
+SHA256 (Test-Portability-Files-0.05.tar.gz) = 60714e29ceab47962ce624593e1e972e0b92ab4c07711a686ad0d650d90be7f7
+SIZE (Test-Portability-Files-0.05.tar.gz) = 14539
diff --git a/devel/p5-Test-Portability-Files/pkg-descr b/devel/p5-Test-Portability-Files/pkg-descr
new file mode 100644
index 000000000000..621ef9933659
--- /dev/null
+++ b/devel/p5-Test-Portability-Files/pkg-descr
@@ -0,0 +1,4 @@
+This module is used to check the portability across operating systems
+of the names of the files present in the distribution of a module.
+
+WWW: http://search.cpan.org/dist/Test-Portability-Files/
diff --git a/devel/p5-Test-Portability-Files/pkg-plist b/devel/p5-Test-Portability-Files/pkg-plist
new file mode 100644
index 000000000000..a4dd19c84a7a
--- /dev/null
+++ b/devel/p5-Test-Portability-Files/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Portability/Files/.packlist
+%%SITE_PERL%%/Test/Portability/Files.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Portability/Files
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Portability
+@dirrmtry %%SITE_PERL%%/Test/Portability