aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--accessibility/py-papi/Makefile6
-rw-r--r--audio/py-al/Makefile7
-rw-r--r--devel/py-astroid/Makefile8
-rw-r--r--devel/py-dynrules/Makefile5
-rw-r--r--devel/py-game/Makefile5
-rw-r--r--devel/py-logilab-common/Makefile4
-rw-r--r--devel/py-ocempgui/Makefile6
-rw-r--r--devel/py-ply/Makefile5
-rw-r--r--devel/py-sdl2/Makefile5
-rw-r--r--devel/pychecker/Makefile5
-rw-r--r--devel/pylint/Makefile4
-rw-r--r--devel/pyrex/Makefile5
-rw-r--r--devel/winpdb/Makefile5
-rw-r--r--games/pysolfc/Makefile6
-rw-r--r--graphics/blender/Makefile3
-rw-r--r--graphics/py-PyX/Makefile6
-rw-r--r--graphics/py-PyX12/Makefile6
-rw-r--r--lang/micropython/Makefile3
18 files changed, 39 insertions, 55 deletions
diff --git a/accessibility/py-papi/Makefile b/accessibility/py-papi/Makefile
index 62c427db8874..194027f6055d 100644
--- a/accessibility/py-papi/Makefile
+++ b/accessibility/py-papi/Makefile
@@ -10,11 +10,9 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= mva@FreeBSD.org
COMMENT= ATK accessibility wrapper for python
-USES= pkgconfig
+USES= pkgconfig python:2
USE_GNOME= atk
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+PYTHON_FEATURES=autoplist distutils
EXAMPLES= atkaction.py atkapplication.py atkcapi.c atktext.py atkvalue.py \
msaaapplication.py msaacapi.cpp
diff --git a/audio/py-al/Makefile b/audio/py-al/Makefile
index eba5ea0bc0db..6bee4174cc3e 100644
--- a/audio/py-al/Makefile
+++ b/audio/py-al/Makefile
@@ -10,10 +10,7 @@ DISTNAME= PyAL-${PORTVERSION}
MAINTAINER= mva@FreeBSD.org
COMMENT= PyAL is a binding of OpenAL for Python
-USES= openal:al
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
-PYDISTUTILS_PKGNAME= PyAL
+USES= openal:al python
+PYTHON_FEATURES=autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-astroid/Makefile b/devel/py-astroid/Makefile
index b1ab13ed9c49..65315acff8c8 100644
--- a/devel/py-astroid/Makefile
+++ b/devel/py-astroid/Makefile
@@ -15,10 +15,10 @@ LICENSE= LGPL21
RUN_DEPENDS= pytest:${PORTSDIR}/devel/py-logilab-common
-WRKSRC= ${WRKDIR}/logilab-astroid-e003574ae51b
-MAKE_ENV= NO_SETUPTOOLS=1
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+WRKSRC= ${WRKDIR}/logilab-astroid-e003574ae51b
+MAKE_ENV= NO_SETUPTOOLS=1
+PYTHON_FEATURES=distutils
.include <bsd.port.pre.mk>
diff --git a/devel/py-dynrules/Makefile b/devel/py-dynrules/Makefile
index 487cb651edac..0160b31c2118 100644
--- a/devel/py-dynrules/Makefile
+++ b/devel/py-dynrules/Makefile
@@ -12,9 +12,8 @@ COMMENT= Dynamic Scripting for adaptive AI systems
LICENSE= ZLIB
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+PYTHON_FEATURES=autoplist distutils
OPTIONS_DEFINE= DOCS
diff --git a/devel/py-game/Makefile b/devel/py-game/Makefile
index 585e7a81f6e9..bab19df5a612 100644
--- a/devel/py-game/Makefile
+++ b/devel/py-game/Makefile
@@ -17,11 +17,10 @@ LICENSE= LGPL21
LIB_DEPENDS= libsmpeg.so:${PORTSDIR}/multimedia/smpeg
RUN_DEPENDS= ${PYNUMPY}
+USES= python
USE_SDL= ttf image mixer sdl
USE_GCC= any
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+PYTHON_FEATURES=autoplist distutils
SDLNOX11= sdl-nox11-[0-9]*
diff --git a/devel/py-logilab-common/Makefile b/devel/py-logilab-common/Makefile
index eaa07ce63c2b..7fc164935242 100644
--- a/devel/py-logilab-common/Makefile
+++ b/devel/py-logilab-common/Makefile
@@ -13,8 +13,8 @@ COMMENT= Common low-level libraries shared among logilab projects
LICENSE= LGPL20
+USES= python
MAKE_ENV= NO_SETUPTOOLS=1
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+PYTHON_FEATURES=distutils
.include <bsd.port.mk>
diff --git a/devel/py-ocempgui/Makefile b/devel/py-ocempgui/Makefile
index d86e929440d5..251b5228a62d 100644
--- a/devel/py-ocempgui/Makefile
+++ b/devel/py-ocempgui/Makefile
@@ -17,9 +17,9 @@ LICENSE= BSD2CLAUSE
BUILD_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/pygame/pygame.h:${PORTSDIR}/devel/py-game
RUN_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/pygame/pygame.h:${PORTSDIR}/devel/py-game
+USES= python:2
USE_GNOME= atk
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+
+PYTHON_FEATURES= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-ply/Makefile b/devel/py-ply/Makefile
index 3fbd8003be5a..6e25fcbbe846 100644
--- a/devel/py-ply/Makefile
+++ b/devel/py-ply/Makefile
@@ -12,9 +12,8 @@ COMMENT= Python Lex-Yacc
LICENSE= BSD3CLAUSE
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+PYTHON_FEATURES=autoplist distutils
PORTDOCS= ply.html internal.html README
diff --git a/devel/py-sdl2/Makefile b/devel/py-sdl2/Makefile
index e96958120738..4c8f42fc30f5 100644
--- a/devel/py-sdl2/Makefile
+++ b/devel/py-sdl2/Makefile
@@ -12,10 +12,9 @@ COMMENT= Python bindings to the SDL2 libraries
LICENSE= ZLIB
+USES= python
USE_SDL= sdl2 gfx2 image2 ttf2 mixer2
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+PYTHON_FEATURES= autoplist distutils
OPTIONS_DEFINE= DOCS
diff --git a/devel/pychecker/Makefile b/devel/pychecker/Makefile
index fd74a8e43f63..961547c2eb3f 100644
--- a/devel/pychecker/Makefile
+++ b/devel/pychecker/Makefile
@@ -11,9 +11,8 @@ COMMENT= Python source code checking tool to help hunting common bugs
LICENSE= BSD3CLAUSE
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+PYTHON_FEATURES=autoplist distutils
DOCS= ChangeLog COPYRIGHT KNOWN_BUGS MAINTAINERS README TODO VERSION
diff --git a/devel/pylint/Makefile b/devel/pylint/Makefile
index 8c125f0f037a..85b4a9926958 100644
--- a/devel/pylint/Makefile
+++ b/devel/pylint/Makefile
@@ -15,8 +15,8 @@ LICENSE= LGPL21
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astroid>=1.1.0:${PORTSDIR}/devel/py-astroid
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+PYTHON_FEATURES=distutils
OPTIONS_DEFINE= GUI
diff --git a/devel/pyrex/Makefile b/devel/pyrex/Makefile
index 01f6e645de65..dc26d6bae225 100644
--- a/devel/pyrex/Makefile
+++ b/devel/pyrex/Makefile
@@ -13,9 +13,8 @@ COMMENT= Programming Language for writing Python extension modules
LICENSE= APACHE20
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
+PYTHON_FEATURES=autoplist distutils
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/Manual
diff --git a/devel/winpdb/Makefile b/devel/winpdb/Makefile
index 16de902581e1..b73e3e98e471 100644
--- a/devel/winpdb/Makefile
+++ b/devel/winpdb/Makefile
@@ -15,9 +15,8 @@ LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+PYTHON_FEATURES=autoplist distutils
USE_WX= 3.0+
WX_COMPS= python
diff --git a/games/pysolfc/Makefile b/games/pysolfc/Makefile
index 675826ca4cd9..69ace83884ed 100644
--- a/games/pysolfc/Makefile
+++ b/games/pysolfc/Makefile
@@ -17,10 +17,8 @@ LICENSE= GPLv3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
-USES= tar:bzip2
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python tar:bzip2
+PYTHON_FEATURES=autoplist distutils
PLIST_FILES= share/pixmaps/pysolfc.png
DATADIR= ${PREFIX}/share/PySolFC
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index c6e7698b031c..994b80f6d801 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -19,8 +19,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
USE_XORG= x11 xext xmu
USE_GL= glew
-USES= cmake:outsource compiler:features shebangfix
-USE_PYTHON= 3.4
+USES= cmake:outsource compiler:features python:3.4 shebangfix
CMAKE_ARGS+= -DWITH_PYTHON_INSTALL:BOOL=OFF \
-DWITH_PYTHON_INSTALL_NUMPY:BOOL=OFF
diff --git a/graphics/py-PyX/Makefile b/graphics/py-PyX/Makefile
index 6f71b2f6640f..04ca0bc9e790 100644
--- a/graphics/py-PyX/Makefile
+++ b/graphics/py-PyX/Makefile
@@ -12,11 +12,11 @@ COMMENT= Python package for creating encapsulated PostScript figures
LICENSE= GPLv2
-USE_PYTHON= 3
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:3
USE_TEX= latex:build
+PYTHON_FEATURES= autoplist distutils
+
OPTIONS_DEFINE= T1CODE KPATHSEA
OPTIONS_DEFAULT= T1CODE KPATHSEA
T1CODE_DESC= Fast t1 font encoding/decoding
diff --git a/graphics/py-PyX12/Makefile b/graphics/py-PyX12/Makefile
index 65a607279f13..97e5271f6839 100644
--- a/graphics/py-PyX12/Makefile
+++ b/graphics/py-PyX12/Makefile
@@ -13,11 +13,11 @@ COMMENT= Python package for creating encapsulated PostScript figures
LICENSE= GPLv2
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
USE_TEX= latex:build
+PYTHON_FEATURES= autoplist distutils
+
OPTIONS_DEFINE= T1CODE KPATHSEA
OPTIONS_DEFAULT= T1CODE KPATHSEA
T1CODE_DESC= Fast t1 font encoding/decoding
diff --git a/lang/micropython/Makefile b/lang/micropython/Makefile
index 4ba0a5f420ff..653390bdc057 100644
--- a/lang/micropython/Makefile
+++ b/lang/micropython/Makefile
@@ -11,8 +11,7 @@ LICENSE= MIT
LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
-USE_PYTHON_BUILD= yes
-USES= gmake shebangfix pkgconfig readline
+USES= gmake pkgconfig python:build readline shebangfix
USE_GITHUB= yes
GH_ACCOUNT= micropython