aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING8
-rw-r--r--www/Makefile2
-rw-r--r--www/p5-Apache-DBI-mp1/Makefile19
-rw-r--r--www/p5-Apache-DBI-mp2/Makefile21
-rw-r--r--www/p5-Apache-DBI/Makefile20
-rw-r--r--www/p5-Apache-DBI/pkg-plist5
6 files changed, 65 insertions, 10 deletions
diff --git a/UPDATING b/UPDATING
index 63797492b375..7a4bb267deec 100644
--- a/UPDATING
+++ b/UPDATING
@@ -33,6 +33,14 @@ upgrades.
Just remember to edit configuration file after upgrade.
20080820:
+ AFFECTS: users of www/p5-Apache-DBI
+ AUTHOR: pgollucci@FreeBSD.org
+
+ www/p5-Apache-DBI has been forked into a MASTER and SLAVE
+ setup www/p5-Apache-DBI-mp1 and www/p5-Apache-DBI-mp2
+ so as to work with www/rt38 among possibly other ports.
+
+20080820:
AFFECTS: users of net/rabbitmq
AUTHOR: pneumann@gmail.com
diff --git a/www/Makefile b/www/Makefile
index 63354664ab37..3174ae389763 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -563,6 +563,8 @@
SUBDIR += p5-Apache-ConfigParser
SUBDIR += p5-Apache-DB
SUBDIR += p5-Apache-DBI
+ SUBDIR += p5-Apache-DBI-mp1
+ SUBDIR += p5-Apache-DBI-mp2
SUBDIR += p5-Apache-DebugInfo
SUBDIR += p5-Apache-DumpHeaders
SUBDIR += p5-Apache-Filter
diff --git a/www/p5-Apache-DBI-mp1/Makefile b/www/p5-Apache-DBI-mp1/Makefile
new file mode 100644
index 000000000000..5c6a4a2ec931
--- /dev/null
+++ b/www/p5-Apache-DBI-mp1/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: p5-Apache-DBI-mp1
+# Date created: 28 Aug 2008
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-DBI
+PKGNAMESUFFIX= -mp1
+
+COMMENT= DBI persistent connection, authentication and authorization (mp1)
+
+MASTERDIR= ${.CURDIR}/../p5-Apache-DBI
+
+.if defined(WITH_MODPERL2) || defined(WITHOUT_MODPERL)
+IGNORE= This port is only for use with www/mod_perl
+.endif
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/p5-Apache-DBI-mp2/Makefile b/www/p5-Apache-DBI-mp2/Makefile
new file mode 100644
index 000000000000..698373d77e89
--- /dev/null
+++ b/www/p5-Apache-DBI-mp2/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Apache-DBI-mp2
+# Date created: 28 Aug 2008
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-DBI
+PKGNAMESUFFIX= -mp2
+
+COMMENT= DBI persistent connection, authentication and authorization (mp2)
+
+MASTERDIR= ${.CURDIR}/../p5-Apache-DBI
+
+.if defined(WITH_MODPERL) || defined(WITHOUT_MODPERL2)
+IGNORE= This port is only for use with www/mod_perl2
+.endif
+
+WITH_MODPERL2= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index 7cde18bc6e95..99160492ef70 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -5,14 +5,17 @@
# $FreeBSD$
#
-PORTNAME= Apache-DBI
+PORTNAME?= Apache-DBI
PORTVERSION= 1.06
+PORTREVISION?= 1
CATEGORIES= www databases perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
-COMMENT= DBI persistent connection, authentication and authorization
+COMMENT?= DBI persistent connection, authentication and authorization
+
+SLAVEDIRS= www/p5-Apache-DBI-mp1 www/p5-Apache-DBI-mp2
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
@@ -22,14 +25,21 @@ MAN3= Apache::DBI.3 Apache::AuthDBI.3
PERL_CONFIGURE= yes
.if defined(WITH_MODPERL2)
-USE_APACHE= 2.0+
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
-BUILD_DEPENDS+= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
.else
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
-BUILD_DEPENDS+= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
.endif
+PLIST_FILES= %%SITE_PERL%%/Apache/DBI.pm \
+ %%SITE_PERL%%/Apache/AuthDBI.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI/.packlist
+
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache \
+ %%SITE_PERL%%/Apache
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
diff --git a/www/p5-Apache-DBI/pkg-plist b/www/p5-Apache-DBI/pkg-plist
deleted file mode 100644
index 814e8dc2141f..000000000000
--- a/www/p5-Apache-DBI/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-%%SITE_PERL%%/Apache/DBI.pm
-%%SITE_PERL%%/Apache/AuthDBI.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI/.packlist
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI
-@dirrmtry %%SITE_PERL%%/Apache