aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/pymol/Makefile6
-rw-r--r--math/atlas-devel/Makefile6
-rw-r--r--math/atlas/Makefile6
3 files changed, 18 insertions, 0 deletions
diff --git a/biology/pymol/Makefile b/biology/pymol/Makefile
index 7f3895d78b36..d53214185a48 100644
--- a/biology/pymol/Makefile
+++ b/biology/pymol/Makefile
@@ -28,7 +28,13 @@ USE_PYTHON= yes
.include <bsd.port.pre.mk>
+.if !defined(PICFLAG)
+.if ${MACHINE_ARCH} == "sparc64"
PICFLAG=-fPIC
+.else
+PICFLAG=-fpic
+.endif
+.endif
pre-patch:
@${INSTALL_DATA} ${WRKSRC}/setup/Rules.linux ${WRKSRC}/Rules.make
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index a5fe33e93454..e184cfa2e292 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -50,7 +50,13 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
+.if !defined(PICFLAG)
+.if ${MACHINE_ARCH} == "sparc64"
PICFLAG=-fPIC
+.else
+PICFLAG=-fpic
+.endif
+.endif
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index 42e8ddbf50be..a3a0fc74d800 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -49,7 +49,13 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
+.if !defined(PICFLAG)
+.if ${MACHINE_ARCH} == "sparc64"
PICFLAG=-fPIC
+.else
+PICFLAG=-fpic
+.endif
+.endif
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"