aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-Application-Plugin-AnyTemplate/Makefile37
-rw-r--r--www/p5-CGI-Application-Plugin-AnyTemplate/distinfo3
-rw-r--r--www/p5-CGI-Application-Plugin-AnyTemplate/pkg-descr15
-rw-r--r--www/p5-CGI-Application-Plugin-AnyTemplate/pkg-plist13
5 files changed, 69 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8fed1669b756..bbaf2e04eca4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -512,6 +512,7 @@
SUBDIR += p5-Business-PayPal
SUBDIR += p5-CGI-Ajax
SUBDIR += p5-CGI-Application
+ SUBDIR += p5-CGI-Application-Plugin-AnyTemplate
SUBDIR += p5-CGI-Application-Plugin-AutoRunmode
SUBDIR += p5-CGI-Application-Plugin-DBH
SUBDIR += p5-CGI-Application-Plugin-DevPopup
diff --git a/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile b/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile
new file mode 100644
index 000000000000..9ee11e668beb
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: www/p5-CGI-Application-Plugin-AnyTemplate
+# Date created: 14 September 2005
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-AnyTemplate
+PORTVERSION= 0.17
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= Use any templating system in CGI::Application
+
+RUN_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/CGI/Application/Plugin/Forward.pm:${PORTSDIR}/www/p5-CGI-Application-Plugin-Forward
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= CGI::Application::Plugin::AnyTemplate.3 \
+ CGI::Application::Plugin::AnyTemplate::Driver::HTMLTemplate.3 \
+ CGI::Application::Plugin::AnyTemplate::Base.3 \
+ CGI::Application::Plugin::AnyTemplate::Driver::TemplateToolkit.3 \
+ CGI::Application::Plugin::AnyTemplate::ComponentHandler.3 \
+ CGI::Application::Plugin::AnyTemplate::Driver::HTMLTemplatePluggable.3 \
+ CGI::Application::Plugin::AnyTemplate::Driver::HTMLTemplateExpr.3 \
+ CGI::Application::Plugin::AnyTemplate::Driver::Petal.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-AnyTemplate/distinfo b/www/p5-CGI-Application-Plugin-AnyTemplate/distinfo
new file mode 100644
index 000000000000..e2f55d53e2e8
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-AnyTemplate/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Application-Plugin-AnyTemplate-0.17.tar.gz) = 1bba5c8dc3670ff0539f941c75cf6ef9
+SHA256 (CGI-Application-Plugin-AnyTemplate-0.17.tar.gz) = d0d9dd0995beeea2b5a43be337172be0337120f6fbbdd2ee67482878549c1880
+SIZE (CGI-Application-Plugin-AnyTemplate-0.17.tar.gz) = 54292
diff --git a/www/p5-CGI-Application-Plugin-AnyTemplate/pkg-descr b/www/p5-CGI-Application-Plugin-AnyTemplate/pkg-descr
new file mode 100644
index 000000000000..15ac9ca65cf2
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-AnyTemplate/pkg-descr
@@ -0,0 +1,15 @@
+CGI::Application::Plugin::AnyTemplate allows you to use any supported
+Perl templating system using a single consistent interface.
+
+Currently supported templating systems include HTML::Template,
+HTML::Template::Expr, HTML::Template::Pluggable, Template::Toolkit and
+Petal.
+
+You can access any of these templating systems using the same
+interface. In this way, you can use the same code and switch
+templating systems on the fly.
+
+This approach has many uses. For instance, it can be useful in
+migrating your application from one templating system to another.
+
+WWW: http://search.cpan.org/dist/CGI-Application-Plugin-AnyTemplate/
diff --git a/www/p5-CGI-Application-Plugin-AnyTemplate/pkg-plist b/www/p5-CGI-Application-Plugin-AnyTemplate/pkg-plist
new file mode 100644
index 000000000000..bdd8dbb9648c
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-AnyTemplate/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/CGI/Application/Plugin/AnyTemplate/Driver/Petal.pm
+%%SITE_PERL%%/CGI/Application/Plugin/AnyTemplate/ComponentHandler.pm
+%%SITE_PERL%%/CGI/Application/Plugin/AnyTemplate/Driver/HTMLTemplatePluggable.pm
+%%SITE_PERL%%/CGI/Application/Plugin/AnyTemplate/Driver/HTMLTemplate.pm
+%%SITE_PERL%%/CGI/Application/Plugin/AnyTemplate/Base.pm
+%%SITE_PERL%%/CGI/Application/Plugin/AnyTemplate/Driver/TemplateToolkit.pm
+%%SITE_PERL%%/CGI/Application/Plugin/AnyTemplate.pm
+%%SITE_PERL%%/CGI/Application/Plugin/AnyTemplate/Driver/HTMLTemplateExpr.pm
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin/AnyTemplate/Driver
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin/AnyTemplate
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin
+@dirrmtry %%SITE_PERL%%/CGI/Application
+@dirrmtry %%SITE_PERL%%/CGI