aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/cliquer/Makefile26
-rw-r--r--math/cliquer/distinfo3
-rw-r--r--math/cliquer/pkg-descr10
-rw-r--r--math/cliquer/pkg-plist14
5 files changed, 54 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index f65f86f0b3bd..92af29fc5df7 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -180,6 +180,7 @@
SUBDIR += clblast
SUBDIR += clfft
SUBDIR += clingo
+ SUBDIR += cliquer
SUBDIR += cln
SUBDIR += cloog
SUBDIR += clp
diff --git a/math/cliquer/Makefile b/math/cliquer/Makefile
new file mode 100644
index 000000000000..7893af7c95ea
--- /dev/null
+++ b/math/cliquer/Makefile
@@ -0,0 +1,26 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= cliquer
+PORTVERSION= 1.21
+DISTVERSIONPREFIX= v
+CATEGORIES= math
+#MASTER_SITES= http://users.aalto.fi/~pat/cliquer/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Routines for clique searching
+
+LICENSE= GPLv2
+
+USE_GITHUB= yes
+GH_ACCOUNT= dimpase
+GH_PROJECT= autocliquer
+
+USES= autoreconf libtool
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+TEST_TARGET= check
+
+.include <bsd.port.mk>
diff --git a/math/cliquer/distinfo b/math/cliquer/distinfo
new file mode 100644
index 000000000000..18ccc955cfca
--- /dev/null
+++ b/math/cliquer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585306838
+SHA256 (dimpase-autocliquer-v1.21_GH0.tar.gz) = 297de57628cf0d89093ef6d3b366a1594b180970e5ffee1395b2b305859584e6
+SIZE (dimpase-autocliquer-v1.21_GH0.tar.gz) = 78863
diff --git a/math/cliquer/pkg-descr b/math/cliquer/pkg-descr
new file mode 100644
index 000000000000..01c22881a1fd
--- /dev/null
+++ b/math/cliquer/pkg-descr
@@ -0,0 +1,10 @@
+Cliquer is a set of C routines for finding cliques in an arbitrary weighted
+graph. It uses an exact branch-and-bound algorithm developed by Patric
+Ostergard. It is designed with the aim of being efficient while still being
+flexible and easy to use.
+
+Note: this port do not use the upstream version, but the version autotoolized
+by Dima Pasechnik.
+
+WWW: https://users.aalto.fi/~pat/cliquer.html
+WWW: https://github.com/dimpase/autocliquer
diff --git a/math/cliquer/pkg-plist b/math/cliquer/pkg-plist
new file mode 100644
index 000000000000..bf1c8ee87ff8
--- /dev/null
+++ b/math/cliquer/pkg-plist
@@ -0,0 +1,14 @@
+bin/cl
+include/cliquer/cliquer.h
+include/cliquer/cliquerconf.h
+include/cliquer/graph.h
+include/cliquer/misc.h
+include/cliquer/reorder.h
+include/cliquer/set.h
+lib/libcliquer.a
+lib/libcliquer.so
+lib/libcliquer.so.1
+lib/libcliquer.so.1.0.21
+%%DATADIR%%/testcase-large-w.b
+%%DATADIR%%/testcase-large.b
+%%DATADIR%%/testcase-small.a