aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING14
-rw-r--r--graphics/mesa-dri/files/patch-src_egl_drivers_dri2_platform__x11.c16
-rw-r--r--graphics/mesa-dri/files/patch-src_glx_glxext.c16
-rw-r--r--graphics/mesa-libs/Makefile2
-rw-r--r--x11-servers/xorg-server/Makefile13
5 files changed, 18 insertions, 43 deletions
diff --git a/UPDATING b/UPDATING
index 14a74f639535..12a6e5da20f9 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,20 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20200308
+ AFFECTS: users of graphics/mesa-libs and legacy graphics drivers
+ AUTHOR: zeising@FreeBSD.org
+
+ The mesa OpenGL library (graphics/mesa-libs) has been switched to use DRI3
+ by default, instead of the older DRI2 interface. This might cause regressions
+ when using the legacy graphics drivers, either through
+ graphics/drm-legacy-kmod or the graphics drivers in base.
+
+ If you experience issues when running OpenGL applications it is possible
+ to force the use of DRI2 by setting the LIBGL_DRI3_DISABLE environment
+ variable to 1 before starting any OpenGL application. The easiest way to
+ do this is by adding it to either your shell startup files or .xinitrc.
+
20200306
AFFECTS: users of databases/mysql80-server
AUTHOR: joneum@FreeBSD.org
diff --git a/graphics/mesa-dri/files/patch-src_egl_drivers_dri2_platform__x11.c b/graphics/mesa-dri/files/patch-src_egl_drivers_dri2_platform__x11.c
deleted file mode 100644
index 060c1e1c4965..000000000000
--- a/graphics/mesa-dri/files/patch-src_egl_drivers_dri2_platform__x11.c
+++ /dev/null
@@ -1,16 +0,0 @@
-# work-around for https://bugs.freedesktop.org/show_bug.cgi?id=100627
-#
---- src/egl/drivers/dri2/platform_x11.c.orig 2018-01-23 18:08:49 UTC
-+++ src/egl/drivers/dri2/platform_x11.c
-@@ -1466,7 +1466,11 @@ dri2_initialize_x11(_EGLDriver *drv, _EGLDisplay *disp
-
- if (!disp->Options.ForceSoftware) {
- #ifdef HAVE_DRI3
-+#if (defined(__FreeBSD__) || defined(__FreeBSD_kernel__)) && !defined(__DRM_NEXT__)
-+ if (env_var_as_boolean("LIBGL_DRI3_ENABLE", false) && !env_var_as_boolean("LIBGL_DRI3_DISABLE", false))
-+#else
- if (!env_var_as_boolean("LIBGL_DRI3_DISABLE", false))
-+#endif
- initialized = dri2_initialize_x11_dri3(drv, disp);
- #endif
-
diff --git a/graphics/mesa-dri/files/patch-src_glx_glxext.c b/graphics/mesa-dri/files/patch-src_glx_glxext.c
deleted file mode 100644
index 05ba1fbf75fd..000000000000
--- a/graphics/mesa-dri/files/patch-src_glx_glxext.c
+++ /dev/null
@@ -1,16 +0,0 @@
-# work-around for https://bugs.freedesktop.org/show_bug.cgi?id=100627
-#
---- src/glx/glxext.c.orig 2017-12-21 17:31:21 UTC
-+++ src/glx/glxext.c
-@@ -920,7 +920,11 @@ __glXInitialize(Display * dpy)
- #if defined(GLX_USE_DRM)
- if (glx_direct && glx_accel) {
- #if defined(HAVE_DRI3)
-+#if (defined(__FreeBSD__) || defined(__FreeBSD_kernel__)) && !defined(__DRM_NEXT__)
-+ if (env_var_as_boolean("LIBGL_DRI3_ENABLE", false) && !env_var_as_boolean("LIBGL_DRI3_DISABLE", false))
-+#else
- if (!env_var_as_boolean("LIBGL_DRI3_DISABLE", false))
-+#endif
- dpyPriv->dri3Display = dri3_create_display(dpy);
- #endif /* HAVE_DRI3 */
- dpyPriv->dri2Display = dri2CreateDisplay(dpy);
diff --git a/graphics/mesa-libs/Makefile b/graphics/mesa-libs/Makefile
index 65a206ceae3c..6eb24bc585b4 100644
--- a/graphics/mesa-libs/Makefile
+++ b/graphics/mesa-libs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mesa-libs
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
COMMENT= OpenGL libraries that support GLX and EGL clients
diff --git a/x11-servers/xorg-server/Makefile b/x11-servers/xorg-server/Makefile
index ed6e44977437..4da5c25467dd 100644
--- a/x11-servers/xorg-server/Makefile
+++ b/x11-servers/xorg-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= xorg-server
PORTVERSION?= 1.20.7
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH?= 1
CATEGORIES= x11-servers
MASTER_SITES= XORG/individual/xserver
@@ -20,7 +20,7 @@ RUN_DEPENDS+= xkeyboard-config>=2.5:x11/xkeyboard-config \
SLAVE_PORT?= no
OPTIONS_SUB= yes
-OPTIONS_DEFINE= FIXDRM SUID
+OPTIONS_DEFINE= SUID
OPTIONS_RADIO= CONF
OPTIONS_RADIO_CONF= DEVD UDEV
OPTIONS_DEFAULT= SUID
@@ -32,7 +32,6 @@ OPTIONS_DEFAULT+= ${OPTIONS_DEFAULT_${OPSYS}_${OSREL:R}}
SUID_DESC= Install setuid wrapper to allow startx as non-root
CONF_DESC= Backend to use for input device configuration
DEVD_DESC= Use devd for autoconfiguration of input devices
-FIXDRM_DESC= Enable glamor workaround for drm-kmod bug
UDEV_DESC= Use udev via libudev-devd for autoconfiguration of input devices
DEVD_CONFIGURE_ENABLE= config-devd
@@ -82,7 +81,7 @@ CONFIGURE_ARGS+=--disable-dmx --disable-xephyr --disable-xnest --disable-xvfb \
SUB_FILES= pkg-install pkg-deinstall
.else
CONFIGURE_ARGS+= --disable-xorg
-OPTIONS_EXCLUDE= DEVD FIXDRM UDEV SUID
+OPTIONS_EXCLUDE= DEVD UDEV SUID
# Set PLIST for slave ports so they only need to set PLIST_FILES
PLIST= ${.CURDIR}/pkg-plist
.endif
@@ -106,12 +105,6 @@ PLIST_SUB+= SPARC64=""
PLIST_SUB+= SPARC64="@comment "
.endif
-post-patch-FIXDRM-on:
-# Workaround lockups with modesetting driver using drm-kmod 4.16+ with partial
-# revert of commit 86b2d8740a330deafe8a9bbf0402705a43efbb42
- @${REINPLACE_CMD} '/glamor_make_pixmap_exportable/ s/FALSE/TRUE/' \
- ${WRKSRC}/glamor/glamor_egl.c
-
post-patch:
@${REINPLACE_CMD} 's/test.*-traditional.*;/true;/' \
${WRKSRC}/configure