aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/mixxx/Makefile4
-rw-r--r--games/kobodeluxe/Makefile4
-rw-r--r--games/tomatoes/Makefile4
-rw-r--r--math/ruby-gmp/Makefile4
-rw-r--r--net/ns/Makefile4
-rw-r--r--net/ns2/Makefile4
-rw-r--r--textproc/ruby-gdome/Makefile4
-rw-r--r--www/openvrml/Makefile4
8 files changed, 0 insertions, 32 deletions
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index 8a80fb088868..91a8bf8fdecb 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -47,10 +47,6 @@ IGNORE= does not compile on FreeBSD 4.x, due to lack of pselect() in libc
IGNORE= does not compile on FreeBSD < 5.3, due to lack of round() in libm
.endif
-.if ${OSVERSION} >= 600000 && ${ARCH} == "amd64"
-BROKEN= "does not build"
-.endif
-
post-patch:
@${REINPLACE_CMD} \
-e 's|/bin/bash|${LOCALBASE}&| ; \
diff --git a/games/kobodeluxe/Makefile b/games/kobodeluxe/Makefile
index e1e315948ad4..01dc03e8ed06 100644
--- a/games/kobodeluxe/Makefile
+++ b/games/kobodeluxe/Makefile
@@ -28,10 +28,6 @@ OPTIONS= OPENGL "OpenGL rendering layer (experimental)" off
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= "Does not compile on amd64"
-.endif
-
.if defined(WITH_OPENGL)
USE_GL= yes
CONFIGURE_ARGS+= --enable-opengl
diff --git a/games/tomatoes/Makefile b/games/tomatoes/Makefile
index e77c6116b24f..ae4f5a5c3a26 100644
--- a/games/tomatoes/Makefile
+++ b/games/tomatoes/Makefile
@@ -47,10 +47,6 @@ SDL_LDFLAGS= `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer \
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
post-patch:
.for file in include/font.h
cd ${WRKSRC} && ${CP} ${file} ${file}.bak \
diff --git a/math/ruby-gmp/Makefile b/math/ruby-gmp/Makefile
index c4bf27ed994f..7779d6904ec4 100644
--- a/math/ruby-gmp/Makefile
+++ b/math/ruby-gmp/Makefile
@@ -28,10 +28,6 @@ DOCS= ChangeLog README doc/PRECISION doc/TODO
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= "Does not build on amd64 (needs to link against shared library)"
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
diff --git a/net/ns/Makefile b/net/ns/Makefile
index 2914fe1b0cab..27681f226eb1 100644
--- a/net/ns/Makefile
+++ b/net/ns/Makefile
@@ -30,10 +30,6 @@ ALL_TARGET=
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ns.1 ${PREFIX}/man/man1
diff --git a/net/ns2/Makefile b/net/ns2/Makefile
index 2914fe1b0cab..27681f226eb1 100644
--- a/net/ns2/Makefile
+++ b/net/ns2/Makefile
@@ -30,10 +30,6 @@ ALL_TARGET=
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ns.1 ${PREFIX}/man/man1
diff --git a/textproc/ruby-gdome/Makefile b/textproc/ruby-gdome/Makefile
index b7a863340895..da5f29b2cd5c 100644
--- a/textproc/ruby-gdome/Makefile
+++ b/textproc/ruby-gdome/Makefile
@@ -28,10 +28,6 @@ INSTALL_TARGET= site-install
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= "Coredump during build on amd64"
-.endif
-
post-extract:
${RM} -rf ${WRKSRC}/examples-ruby/CVS
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index 9a99225c4aa1..068b73f6928b 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -46,10 +46,6 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on ${ARCH}"
-.endif
-
.if ${OSVERSION} < 500000
BROKEN= "Does not compile on ${OPSYS}-${OSREL}"
.endif