aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/pear-File_Fortune/Makefile9
-rw-r--r--textproc/pear-File_MARC/Makefile6
-rw-r--r--textproc/pear-Numbers_Roman/Makefile9
-rw-r--r--textproc/pear-Numbers_Words/Makefile12
-rw-r--r--textproc/pear-Spreadsheet_Excel_Writer/Makefile12
-rw-r--r--textproc/pear-Structures_DataGrid_DataSource_RSS/Makefile6
-rw-r--r--textproc/pear-Structures_DataGrid_DataSource_XML/Makefile6
-rw-r--r--textproc/pear-Structures_DataGrid_Renderer_CSV/Makefile6
-rw-r--r--textproc/pear-Structures_DataGrid_Renderer_XLS/Makefile6
-rw-r--r--textproc/pear-Structures_DataGrid_Renderer_XML/Makefile6
-rw-r--r--textproc/pear-Symfony_Component_Yaml/Makefile6
-rw-r--r--textproc/pear-Text_Highlighter/Makefile6
-rw-r--r--textproc/pear-Text_Template/Makefile12
-rw-r--r--textproc/pear-XML_Beautifier/Makefile6
-rw-r--r--textproc/pear-XML_DTD/Makefile13
-rw-r--r--textproc/pear-XML_Feed_Parser/Makefile10
-rw-r--r--textproc/pear-XML_HTMLSax/Makefile9
-rw-r--r--textproc/pear-XML_Wddx/Makefile6
-rw-r--r--textproc/pear-YAML/Makefile13
19 files changed, 48 insertions, 111 deletions
diff --git a/textproc/pear-File_Fortune/Makefile b/textproc/pear-File_Fortune/Makefile
index 8f6d09ab1890..cd821477935a 100644
--- a/textproc/pear-File_Fortune/Makefile
+++ b/textproc/pear-File_Fortune/Makefile
@@ -9,11 +9,6 @@ CATEGORIES= textproc pear
MAINTAINER= ports@FreeBSD.org
COMMENT= Interface for reading from and writing to fortune files
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-File_MARC/Makefile b/textproc/pear-File_MARC/Makefile
index 3a956a9136bf..60c1435a3877 100644
--- a/textproc/pear-File_MARC/Makefile
+++ b/textproc/pear-File_MARC/Makefile
@@ -8,8 +8,6 @@ CATEGORIES= textproc pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Parse, modify, and create MARC records
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Numbers_Roman/Makefile b/textproc/pear-Numbers_Roman/Makefile
index 886abfda695d..e3bdd0ccb184 100644
--- a/textproc/pear-Numbers_Roman/Makefile
+++ b/textproc/pear-Numbers_Roman/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= textproc devel pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR methods for converting to and from Roman Numerals
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Numbers_Words/Makefile b/textproc/pear-Numbers_Words/Makefile
index d207832589fd..2b9030a09534 100644
--- a/textproc/pear-Numbers_Words/Makefile
+++ b/textproc/pear-Numbers_Words/Makefile
@@ -8,13 +8,9 @@ CATEGORIES= textproc pear
MAINTAINER= meritus@innervision.pl
COMMENT= PEAR package provides methods for spelling numerals in words
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Math/BigInteger.php:${PORTSDIR}/math/pear-Math_BigInteger
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Math/BigInteger.php:${PORTSDIR}/math/pear-Math_BigInteger
+BUILD_DEPENDS= ${PEARDIR}/Math/BigInteger.php:${PORTSDIR}/math/pear-Math_BigInteger
+RUN_DEPENDS= ${PEARDIR}/Math/BigInteger.php:${PORTSDIR}/math/pear-Math_BigInteger
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Spreadsheet_Excel_Writer/Makefile b/textproc/pear-Spreadsheet_Excel_Writer/Makefile
index 6958ca073f99..e9b19052c48e 100644
--- a/textproc/pear-Spreadsheet_Excel_Writer/Makefile
+++ b/textproc/pear-Spreadsheet_Excel_Writer/Makefile
@@ -10,13 +10,9 @@ COMMENT= PEAR class for writing Microsoft Excel files
LICENSE= LGPL3
-BUILD_DEPENDS= ${PEARDIR}/OLE.php:${PORTSDIR}/devel/pear-OLE \
- ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/OLE.php:${PORTSDIR}/devel/pear-OLE \
- ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+BUILD_DEPENDS= ${PEARDIR}/OLE.php:${PORTSDIR}/devel/pear-OLE
+RUN_DEPENDS= ${PEARDIR}/OLE.php:${PORTSDIR}/devel/pear-OLE
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Structures_DataGrid_DataSource_RSS/Makefile b/textproc/pear-Structures_DataGrid_DataSource_RSS/Makefile
index f271a2eb6103..f696556d6c85 100644
--- a/textproc/pear-Structures_DataGrid_DataSource_RSS/Makefile
+++ b/textproc/pear-Structures_DataGrid_DataSource_RSS/Makefile
@@ -11,9 +11,7 @@ COMMENT= DataSource driver using RSS files
BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
+USES= pear
USE_PHP= mysql
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Structures_DataGrid_DataSource_XML/Makefile b/textproc/pear-Structures_DataGrid_DataSource_XML/Makefile
index 7a8e372417f7..69236dd77103 100644
--- a/textproc/pear-Structures_DataGrid_DataSource_XML/Makefile
+++ b/textproc/pear-Structures_DataGrid_DataSource_XML/Makefile
@@ -11,9 +11,7 @@ COMMENT= DataSource driver using XML files
BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
+USES= pear
USE_PHP= mysql
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Structures_DataGrid_Renderer_CSV/Makefile b/textproc/pear-Structures_DataGrid_Renderer_CSV/Makefile
index fc2a7a4428e2..0b741f0dffa4 100644
--- a/textproc/pear-Structures_DataGrid_Renderer_CSV/Makefile
+++ b/textproc/pear-Structures_DataGrid_Renderer_CSV/Makefile
@@ -11,8 +11,6 @@ COMMENT= Renderer driver that generates a CSV string
BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Structures_DataGrid_Renderer_XLS/Makefile b/textproc/pear-Structures_DataGrid_Renderer_XLS/Makefile
index b31a2c3c9913..44896efa6552 100644
--- a/textproc/pear-Structures_DataGrid_Renderer_XLS/Makefile
+++ b/textproc/pear-Structures_DataGrid_Renderer_XLS/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/d
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array \
${PEARDIR}/Spreadsheet/Excel/Writer.php:${PORTSDIR}/textproc/pear-Spreadsheet_Excel_Writer
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Structures_DataGrid_Renderer_XML/Makefile b/textproc/pear-Structures_DataGrid_Renderer_XML/Makefile
index 2fef87c710d6..ca422a65aafa 100644
--- a/textproc/pear-Structures_DataGrid_Renderer_XML/Makefile
+++ b/textproc/pear-Structures_DataGrid_Renderer_XML/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/d
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array \
${PEARDIR}/XML/Util.php:${PORTSDIR}/devel/pear-XML_Util
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Symfony_Component_Yaml/Makefile b/textproc/pear-Symfony_Component_Yaml/Makefile
index 6b96a4a87d33..839c31c7fb0f 100644
--- a/textproc/pear-Symfony_Component_Yaml/Makefile
+++ b/textproc/pear-Symfony_Component_Yaml/Makefile
@@ -11,8 +11,6 @@ COMMENT= Symfony2 Yaml Component
LICENSE= MIT
-IGNORE_WITH_PHP=52
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-channel-symfony2/bsd.symfony2.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Text_Highlighter/Makefile b/textproc/pear-Text_Highlighter/Makefile
index 6a9a221e2177..fae79bee9b0e 100644
--- a/textproc/pear-Text_Highlighter/Makefile
+++ b/textproc/pear-Text_Highlighter/Makefile
@@ -11,8 +11,6 @@ COMMENT= PEAR Syntax highlighting
BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
RUN_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-Text_Template/Makefile b/textproc/pear-Text_Template/Makefile
index 11306a50daf3..a1a753499276 100644
--- a/textproc/pear-Text_Template/Makefile
+++ b/textproc/pear-Text_Template/Makefile
@@ -10,14 +10,10 @@ PKGNAMEPREFIX= pear-
MAINTAINER= miwi@FreeBSD.org
COMMENT= Simple template engine
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/.channels/pear.phpunit.de.reg:${PORTSDIR}/devel/pear-channel-phpunit
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/.channels/pear.phpunit.de.reg:${PORTSDIR}/devel/pear-channel-phpunit
+BUILD_DEPENDS= ${PEARDIR}/.channels/pear.phpunit.de.reg:${PORTSDIR}/devel/pear-channel-phpunit
+RUN_DEPENDS= ${PEARDIR}/.channels/pear.phpunit.de.reg:${PORTSDIR}/devel/pear-channel-phpunit
+USES= pear
PEAR_CHANNEL= phpunit
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-XML_Beautifier/Makefile b/textproc/pear-XML_Beautifier/Makefile
index b935ce4d291c..7ff830db5b4d 100644
--- a/textproc/pear-XML_Beautifier/Makefile
+++ b/textproc/pear-XML_Beautifier/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
RUN_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
${PEARDIR}/XML/Util.php:${PORTSDIR}/devel/pear-XML_Util
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-XML_DTD/Makefile b/textproc/pear-XML_DTD/Makefile
index 3a91d50e25aa..85957c97ab0f 100644
--- a/textproc/pear-XML_DTD/Makefile
+++ b/textproc/pear-XML_DTD/Makefile
@@ -8,14 +8,9 @@ CATEGORIES= textproc devel pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Parsing of DTD files and DTD validation of XML files
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
+BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
+RUN_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
-USES= dos2unix
-PEAR_AUTOINSTALL= yes
+USES= dos2unix pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-XML_Feed_Parser/Makefile b/textproc/pear-XML_Feed_Parser/Makefile
index 6d05ca8b9819..416994bf5030 100644
--- a/textproc/pear-XML_Feed_Parser/Makefile
+++ b/textproc/pear-XML_Feed_Parser/Makefile
@@ -8,12 +8,6 @@ CATEGORIES= textproc devel pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Providing a unified API for handling Atom/RSS
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USE_PHP= tidy dom pear
-USE_PHP= tidy dom
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-XML_HTMLSax/Makefile b/textproc/pear-XML_HTMLSax/Makefile
index c3b9597ecbaa..e162d6cc4d19 100644
--- a/textproc/pear-XML_HTMLSax/Makefile
+++ b/textproc/pear-XML_HTMLSax/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= textproc devel pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR SAX parser for HTML and other badly formed XML documents
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-XML_Wddx/Makefile b/textproc/pear-XML_Wddx/Makefile
index 4fec88c80066..0590152a1cad 100644
--- a/textproc/pear-XML_Wddx/Makefile
+++ b/textproc/pear-XML_Wddx/Makefile
@@ -11,8 +11,6 @@ COMMENT= PEAR Wddx pretty serializer and deserializer
BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
RUN_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pear-YAML/Makefile b/textproc/pear-YAML/Makefile
index 08ee3615989b..ffb6c1f5dd8b 100644
--- a/textproc/pear-YAML/Makefile
+++ b/textproc/pear-YAML/Makefile
@@ -10,15 +10,10 @@ PKGNAMEPREFIX= pear-
MAINTAINER= miwi@FreeBSD.org
COMMENT= The Symfony YAML Component
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/.channels/pear.symfony-project.com.reg:${PORTSDIR}/devel/pear-channel-symfony
-
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/.channels/pear.symfony-project.com.reg:${PORTSDIR}/devel/pear-channel-symfony
+BUILD_DEPENDS= ${PEARDIR}/.channels/pear.symfony-project.com.reg:${PORTSDIR}/devel/pear-channel-symfony
+RUN_DEPENDS= ${PEARDIR}/.channels/pear.symfony-project.com.reg:${PORTSDIR}/devel/pear-channel-symfony
+USES= pear
PEAR_CHANNEL= symfony
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>