aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/intergif/Makefile31
-rw-r--r--graphics/intergif/distinfo2
-rw-r--r--graphics/intergif/files/patch-src-animlib.h24
-rw-r--r--graphics/intergif/pkg-descr24
5 files changed, 82 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f908313ba4fc..020088da51cd 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -222,6 +222,7 @@
SUBDIR += imlib2
SUBDIR += imlib2_loaders
SUBDIR += inkscape
+ SUBDIR += intergif
SUBDIR += inventor
SUBDIR += ipe
SUBDIR += irit
diff --git a/graphics/intergif/Makefile b/graphics/intergif/Makefile
new file mode 100644
index 000000000000..4fb908d0feca
--- /dev/null
+++ b/graphics/intergif/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: interGif
+# Date created: 31 August 2005
+# Whom: jamie
+#
+# $FreeBSD$
+#
+
+PORTNAME= interGif
+PORTVERSION= 6.15
+CATEGORIES= graphics
+MASTER_SITES= http://utter.chaos.org.uk/~pdh/software/arc/ \
+ http://ftp.bishopston.net/freebsd/distfiles/ \
+ ftp://ftp.bishopston.net/freebsd/distfiles/
+DISTNAME= ig615src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jamie@bishopston.net
+COMMENT= Efficient animated GIF optimiser
+
+WRKSRC= ${WRKDIR}/igsrc
+
+PLIST_FILES= bin/intergif
+ALL_TARGET= intergif
+
+pre-patch:
+ ${CP} -f ${WRKSRC}/makefile.ix ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/intergif ${PREFIX}/bin/intergif
+
+.include <bsd.port.mk>
diff --git a/graphics/intergif/distinfo b/graphics/intergif/distinfo
new file mode 100644
index 000000000000..8d21dc4966db
--- /dev/null
+++ b/graphics/intergif/distinfo
@@ -0,0 +1,2 @@
+MD5 (ig615src.tgz) = 1d9ab04e9bb42e7392f401b669bad508
+SIZE (ig615src.tgz) = 120400
diff --git a/graphics/intergif/files/patch-src-animlib.h b/graphics/intergif/files/patch-src-animlib.h
new file mode 100644
index 000000000000..75cce003c0b6
--- /dev/null
+++ b/graphics/intergif/files/patch-src-animlib.h
@@ -0,0 +1,24 @@
+--- src/animlib.h.orig Tue Oct 5 21:20:58 2004
++++ src/animlib.h Sun Sep 4 16:38:34 2005
+@@ -144,18 +144,18 @@
+
+ BOOL Anim_ConvertSprite( const void *spritedata, size_t size,
+ anim_animfn animfn, anim_imagefn fn, void *handle );
+-BOOL Anim_ConvertTCA( const void *tcadata, size_t size,
++BOOL Anim_ConvertTCA( const void *tcadata, unsigned int size,
+ anim_animfn animfn, anim_imagefn fn, void *handle );
+ BOOL Anim_ConvertDraw( const void *drawdata, size_t size,
+ anim_animfn animfn, anim_imagefn fn, void *handle );
+-BOOL Anim_ConvertGIF( const void *gifdata, size_t size,
++BOOL Anim_ConvertGIF( const void *gifdata, unsigned int size,
+ anim_animfn animfn, anim_imagefn fn, void *handle );
+
+ /* Very high-level constructors (calling these will link in *all* the above
+ * constructors)
+ */
+
+-BOOL Anim_ConvertData( const void *data, unsigned int size,
++BOOL Anim_ConvertData( const void *data, size_t size,
+ anim_animfn animfn, anim_imagefn fn, void *handle );
+ BOOL Anim_ConvertFile( const char *filename,
+ anim_animfn animfn, anim_imagefn fn, void *handle );
diff --git a/graphics/intergif/pkg-descr b/graphics/intergif/pkg-descr
new file mode 100644
index 000000000000..88aca0bb165f
--- /dev/null
+++ b/graphics/intergif/pkg-descr
@@ -0,0 +1,24 @@
+INTERGIF 6.15 is a program for joining GIFs together (for animation),
+or splitting animations apart, or for optimising animations created
+by other programs.
+* Supports the animation, transparency and interleaving features of GIF89a.
+* Eliminates unused palette entries.
+* Minimises the final size of the GIF with a devious and cunning optimisation
+ routine: almost every animated GIF the author has found on the web ends up
+ smaller when run through InterGif.
+* Can forcibly reduce a GIF's palette to the standard Acorn 256-colour palette,
+ or to a 216-entry "web safe" colour cube (as used on the Macintosh and by
+ most Windows browsers),or to a palette file you supply. Alternatively, it can
+ calculate the best palette for displaying the GIF, and then reduce to that.
+* From version 6.03, this also works with 16bpp and 24bpp input images -- and
+ with GIFs which use more than 256 colours in total. (GIFs can only use 256
+ colours per frame, but each frame can have its own palette.)
+* Lets you trim away any wholly transparent rows or columns from the edges of
+ your GIF (whether single-frame or animated).
+* Can dither 16bpp or 24bpp input files to whatever palette is required (error
+ diffusion implementation kindly donated by Martin Wurthner).
+
+WWW: http://utter.chaos.org.uk/~pdh/software/intergif.htm
+
+- Jamie
+jamie@bishopston.net