aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING9
-rw-r--r--databases/mysql-proxy/Makefile7
-rw-r--r--databases/mysql-proxy/distinfo5
-rw-r--r--databases/mysql-proxy/files/mysql-proxy.in (renamed from databases/mysql-proxy/files/mysql-proxy.sh.in)2
-rw-r--r--databases/mysql-proxy/pkg-plist10
5 files changed, 25 insertions, 8 deletions
diff --git a/UPDATING b/UPDATING
index 1510286e9a17..0029f7ec9e01 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,15 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20101211:
+ AFFECTS: users of databases/mysql-proxy
+ AUTHOR: Florian Smeets <flo@smeets.im>
+
+ The parameters --admin-username and --admin-password are mandatory now.
+ Add something like the following to rc.conf
+
+ mysql_proxy_args="--admin-username admin --admin-password somepassword"
+
20101210:
AFFECTS: users of multimedia/avidemux2
AUTHOR: nox@FreeBSD.org
diff --git a/databases/mysql-proxy/Makefile b/databases/mysql-proxy/Makefile
index 66d77e2bac0f..33f8c1e256df 100644
--- a/databases/mysql-proxy/Makefile
+++ b/databases/mysql-proxy/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mysql-proxy
-PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTVERSION= 0.8.1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
MASTER_SITE_SUBDIR= MySQL-Proxy
@@ -18,7 +17,7 @@ COMMENT= Monitor, analyze or transform the communication of MySQL
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent \
glib:${PORTSDIR}/devel/glib20
-CONFIGURE_ARGS+= --with-lua=lua-5.1 --with-mysql --docdir=${DATADIR} --enable-self-contained
+CONFIGURE_ARGS+= --with-lua=lua-5.1 --with-mysql=${LOCALBASE}/bin/mysql_config --docdir=${DATADIR} --enable-self-contained
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -L${LUA_LIBDIR}" \
PKG_CONFIG_PATH="${LUA_PREFIX}/share/doc/${LUA_SUBDIR}/etc"
@@ -28,7 +27,7 @@ USE_ICONV= yes
USE_LDCONFIG= yes
USE_LUA= 5.1+
USE_MYSQL= yes
-USE_RC_SUBR= mysql-proxy.sh
+USE_RC_SUBR= mysql-proxy
IGNORE_WITH_MYSQL= 323 40 41
.include <bsd.port.mk>
diff --git a/databases/mysql-proxy/distinfo b/databases/mysql-proxy/distinfo
index c61a92892354..61b7309d84ba 100644
--- a/databases/mysql-proxy/distinfo
+++ b/databases/mysql-proxy/distinfo
@@ -1,3 +1,2 @@
-MD5 (mysql-proxy-0.8.0.tar.gz) = b6a9748d72e8db7fe3789fbdd60ff451
-SHA256 (mysql-proxy-0.8.0.tar.gz) = 0a195fe0f86d12df8d9ffc27e91347680521c8702460bac5ed591608a740bc1c
-SIZE (mysql-proxy-0.8.0.tar.gz) = 756371
+SHA256 (mysql-proxy-0.8.1.tar.gz) = d59a5d0bf536999d067982bbbe92650cbcb84e6ba5d6fddb9778de92c07a7093
+SIZE (mysql-proxy-0.8.1.tar.gz) = 788570
diff --git a/databases/mysql-proxy/files/mysql-proxy.sh.in b/databases/mysql-proxy/files/mysql-proxy.in
index fe328e56a363..79704eb9ddf5 100644
--- a/databases/mysql-proxy/files/mysql-proxy.sh.in
+++ b/databases/mysql-proxy/files/mysql-proxy.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/databases/mysql-proxy/files/Attic/mysql-proxy.sh.in,v 1.4 2010-03-27 00:12:46 dougb Exp $
+# $FreeBSD$
#
# PROVIDE: mysql-proxy
diff --git a/databases/mysql-proxy/pkg-plist b/databases/mysql-proxy/pkg-plist
index a8ef7bd1d659..a04a0b0fccf9 100644
--- a/databases/mysql-proxy/pkg-plist
+++ b/databases/mysql-proxy/pkg-plist
@@ -24,6 +24,12 @@ include/chassis-path.h
include/chassis-filemode.h
include/chassis-limits.h
include/chassis-event-thread.h
+include/chassis-gtimeval.h
+include/chassis-shutdown-hooks.h
+include/chassis-frontend.h
+include/chassis-options.h
+include/chassis-win32-service.h
+include/chassis-unix-daemon.h
include/glib-ext.h
include/glib-ext-ref.h
include/string-len.h
@@ -52,9 +58,13 @@ lib/libmysql-chassis.la
lib/libmysql-chassis-timing.so.0
lib/libmysql-chassis-timing.so
lib/libmysql-chassis-timing.la
+lib/libmysql-chassis-glibext.so.0
+lib/libmysql-chassis-glibext.so
+lib/libmysql-chassis-glibext.la
lib/libmysql-proxy.so.0
lib/libmysql-proxy.so
lib/libmysql-proxy.la
+lib/mysql-proxy/lua/admin.lua
lib/mysql-proxy/lua/lfs.so
lib/mysql-proxy/lua/lfs.la
lib/mysql-proxy/lua/glib2.so