aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/flake/Makefile3
-rw-r--r--audio/gigedit/Makefile4
-rw-r--r--irc/scrollz/Makefile4
-rw-r--r--mail/mailutils/Makefile1
-rw-r--r--misc/floatator/Makefile1
-rw-r--r--multimedia/mplayerxp/Makefile5
-rw-r--r--net/tcpview/Makefile2
-rw-r--r--net/trickle/Makefile8
8 files changed, 16 insertions, 12 deletions
diff --git a/audio/flake/Makefile b/audio/flake/Makefile
index c78eff957465..95e073b8b01a 100644
--- a/audio/flake/Makefile
+++ b/audio/flake/Makefile
@@ -14,7 +14,8 @@ LICENSE= LGPL21
HAS_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
+MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/flake include/flake.h lib/libflake.a
diff --git a/audio/gigedit/Makefile b/audio/gigedit/Makefile
index 8eb639c12a7c..f6c66a9f6b98 100644
--- a/audio/gigedit/Makefile
+++ b/audio/gigedit/Makefile
@@ -19,9 +19,9 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake
USE_LDCONFIG= yes
USE_GNOME= intltool
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.mk>
diff --git a/irc/scrollz/Makefile b/irc/scrollz/Makefile
index 85a70df00d1f..9f2451836b1a 100644
--- a/irc/scrollz/Makefile
+++ b/irc/scrollz/Makefile
@@ -12,12 +12,12 @@ DISTNAME= ScrollZ-${PORTVERSION}
MAINTAINER= mdv@unsavoury.net
COMMENT= Enhanced ircII client that supports scripts, colors, and more
-USES= iconv ncurses
-USE_GMAKE= yes
+USES= gmake iconv ncurses
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-ipv6 --enable-regexp --enable-iconv
MAKE_ENV+= IRCLIB="${PREFIX}/share/scrollz"
+MAKE_JOBS_UNSAFE= yes
PLIST_SUB+= SCROLLZ_VER="${PORTVERSION}"
PORTDATA= *
diff --git a/mail/mailutils/Makefile b/mail/mailutils/Makefile
index 3f94d899dcd2..721c32da7a8d 100644
--- a/mail/mailutils/Makefile
+++ b/mail/mailutils/Makefile
@@ -13,6 +13,7 @@ COMMENT= Mailutils offers utilities and daemons for processing e-mail
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS+=--disable-build-comsat
+MAKE_JOBS_UNSAFE= yes
LDFLAGS= -L${LOCALBASE}/lib
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/${PORTNAME}
diff --git a/misc/floatator/Makefile b/misc/floatator/Makefile
index bead9abe7af8..83fcf420a05f 100644
--- a/misc/floatator/Makefile
+++ b/misc/floatator/Makefile
@@ -17,6 +17,7 @@ USES= motif
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DNDEBUG" \
X11INCLUDE="-I${LOCALBASE}/include" X11LIB="-L${LOCALBASE}/lib"
PLIST_FILES= bin/floatator bin/floatator_X_interface
+MAKE_JOBS_UNSAFE= yes
do-install:
.for f in floatator floatator_X_interface
diff --git a/multimedia/mplayerxp/Makefile b/multimedia/mplayerxp/Makefile
index c5f050595dd0..260d7da426e7 100644
--- a/multimedia/mplayerxp/Makefile
+++ b/multimedia/mplayerxp/Makefile
@@ -23,10 +23,11 @@ WIN32_DESC= Enable win32 codec set
OPTIONS_DEFAULT= WIN32
ONLY_FOR_ARCHS= i386
+MAKE_JOBS_UNSAFE= yes
+
USE_BZIP2= yes
USE_XORG= xinerama xv xxf86dga xxf86vm
-USES= iconv
-USE_GMAKE= yes
+USES= iconv gmake
HAS_CONFIGURE= yes
WANT_SDL= yes
USE_LDCONFIG= yes
diff --git a/net/tcpview/Makefile b/net/tcpview/Makefile
index ea76cb66ebe9..d00f2dc55281 100644
--- a/net/tcpview/Makefile
+++ b/net/tcpview/Makefile
@@ -13,6 +13,8 @@ COMMENT= Motif-based TCP/IP protocol analyzer
USES= bison motif
+MAKE_JOBS_UNSAFE= yes
+
MAN1= tcpview.1
.include <bsd.port.pre.mk>
diff --git a/net/trickle/Makefile b/net/trickle/Makefile
index 911c88cb444d..9c709c5af912 100644
--- a/net/trickle/Makefile
+++ b/net/trickle/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: trickle
-# Date created: 04.06.2003
-# Whom: Kirill Ponomarew <ponomarew@oberon.net>
-#
+# Created by: Kirill Ponomarew <ponomarew@oberon.net>
# $FreeBSD$
-#
PORTNAME= trickle
PORTVERSION= 1.07
@@ -20,6 +16,8 @@ USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
+
CONFIGURE_ARGS+=--with-libevent=${LOCALBASE} \
--sysconfdir=${PREFIX}/etc
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"