aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/kshutdown-kde4/Makefile9
-rw-r--r--sysutils/kshutdown-kde4/distinfo4
-rw-r--r--sysutils/kshutdown-kde4/files/patch-src__CMakeLists.txt14
-rw-r--r--sysutils/kshutdown-kde4/pkg-plist4
4 files changed, 20 insertions, 11 deletions
diff --git a/sysutils/kshutdown-kde4/Makefile b/sysutils/kshutdown-kde4/Makefile
index 7c711f3cef6e..4f522d04d22c 100644
--- a/sysutils/kshutdown-kde4/Makefile
+++ b/sysutils/kshutdown-kde4/Makefile
@@ -1,18 +1,17 @@
# $FreeBSD$
PORTNAME= kshutdown
-DISTVERSION= 3.0beta6
-PORTREVISION= 4
+DISTVERSION= 3.2
CATEGORIES= sysutils kde
-MASTER_SITES= SF/${PORTNAME}/KShutdown/3.0%20Beta%206/
+MASTER_SITES= SF/${PORTNAME}/KShutdown/${DISTVERSION}/
DISTNAME= ${PORTNAME}-source-${DISTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Advanced shutdown utility for KDE
-USES= cmake zip
+USES= cmake:outsource compiler:c++0x zip
USE_QT4= moc_build qmake_build rcc_build uic_build
-USE_KDE4= automoc4 kdehier kdeprefix workspace
+USE_KDE4= automoc4 kdeprefix workspace
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
diff --git a/sysutils/kshutdown-kde4/distinfo b/sysutils/kshutdown-kde4/distinfo
index d1c917287d6a..f68d7337e5dc 100644
--- a/sysutils/kshutdown-kde4/distinfo
+++ b/sysutils/kshutdown-kde4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (kshutdown-source-3.0beta6.zip) = dfe89f124e68ae3f5b859fc02ad4d37726b3e001ee6b02f1bb1f6281fbef45cf
-SIZE (kshutdown-source-3.0beta6.zip) = 425793
+SHA256 (kshutdown-source-3.2.zip) = 8be6c2a15bb539919f94ec0caf20f00b144185f996b7663c464fbf7ce8f4a39f
+SIZE (kshutdown-source-3.2.zip) = 435553
diff --git a/sysutils/kshutdown-kde4/files/patch-src__CMakeLists.txt b/sysutils/kshutdown-kde4/files/patch-src__CMakeLists.txt
new file mode 100644
index 000000000000..f4a660aab924
--- /dev/null
+++ b/sysutils/kshutdown-kde4/files/patch-src__CMakeLists.txt
@@ -0,0 +1,14 @@
+--- src/CMakeLists.txt.orig 2014-10-12 13:00:51 UTC
++++ src/CMakeLists.txt
+@@ -47,10 +47,7 @@
+
+ target_link_libraries(kshutdown kdecore kdeui kio ${KDE4_KNOTIFYCONFIG_LIBS} ${KDE4_KUTILS_LIBS})
+
+-install(
+- PROGRAMS "${CMAKE_CURRENT_BINARY_DIR}/kshutdown"
+- DESTINATION bin
+-)
++install(TARGETS kshutdown RUNTIME DESTINATION bin)
+ install(FILES kshutdown.desktop DESTINATION ${XDG_APPS_INSTALL_DIR})
+ install(FILES kshutdown.notifyrc DESTINATION ${DATA_INSTALL_DIR}/kshutdown)
+
diff --git a/sysutils/kshutdown-kde4/pkg-plist b/sysutils/kshutdown-kde4/pkg-plist
index 812585984510..6b7d4e80e3a0 100644
--- a/sysutils/kshutdown-kde4/pkg-plist
+++ b/sysutils/kshutdown-kde4/pkg-plist
@@ -43,7 +43,3 @@ share/locale/sr@latin/LC_MESSAGES/kshutdown.mo
share/locale/sv/LC_MESSAGES/kshutdown.mo
share/locale/tr/LC_MESSAGES/kshutdown.mo
share/locale/zh_CN/LC_MESSAGES/kshutdown.mo
-@dirrm share/apps/kshutdown/extras/system
-@dirrm share/apps/kshutdown/extras/multimedia
-@dirrm share/apps/kshutdown/extras
-@dirrm share/apps/kshutdown