aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/p5-Archive-Any-Lite/Makefile27
-rw-r--r--archivers/p5-Archive-Any-Lite/distinfo2
-rw-r--r--archivers/p5-Archive-Any-Lite/pkg-descr7
-rw-r--r--archivers/p5-Archive-Any-Lite/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index a76f1eaa0db3..7af97e387e4e 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -88,6 +88,7 @@
SUBDIR += ocaml-bz2
SUBDIR += ocaml-zip
SUBDIR += p5-Archive-Any
+ SUBDIR += p5-Archive-Any-Lite
SUBDIR += p5-Archive-Any-Plugin-Rar
SUBDIR += p5-Archive-Extract
SUBDIR += p5-Archive-Extract-Libarchive
diff --git a/archivers/p5-Archive-Any-Lite/Makefile b/archivers/p5-Archive-Any-Lite/Makefile
new file mode 100644
index 000000000000..848b3a178726
--- /dev/null
+++ b/archivers/p5-Archive-Any-Lite/Makefile
@@ -0,0 +1,27 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Archive-Any-Lite
+PORTVERSION= 0.07
+CATEGORIES= archivers perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple CPAN package extractor
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Pod>=1.18:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=1.04:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ p5-Test-UseAllModules>=0.10:${PORTSDIR}/devel/p5-Test-UseAllModules
+
+USE_PERL5= configure
+USES= perl5
+
+MAN3= Archive::Any::Lite.3
+
+.include <bsd.port.mk>
diff --git a/archivers/p5-Archive-Any-Lite/distinfo b/archivers/p5-Archive-Any-Lite/distinfo
new file mode 100644
index 000000000000..687838812838
--- /dev/null
+++ b/archivers/p5-Archive-Any-Lite/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Archive-Any-Lite-0.07.tar.gz) = d70407c97785cc63c517cf46a9f25325fb140efbf573a3b688fec8cf5c23b943
+SIZE (Archive-Any-Lite-0.07.tar.gz) = 21207
diff --git a/archivers/p5-Archive-Any-Lite/pkg-descr b/archivers/p5-Archive-Any-Lite/pkg-descr
new file mode 100644
index 000000000000..9cfffb1a5f7f
--- /dev/null
+++ b/archivers/p5-Archive-Any-Lite/pkg-descr
@@ -0,0 +1,7 @@
+Archive::Any::Lite is a fork of Archive::Any. The main difference is this works
+properly even when you fork(), and may require less memory to extract a tarball.
+On the other hand, this isn't pluggable (this only supports file formats used in
+the CPAN toolchains), and this doesn't check mime types (at least as of this
+writing).
+
+WWW: http://search.cpan.org/dist/Archive-Any-Lite/
diff --git a/archivers/p5-Archive-Any-Lite/pkg-plist b/archivers/p5-Archive-Any-Lite/pkg-plist
new file mode 100644
index 000000000000..c531f6204f5b
--- /dev/null
+++ b/archivers/p5-Archive-Any-Lite/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Archive/Any/Lite.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive/Any/Lite/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive/Any/Lite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive/Any
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive
+@dirrmtry %%SITE_PERL%%/Archive/Any
+@dirrmtry %%SITE_PERL%%/Archive