aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-compat/Makefile23
-rw-r--r--www/py-django-compat/distinfo3
-rw-r--r--www/py-django-compat/pkg-descr9
4 files changed, 36 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 54ecad9b822b..28c6bc2353d2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1477,6 +1477,7 @@
SUBDIR += py-django-classy-tags
SUBDIR += py-django-cms
SUBDIR += py-django-common-helpers
+ SUBDIR += py-django-compat
SUBDIR += py-django-configurations
SUBDIR += py-django-constance
SUBDIR += py-django-contact-form
diff --git a/www/py-django-compat/Makefile b/www/py-django-compat/Makefile
new file mode 100644
index 000000000000..d1d256b32d42
--- /dev/null
+++ b/www/py-django-compat/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= django-compat
+PORTVERSION= 1.0.15
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@caomhin.org
+COMMENT= For- and backwards compatibility layer for different Django versions
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django22>=1.4:www/py-django22@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-compat/distinfo b/www/py-django-compat/distinfo
new file mode 100644
index 000000000000..2e1dbabec3ed
--- /dev/null
+++ b/www/py-django-compat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1590387237
+SHA256 (django-compat-1.0.15.tar.gz) = 3ac9a3bedc56b9365d9eb241bc5157d0c193769bf995f9a78dc1bc24e7c2331b
+SIZE (django-compat-1.0.15.tar.gz) = 21980
diff --git a/www/py-django-compat/pkg-descr b/www/py-django-compat/pkg-descr
new file mode 100644
index 000000000000..0de39c59bfee
--- /dev/null
+++ b/www/py-django-compat/pkg-descr
@@ -0,0 +1,9 @@
+Forward and backwards compatibility layer for different Django versions.
+
+Reasons to use django-compat:
+
+* Be able to use LTS versions of Django and support newer versions in an app
+* Use features from newer Django versions in an old one
+* Manage and master the gap between different framework versions
+
+WWW: https://github.com/arteria/django-compat