aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/gworkspace/Makefile5
-rw-r--r--games/gshisen/Makefile5
-rw-r--r--misc/gnustep-examples/Makefile5
-rw-r--r--x11-toolkits/gtoolkit/Makefile2
4 files changed, 17 insertions, 0 deletions
diff --git a/deskutils/gworkspace/Makefile b/deskutils/gworkspace/Makefile
index 2629df61d413..59df564b62ba 100644
--- a/deskutils/gworkspace/Makefile
+++ b/deskutils/gworkspace/Makefile
@@ -30,6 +30,7 @@ MAKE_ENV+= ADDITIONAL_LDFLAGS="${ADDITIONAL_LDFLAGS}"
DEFAULT_LIBVERSION2= 0.1.0
PLIST_SUB+= LIBVERSION2=${DEFAULT_LIBVERSION2}
PLIST_SUB+= MAJORLIBVERSION2=${DEFAULT_LIBVERSION2:C/([0-9]).*/\1/1}
+USE_REINPLACE= yes
.if defined(WITHOUT_GHOSTSCRIPT)
PLIST_SUB+= PDFVIEW="@comment "
@@ -38,4 +39,8 @@ PLIST_SUB+= PDFVIEW=""
USE_GHOSTSCRIPT= yes
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|)/Makefiles|)/Library/Makefiles|' \
+ ${WRKSRC}/FSNode/GNUmakefile
+
.include <bsd.port.mk>
diff --git a/games/gshisen/Makefile b/games/gshisen/Makefile
index 629b1d4426e6..3aa4b6fa131d 100644
--- a/games/gshisen/Makefile
+++ b/games/gshisen/Makefile
@@ -23,6 +23,11 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
MAKEFILE=
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|)/Makefiles|)/Library/Makefiles|' \
+ ${WRKSRC}/GNUmakefile
.include <bsd.port.pre.mk>
diff --git a/misc/gnustep-examples/Makefile b/misc/gnustep-examples/Makefile
index 11f47c6ed953..eeeb0a1298dd 100644
--- a/misc/gnustep-examples/Makefile
+++ b/misc/gnustep-examples/Makefile
@@ -24,10 +24,15 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
MAKEFILE= GNUmakefile
+USE_REINPLACE= yes
MAKE_APPS= Finger GFractal GPuzzle HostAddress
INSTALL_APPS= Finger GFractal GPuzzle HostAddress
+post-patch:
+ ${REINPLACE_CMD} -e 's|)/Makefiles|)/Library/Makefiles|' \
+ ${WRKSRC}/gui/GPuzzle/GNUmakefile
+
post-build:
.for i in ${MAKE_APPS}
@(cd ${WRKSRC}/gui/${i}; . ${SYSMAKEDIR}/GNUstep.sh; \
diff --git a/x11-toolkits/gtoolkit/Makefile b/x11-toolkits/gtoolkit/Makefile
index f3ac638cd158..aa3d2ff78e19 100644
--- a/x11-toolkits/gtoolkit/Makefile
+++ b/x11-toolkits/gtoolkit/Makefile
@@ -36,6 +36,8 @@ CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}
post-patch:
${REINPLACE_CMD} -e 's#gtk-config#gtk12-config#g' \
${CONFIGURE_WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|)/Makefiles|)/Library/Makefiles|' \
+ ${WRKSRC}/Makefile.gnustep
.include <bsd.port.pre.mk>