aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/wxgtk-docs/Makefile34
-rw-r--r--x11-toolkits/wxgtk-docs/distinfo1
-rw-r--r--x11-toolkits/wxgtk-docs/pkg-descr3
-rw-r--r--x11-toolkits/wxgtk-docs/pkg-plist1
-rw-r--r--x11-toolkits/wxgtk24-docs/Makefile34
-rw-r--r--x11-toolkits/wxgtk24-docs/distinfo1
-rw-r--r--x11-toolkits/wxgtk24-docs/pkg-descr3
-rw-r--r--x11-toolkits/wxgtk24-docs/pkg-plist1
9 files changed, 79 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 0270c28a4286..70c92ddd7717 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -177,6 +177,7 @@
SUBDIR += wmapp
SUBDIR += wxgtk
SUBDIR += wxgtk-devel
+ SUBDIR += wxgtk-docs
SUBDIR += xbae
SUBDIR += xclasses
SUBDIR += xenophilia
diff --git a/x11-toolkits/wxgtk-docs/Makefile b/x11-toolkits/wxgtk-docs/Makefile
new file mode 100644
index 000000000000..122b4b270a2d
--- /dev/null
+++ b/x11-toolkits/wxgtk-docs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: wxgtk_doc
+# Date created: 1 Apr 23:51:14 2003 CEST
+# Whom: Michal Pasternak <dotz@irc.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxgtk_doc
+PORTVERSION= 2.4.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= wxwindows
+DISTNAME= wxWindows-${PORTVERSION}-HTML
+
+MAINTAINER= dotz@irc.pl
+COMMENT= wxWindows documentation in HTML
+
+NO_BUILD= YES
+USE_ZIP= YES
+
+WXGTKDOCDIR= ${PREFIX}/share/doc/${PORTNAME}/html/
+WRKSRC= ${WRKDIR}/wxWindows-${PORTVERSION}/docs/html/
+
+do-install:
+ @${MKDIR} ${WXGTKDOCDIR}
+ @${CP} -R ${WRKSRC}/* ${WXGTKDOCDIR}
+
+post-install:
+ @(cd ${WRKSRC} && ${FIND} * -type f | ${XARGS} printf "share/doc/${PORTNAME}/html/%s\n" >> ${TMPPLIST})
+ @(cd ${WRKSRC} && ${FIND} * -type d | ${XARGS} printf "@dirrm share/doc/${PORTNAME}/html/%s\n" >> ${TMPPLIST})
+ @${ECHO} @dirrm share/doc/${PORTNAME}/html >> ${TMPPLIST}
+ @${ECHO} @dirrm share/doc/${PORTNAME} >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/wxgtk-docs/distinfo b/x11-toolkits/wxgtk-docs/distinfo
new file mode 100644
index 000000000000..3b13d8232e48
--- /dev/null
+++ b/x11-toolkits/wxgtk-docs/distinfo
@@ -0,0 +1 @@
+MD5 (wxWindows-2.4.0-HTML.zip) = 5eb22380d408f770af565639cbf8b34f
diff --git a/x11-toolkits/wxgtk-docs/pkg-descr b/x11-toolkits/wxgtk-docs/pkg-descr
new file mode 100644
index 000000000000..9a66e42e3cf6
--- /dev/null
+++ b/x11-toolkits/wxgtk-docs/pkg-descr
@@ -0,0 +1,3 @@
+wxGTK documentation
+
+WWW: http://www.wxwindows.org/
diff --git a/x11-toolkits/wxgtk-docs/pkg-plist b/x11-toolkits/wxgtk-docs/pkg-plist
new file mode 100644
index 000000000000..435f005646ca
--- /dev/null
+++ b/x11-toolkits/wxgtk-docs/pkg-plist
@@ -0,0 +1 @@
+@comment automatically generated plist
diff --git a/x11-toolkits/wxgtk24-docs/Makefile b/x11-toolkits/wxgtk24-docs/Makefile
new file mode 100644
index 000000000000..122b4b270a2d
--- /dev/null
+++ b/x11-toolkits/wxgtk24-docs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: wxgtk_doc
+# Date created: 1 Apr 23:51:14 2003 CEST
+# Whom: Michal Pasternak <dotz@irc.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxgtk_doc
+PORTVERSION= 2.4.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= wxwindows
+DISTNAME= wxWindows-${PORTVERSION}-HTML
+
+MAINTAINER= dotz@irc.pl
+COMMENT= wxWindows documentation in HTML
+
+NO_BUILD= YES
+USE_ZIP= YES
+
+WXGTKDOCDIR= ${PREFIX}/share/doc/${PORTNAME}/html/
+WRKSRC= ${WRKDIR}/wxWindows-${PORTVERSION}/docs/html/
+
+do-install:
+ @${MKDIR} ${WXGTKDOCDIR}
+ @${CP} -R ${WRKSRC}/* ${WXGTKDOCDIR}
+
+post-install:
+ @(cd ${WRKSRC} && ${FIND} * -type f | ${XARGS} printf "share/doc/${PORTNAME}/html/%s\n" >> ${TMPPLIST})
+ @(cd ${WRKSRC} && ${FIND} * -type d | ${XARGS} printf "@dirrm share/doc/${PORTNAME}/html/%s\n" >> ${TMPPLIST})
+ @${ECHO} @dirrm share/doc/${PORTNAME}/html >> ${TMPPLIST}
+ @${ECHO} @dirrm share/doc/${PORTNAME} >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/wxgtk24-docs/distinfo b/x11-toolkits/wxgtk24-docs/distinfo
new file mode 100644
index 000000000000..3b13d8232e48
--- /dev/null
+++ b/x11-toolkits/wxgtk24-docs/distinfo
@@ -0,0 +1 @@
+MD5 (wxWindows-2.4.0-HTML.zip) = 5eb22380d408f770af565639cbf8b34f
diff --git a/x11-toolkits/wxgtk24-docs/pkg-descr b/x11-toolkits/wxgtk24-docs/pkg-descr
new file mode 100644
index 000000000000..9a66e42e3cf6
--- /dev/null
+++ b/x11-toolkits/wxgtk24-docs/pkg-descr
@@ -0,0 +1,3 @@
+wxGTK documentation
+
+WWW: http://www.wxwindows.org/
diff --git a/x11-toolkits/wxgtk24-docs/pkg-plist b/x11-toolkits/wxgtk24-docs/pkg-plist
new file mode 100644
index 000000000000..435f005646ca
--- /dev/null
+++ b/x11-toolkits/wxgtk24-docs/pkg-plist
@@ -0,0 +1 @@
+@comment automatically generated plist