aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/codeworker/Makefile33
-rw-r--r--devel/codeworker/distinfo1
-rw-r--r--devel/codeworker/files/patch-CGRuntime.cpp13
-rw-r--r--devel/codeworker/files/patch-UtlTimer.cpp10
-rw-r--r--devel/codeworker/pkg-descr13
-rw-r--r--devel/codeworker/pkg-plist1
7 files changed, 72 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ef3ab6b907f9..70bb3ad07551 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -125,6 +125,7 @@
SUBDIR += clo++
SUBDIR += cmake
SUBDIR += codecrusader
+ SUBDIR += codeworker
SUBDIR += commoncpp
SUBDIR += cons
SUBDIR += cons-test
diff --git a/devel/codeworker/Makefile b/devel/codeworker/Makefile
new file mode 100644
index 000000000000..165ac529163a
--- /dev/null
+++ b/devel/codeworker/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: CodeWorker
+# Date created: Dec 31, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= codeworker
+PORTVERSION= 3.2
+CATEGORIES= devel
+MASTER_SITES= http://codeworker.free.fr/downloads/
+DISTNAME= CodeWorker_SRC${PORTVERSION:S/./_/}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A parsing tool and a source code generator
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+LDFLAGS+= -lcompat
+USE_GMAKE= yes
+MAKE_ENV= LDFLAGS="${LDFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CXXFLAGS|#CXXFLAGS|g" \
+ -e s"|LFLAGS|LDFLAGS|" -e "s|^LDFLAGS|#LDFLAGS|" \
+ -e "s|CC|CXX|g" -e "s|^CXX|#CXX|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/CodeWorker ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/codeworker/distinfo b/devel/codeworker/distinfo
new file mode 100644
index 000000000000..e46c210c257d
--- /dev/null
+++ b/devel/codeworker/distinfo
@@ -0,0 +1 @@
+MD5 (CodeWorker_SRC3_2.zip) = 3b81568ee2c842a184ab5b3cd6577cfe
diff --git a/devel/codeworker/files/patch-CGRuntime.cpp b/devel/codeworker/files/patch-CGRuntime.cpp
new file mode 100644
index 000000000000..150f98f5e641
--- /dev/null
+++ b/devel/codeworker/files/patch-CGRuntime.cpp
@@ -0,0 +1,13 @@
+--- CGRuntime.cpp.orig Wed Dec 31 09:56:40 2003
++++ CGRuntime.cpp Wed Dec 31 09:57:16 2003
+@@ -60,6 +60,10 @@
+ # endif
+ # include "UtlString.h" // for Debian/gcc 2.95.4
+ #endif
++
++#if defined(__FreeBSD__)
++ extern char **environ;
++#endif
+
+
+ #ifndef WIN32
diff --git a/devel/codeworker/files/patch-UtlTimer.cpp b/devel/codeworker/files/patch-UtlTimer.cpp
new file mode 100644
index 000000000000..c52c67fe468d
--- /dev/null
+++ b/devel/codeworker/files/patch-UtlTimer.cpp
@@ -0,0 +1,10 @@
+--- UtlTimer.cpp.orig Wed Dec 31 10:07:18 2003
++++ UtlTimer.cpp Wed Dec 31 10:09:12 2003
+@@ -30,6 +30,7 @@
+ # include "windows.h"
+ # include "winbase.h"
+ #else
++# include <time.h>
+ # include <sys/timeb.h>
+ #endif
+
diff --git a/devel/codeworker/pkg-descr b/devel/codeworker/pkg-descr
new file mode 100644
index 000000000000..3ce9c8f9a545
--- /dev/null
+++ b/devel/codeworker/pkg-descr
@@ -0,0 +1,13 @@
+CodeWorker is a parsing tool and a source code generator, available in Open
+Source (distributed under the GNU Lesser General Public License) devoted to
+cover many aspects of the generative programming. Generative programming is
+a software engineering approach for producing reusable, tailor-made, evolvable
+and reliable IT systems with a high level of automation.
+
+The tool interprets a scripting language that drives the processing of parsing
+and source code generation in a quite familiar syntax for developers. It
+insists on adapting the syntax of the language to the particularities of tasks
+to resolve (parse, code generation, procedural) and on offering powerful
+functionalities to do intensive source code generation.
+
+WWW: http://www.codeworker.org/
diff --git a/devel/codeworker/pkg-plist b/devel/codeworker/pkg-plist
new file mode 100644
index 000000000000..a1ed8263c176
--- /dev/null
+++ b/devel/codeworker/pkg-plist
@@ -0,0 +1 @@
+bin/CodeWorker