aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/exim-devel/Makefile1
-rw-r--r--mail/exim-devel/files/patch-src::filter.c31
-rw-r--r--mail/exim-old/Makefile1
-rw-r--r--mail/exim-old/files/patch-src::filter.c31
-rw-r--r--mail/exim/Makefile1
-rw-r--r--mail/exim/files/patch-src::filter.c31
6 files changed, 96 insertions, 0 deletions
diff --git a/mail/exim-devel/Makefile b/mail/exim-devel/Makefile
index 05d315fb7ae3..fbee0a6e3e4c 100644
--- a/mail/exim-devel/Makefile
+++ b/mail/exim-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.33
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
diff --git a/mail/exim-devel/files/patch-src::filter.c b/mail/exim-devel/files/patch-src::filter.c
new file mode 100644
index 000000000000..5b662add1022
--- /dev/null
+++ b/mail/exim-devel/files/patch-src::filter.c
@@ -0,0 +1,31 @@
+Fix the message_body_size filter variable bug reported by Phil Chambers
+to the exim-users mailing list on 2001-09-19 using the patch posted to
+the list by the author on 2001-09-24.
+
+--- src/filter.c.orig Wed Aug 15 13:09:09 2001
++++ src/filter.c Wed Sep 26 18:16:20 2001
+@@ -2566,7 +2566,7 @@
+ BOOL
+ filter_runtest(int fd, BOOL is_system, BOOL dot_ended)
+ {
+-int rc, body_len, action;
++int rc, body_len, action, header_size;
+ register int ch;
+ BOOL yield, delivered;
+ struct stat statbuf;
+@@ -2658,6 +2658,7 @@
+ s = message_body_end;
+ body_len = 0;
+ body_linecount = 0;
++header_size = message_size;
+
+ if (!dot_ended && !feof(stdin))
+ {
+@@ -2713,6 +2714,7 @@
+ }
+
+ message_body[body_len] = 0;
++message_body_size = message_size - header_size;
+
+ /* body_len stops at message_body_visible; it if got there, we may have
+ wrapped round in message_body_end. */
diff --git a/mail/exim-old/Makefile b/mail/exim-old/Makefile
index 05d315fb7ae3..fbee0a6e3e4c 100644
--- a/mail/exim-old/Makefile
+++ b/mail/exim-old/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.33
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
diff --git a/mail/exim-old/files/patch-src::filter.c b/mail/exim-old/files/patch-src::filter.c
new file mode 100644
index 000000000000..5b662add1022
--- /dev/null
+++ b/mail/exim-old/files/patch-src::filter.c
@@ -0,0 +1,31 @@
+Fix the message_body_size filter variable bug reported by Phil Chambers
+to the exim-users mailing list on 2001-09-19 using the patch posted to
+the list by the author on 2001-09-24.
+
+--- src/filter.c.orig Wed Aug 15 13:09:09 2001
++++ src/filter.c Wed Sep 26 18:16:20 2001
+@@ -2566,7 +2566,7 @@
+ BOOL
+ filter_runtest(int fd, BOOL is_system, BOOL dot_ended)
+ {
+-int rc, body_len, action;
++int rc, body_len, action, header_size;
+ register int ch;
+ BOOL yield, delivered;
+ struct stat statbuf;
+@@ -2658,6 +2658,7 @@
+ s = message_body_end;
+ body_len = 0;
+ body_linecount = 0;
++header_size = message_size;
+
+ if (!dot_ended && !feof(stdin))
+ {
+@@ -2713,6 +2714,7 @@
+ }
+
+ message_body[body_len] = 0;
++message_body_size = message_size - header_size;
+
+ /* body_len stops at message_body_visible; it if got there, we may have
+ wrapped round in message_body_end. */
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 05d315fb7ae3..fbee0a6e3e4c 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.33
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
diff --git a/mail/exim/files/patch-src::filter.c b/mail/exim/files/patch-src::filter.c
new file mode 100644
index 000000000000..5b662add1022
--- /dev/null
+++ b/mail/exim/files/patch-src::filter.c
@@ -0,0 +1,31 @@
+Fix the message_body_size filter variable bug reported by Phil Chambers
+to the exim-users mailing list on 2001-09-19 using the patch posted to
+the list by the author on 2001-09-24.
+
+--- src/filter.c.orig Wed Aug 15 13:09:09 2001
++++ src/filter.c Wed Sep 26 18:16:20 2001
+@@ -2566,7 +2566,7 @@
+ BOOL
+ filter_runtest(int fd, BOOL is_system, BOOL dot_ended)
+ {
+-int rc, body_len, action;
++int rc, body_len, action, header_size;
+ register int ch;
+ BOOL yield, delivered;
+ struct stat statbuf;
+@@ -2658,6 +2658,7 @@
+ s = message_body_end;
+ body_len = 0;
+ body_linecount = 0;
++header_size = message_size;
+
+ if (!dot_ended && !feof(stdin))
+ {
+@@ -2713,6 +2714,7 @@
+ }
+
+ message_body[body_len] = 0;
++message_body_size = message_size - header_size;
+
+ /* body_len stops at message_body_visible; it if got there, we may have
+ wrapped round in message_body_end. */