aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING13
-rw-r--r--graphics/jpeg-turbo/Makefile51
-rw-r--r--graphics/jpeg-turbo/distinfo (renamed from graphics/libjpeg-turbo/distinfo)0
-rw-r--r--graphics/jpeg-turbo/pkg-descr20
-rw-r--r--graphics/jpeg-turbo/pkg-plist24
-rw-r--r--graphics/libjpeg-turbo/Makefile57
-rw-r--r--graphics/libjpeg-turbo/pkg-descr2
-rw-r--r--graphics/libjpeg-turbo/pkg-plist24
8 files changed, 116 insertions, 75 deletions
diff --git a/UPDATING b/UPDATING
index 2122ed8fc4e8..e6c9dc4b9b5c 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,19 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20140823
+ AFFECTS: users of graphics/libjpeg-turbo
+ AUTHOR: adamw@FreeBSD.org
+
+ libjpeg-turbo installs its own unique library (libturbojpeg.so) and
+ a drop-in replacement for libjpeg.so. The drop-in replacement has been
+ split off into graphics/jpeg-turbo; libjpeg-turbo now installs only
+ libturbojpeg.so.
+
+ If you were using the libjpeg.so from graphics/libjpeg-turbo, you
+ should install graphics/jpeg-turbo AFTER upgrading the libjpeg-turbo
+ port.
+
+20140823
AFFECTS: users of TeXLive
AUTHOR: hrs@FreeBSD.org
diff --git a/graphics/jpeg-turbo/Makefile b/graphics/jpeg-turbo/Makefile
new file mode 100644
index 000000000000..6ee91b6122e0
--- /dev/null
+++ b/graphics/jpeg-turbo/Makefile
@@ -0,0 +1,51 @@
+# Created by: Denis Podolskiy <bytestore@yandex.ru>
+# $FreeBSD$
+
+PORTNAME= jpeg-turbo
+PORTVERSION= 1.3.0
+PORTREVISION?= 2
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
+DISTNAME= lib${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bytestore@yandex.ru
+COMMENT?= SIMD-accelerated JPEG codec which replaces libjpeg
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+
+ONLY_FOR_ARCHS= amd64 i386
+USES= libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SO_MAJOR_VERSION=${SOVERSION}
+CONFIGURE_ARGS= --with-jpeg8
+USE_LDCONFIG= yes
+ALL_TARGET= test
+INSTALL_TARGET= install-strip
+
+PLIST_SUB= SOVERSION=${SOVERSION}
+PORTDOCS= *
+PORTEXAMPLES= *
+
+# chase graphics/jpeg
+SOVERSION= 11
+
+OPTIONS_DEFINE= PIC
+PIC_DESC= Static library with PIC (required for VirtualGL)
+
+PIC_CONFIGURE_ON= --with-pic
+
+.if defined(SLAVE_PORT)
+PLIST_SUB+= JPEG="@comment " LIBTURBOJPEG=""
+.else
+PLIST_SUB+= JPEG="" LIBTURBOJPEG="@comment "
+CONFLICTS_INSTALL= jpeg-[0-9]*
+OPTIONS_DEFINE+=DOCS EXAMPLES
+CONFIGURE_ARGS+=--without-libturbojpeg
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e '/^docdir/s,=.*,= ${DOCSDIR},' \
+ -e '/^exampledir/s,=.*,= ${EXAMPLESDIR},' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/libjpeg-turbo/distinfo b/graphics/jpeg-turbo/distinfo
index fb53bf70a8bb..fb53bf70a8bb 100644
--- a/graphics/libjpeg-turbo/distinfo
+++ b/graphics/jpeg-turbo/distinfo
diff --git a/graphics/jpeg-turbo/pkg-descr b/graphics/jpeg-turbo/pkg-descr
new file mode 100644
index 000000000000..b4a2d1e103be
--- /dev/null
+++ b/graphics/jpeg-turbo/pkg-descr
@@ -0,0 +1,20 @@
+This is a drop-in replacement for the graphics/jpeg library. It does not
+include libturbojpeg.so (see graphics/libjpeg-turbo).
+
+libjpeg-turbo is a high-speed version of libjpeg for x86 and x86-64 processors
+which uses SIMD instructions (MMX, SSE2, etc.) to accelerate baseline JPEG
+compression and decompression.
+libjpeg-turbo is generally 2-4x as fast as the unmodified version
+of libjpeg, all else being equal.
+
+libjpeg-turbo was originally based on libjpeg/SIMD by Miyasaka Masaru,
+but the TigerVNC and VirtualGL projects made numerous enhancements to the codec,
+including improved support for Mac OS X, 64-bit support,
+support for 32-bit and big endian pixel formats (RGBA, ABGR, etc.),
+accelerated Huffman encoding/decoding, and various bug fixes.
+The goal was to produce a fully open source codec that could replace
+the partially closed source TurboJPEG/IPP codec used by VirtualGL and TurboVNC.
+libjpeg-turbo generally achieves 80-120% of the performance of TurboJPEG/IPP.
+It is faster in some areas but slower in others.
+
+WWW: http://libjpeg-turbo.virtualgl.org/
diff --git a/graphics/jpeg-turbo/pkg-plist b/graphics/jpeg-turbo/pkg-plist
new file mode 100644
index 000000000000..b51f17a84ae8
--- /dev/null
+++ b/graphics/jpeg-turbo/pkg-plist
@@ -0,0 +1,24 @@
+%%JPEG%%bin/cjpeg
+%%JPEG%%bin/djpeg
+%%JPEG%%bin/jpegtran
+%%JPEG%%bin/rdjpgcom
+%%JPEG%%bin/wrjpgcom
+%%JPEG%%include/jconfig.h
+%%JPEG%%include/jerror.h
+%%JPEG%%include/jmorecfg.h
+%%JPEG%%include/jpeglib.h
+%%JPEG%%lib/libjpeg.a
+%%JPEG%%lib/libjpeg.so
+%%JPEG%%lib/libjpeg.so.%%SOVERSION%%
+%%JPEG%%lib/libjpeg.so.%%SOVERSION%%.0.2
+%%JPEG%%man/man1/cjpeg.1.gz
+%%JPEG%%man/man1/djpeg.1.gz
+%%JPEG%%man/man1/jpegtran.1.gz
+%%JPEG%%man/man1/rdjpgcom.1.gz
+%%JPEG%%man/man1/wrjpgcom.1.gz
+%%LIBTURBOJPEG%%bin/tjbench
+%%LIBTURBOJPEG%%include/turbojpeg.h
+%%LIBTURBOJPEG%%lib/libturbojpeg.a
+%%LIBTURBOJPEG%%lib/libturbojpeg.so
+%%LIBTURBOJPEG%%lib/libturbojpeg.so.0
+%%LIBTURBOJPEG%%lib/libturbojpeg.so.0.0.0
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
index 346294153e52..52bcaef07760 100644
--- a/graphics/libjpeg-turbo/Makefile
+++ b/graphics/libjpeg-turbo/Makefile
@@ -1,57 +1,12 @@
# Created by: Denis Podolskiy <bytestore@yandex.ru>
# $FreeBSD$
-PORTNAME= libjpeg-turbo
-PORTVERSION= 1.3.0
-PORTREVISION= 1
-CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
+PKGNAMEPREFIX= lib
-MAINTAINER= bytestore@yandex.ru
-COMMENT= SIMD-accelerated JPEG codec which provides both the libjpeg,TurboJPEG
+COMMENT= SIMD-accelerated JPEG codec library, provides libTurboJPEG
-BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+MASTERDIR= ${.CURDIR:H}/jpeg-turbo
+SLAVE_PORT= yes
+OPTIONS_SLAVE= PIC
-CONFLICTS_INSTALL= jpeg-[0-9]*
-ONLY_FOR_ARCHS= amd64 i386
-USES= libtool
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= SO_MAJOR_VERSION=${SOVERSION}
-CONFIGURE_ARGS= --with-jpeg8
-USE_LDCONFIG= yes
-ALL_TARGET= test
-
-PLIST_SUB= SOVERSION=${SOVERSION}
-PORTDOCS= *
-PORTEXAMPLES= *
-
-# chase graphics/jpeg
-SOVERSION= 11
-
-OPTIONS_DEFINE= PIC DOCS EXAMPLES
-PIC_DESC= Static library with PIC (required for VirtualGL)
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPIC}
-CONFIGURE_ARGS+=--with-pic
-.endif
-
-post-patch:
-.if ! ${PORT_OPTIONS:MDOCS}
- ${REINPLACE_CMD} -e '/^install-data-am/s,install-dist_docDATA,,' \
- ${WRKSRC}/Makefile.in
-.else
- ${REINPLACE_CMD} -e '/^docdir/s,=.*,= ${DOCSDIR},' \
- ${WRKSRC}/Makefile.in
-.endif
-
-.if ! ${PORT_OPTIONS:MEXAMPLES}
- ${REINPLACE_CMD} -e '/^install-data-am/s,install-dist_exampleDATA,,' \
- ${WRKSRC}/Makefile.in
-.else
- ${REINPLACE_CMD} -e '/^exampledir/s,=.*,= ${EXAMPLESDIR},' \
- ${WRKSRC}/Makefile.in
-.endif
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/libjpeg-turbo/pkg-descr b/graphics/libjpeg-turbo/pkg-descr
index 53fff38aa09d..1f6b36bd07bd 100644
--- a/graphics/libjpeg-turbo/pkg-descr
+++ b/graphics/libjpeg-turbo/pkg-descr
@@ -1,3 +1,5 @@
+This is the libjpeg-turbo library.
+
libjpeg-turbo is a high-speed version of libjpeg for x86 and x86-64 processors
which uses SIMD instructions (MMX, SSE2, etc.) to accelerate baseline JPEG
compression and decompression.
diff --git a/graphics/libjpeg-turbo/pkg-plist b/graphics/libjpeg-turbo/pkg-plist
deleted file mode 100644
index 61d92bf82128..000000000000
--- a/graphics/libjpeg-turbo/pkg-plist
+++ /dev/null
@@ -1,24 +0,0 @@
-bin/cjpeg
-bin/djpeg
-bin/jpegtran
-bin/rdjpgcom
-bin/tjbench
-bin/wrjpgcom
-include/jconfig.h
-include/jerror.h
-include/jmorecfg.h
-include/jpeglib.h
-include/turbojpeg.h
-lib/libjpeg.a
-lib/libjpeg.so
-lib/libjpeg.so.%%SOVERSION%%
-lib/libjpeg.so.%%SOVERSION%%.0.2
-lib/libturbojpeg.a
-lib/libturbojpeg.so
-lib/libturbojpeg.so.0
-lib/libturbojpeg.so.0.0.0
-man/man1/cjpeg.1.gz
-man/man1/djpeg.1.gz
-man/man1/jpegtran.1.gz
-man/man1/rdjpgcom.1.gz
-man/man1/wrjpgcom.1.gz