aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/privoxy/Makefile47
-rw-r--r--www/privoxy/distinfo6
-rw-r--r--www/privoxy/pkg-descr2
-rw-r--r--www/privoxy/pkg-plist1
4 files changed, 34 insertions, 22 deletions
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index 7821a0de8e64..6a6fe4091a8d 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= privoxy
-PORTVERSION= 3.0.28
+PORTVERSION= 3.0.29
CATEGORIES= www
MASTER_SITES= https://www.privoxy.org/sf-download-mirror/Sources/${PORTVERSION}%20(stable)/ \
SF/ijbswa/Sources/${PORTVERSION}%20%28stable%29
@@ -14,47 +14,55 @@ COMMENT= Web proxy with advanced filtering capabilities
LIB_DEPENDS= libpcre.so:devel/pcre
USES= autoreconf cpe gmake shebangfix
+USE_RC_SUBR= privoxy
-WRKSRC= ${WRKDIR}/privoxy-${PORTVERSION}-stable
+SHEBANG_FILES= tools/privoxy-log-parser.pl tools/privoxy-regression-test.pl \
+ tools/uagen.pl tools/url-pattern-translator.pl
GNU_CONFIGURE= yes
-SHEBANG_FILES= tools/privoxy-log-parser.pl tools/privoxy-regression-test.pl tools/uagen.pl
-
-USE_RC_SUBR= privoxy
-SUB_FILES= pkg-message
+CONFIGURE_ARGS= --enable-extended-statistics --enable-pcre-host-patterns
MAKEFILE= GNUmakefile
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
# privoxy-devel is the development release available at the Privoxy website.
# It's not (yet) part of the FreeBSD ports collection.
CONFLICTS= privoxy-devel-[0-9]*
+SUB_FILES= pkg-message
+
+WRKSRC= ${WRKDIR}/privoxy-${PORTVERSION}-stable
+
USERS= privoxy
GROUPS= privoxy
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= ACCEPT_FILTER BROKEN_STRPTIME BROTLI COMPRESSION DEBUG \
+ DOCS EDITOR FORCE HTTPS_INSPECTION PRIVOXY_TOOLS TOGGLE
-OPTIONS_DEFINE= ACCEPT_FILTER BROKEN_STRPTIME COMPRESSION \
- DEBUG DOCS EDITOR FORCE PRIVOXY_TOOLS TOGGLE
+OPTIONS_DEFAULT= ACCEPT_FILTER BROTLI EDITOR FORCE \
+ HTTPS_INSPECTION TOGGLE PRIVOXY_TOOLS
+OPTIONS_SUB= yes
ACCEPT_FILTER_DESC= Support for accf_http(9)
BROKEN_STRPTIME_DESC= Enable workaround for standards/173421
+BROTLI_DESC= Support decompression of Brotli-encoded content
COMPRESSION_DESC= Support compression of buffered content
DOCS_DESC= Let Privoxy serve the user manual
EDITOR_DESC= Support use of the web-based action editor
FORCE_DESC= Support bypassing of blocks
+HTTPS_INSPECTION_DESC= Support filtering of encrypted content
PRIVOXY_TOOLS_DESC= Install Privoxy-Log-Parser, uagen, etc.
TOGGLE_DESC= Support for remote toggling
-OPTIONS_DEFAULT= EDITOR FORCE TOGGLE PRIVOXY_TOOLS
-
-OPTIONS_SUB= yes
-
ACCEPT_FILTER_CONFIGURE_ON= --enable-accept-filter
BROKEN_STRPTIME_CONFIGURE_ON= --enable-strptime-sanity-checks
+BROTLI_LIB_DEPENDS= libbrotlidec.so:archivers/brotli
+BROTLI_CONFIGURE_ON= --with-brotli
+
COMPRESSION_CONFIGURE_ON= --enable-compression
DEBUG_CONFIGURE_ON= --with-debug
@@ -63,11 +71,13 @@ EDITOR_CONFIGURE_OFF= --disable-editor
FORCE_CONFIGURE_OFF= --disable-force
-TOGGLE_CONFIGURE_OFF= --disable-toggle
+HTTPS_INSPECTION_CONFIGURE_ON= --with-openssl
+PRIVOXY_TOOLS_RUN_DEPENDS= curl:ftp/curl
PRIVOXY_TOOLS_USES= perl5
PRIVOXY_TOOLS_USE= PERL5=run
-PRIVOXY_TOOLS_RUN_DEPENDS= curl:ftp/curl
+
+TOGGLE_CONFIGURE_OFF= --disable-toggle
post-patch:
${REINPLACE_CMD} \
@@ -75,20 +85,21 @@ post-patch:
-e 's,^\(logdir\) \.,\1 /var/log/privoxy,' \
-e 's,^\(actionsfile user\),#\1,' \
-e 's,^\(filterfile user\),#\1,' \
+ -e 's,^#\(listen-backlog -1\),\1,' \
${WRKSRC}/config
${REINPLACE_CMD} \
-e 's,\(/etc/privoxy\),${PREFIX}\1,' ${WRKSRC}/tools/uagen.pl
post-patch-DOCS-on:
${REINPLACE_CMD} \
- -e 's,^#\(user-manual\) http://www.privoxy.org/user-manual/,\1 ${DOCSDIR}/user-manual,' \
+ -e 's,^#\(user-manual\) https://www.privoxy.org/user-manual/,\1 ${DOCSDIR}/user-manual,' \
${WRKSRC}/config
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/privoxy/templates
${INSTALL_PROGRAM} ${WRKSRC}/privoxy ${STAGEDIR}${PREFIX}/sbin
${INSTALL_DATA} ${WRKSRC}/templates/[a-z]* ${STAGEDIR}${PREFIX}/etc/privoxy/templates
-.for privoxy_tool in privoxy-log-parser.pl privoxy-regression-test.pl uagen.pl
+.for privoxy_tool in privoxy-log-parser.pl privoxy-regression-test.pl uagen.pl url-pattern-translator.pl
${INSTALL_SCRIPT} ${WRKSRC}/tools/${privoxy_tool} ${STAGEDIR}${PREFIX}/bin
.endfor
.for defaultfile in default.action default.filter regression-tests.action
diff --git a/www/privoxy/distinfo b/www/privoxy/distinfo
index 72062ac45df8..5391601e064b 100644
--- a/www/privoxy/distinfo
+++ b/www/privoxy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1546260542
-SHA256 (privoxy-3.0.28-stable-src.tar.gz) = b5d78cc036aaadb3b7cf860e9d598d7332af468926a26e2d56167f1cb6f2824a
-SIZE (privoxy-3.0.28-stable-src.tar.gz) = 1753809
+TIMESTAMP = 1606563663
+SHA256 (privoxy-3.0.29-stable-src.tar.gz) = 25c6069efdaf577d47c257da63b03cd6d063fb790e19cc39603d82e5db72489d
+SIZE (privoxy-3.0.29-stable-src.tar.gz) = 1830550
diff --git a/www/privoxy/pkg-descr b/www/privoxy/pkg-descr
index ace31c272023..29fd068a426f 100644
--- a/www/privoxy/pkg-descr
+++ b/www/privoxy/pkg-descr
@@ -5,4 +5,4 @@ flexible configuration and can be customized to suit individual needs and
tastes. It has application for both stand-alone systems and multi-user
networks.
-WWW: http://www.privoxy.org/
+WWW: https://www.privoxy.org/
diff --git a/www/privoxy/pkg-plist b/www/privoxy/pkg-plist
index d65ce475448f..67a9608dfec3 100644
--- a/www/privoxy/pkg-plist
+++ b/www/privoxy/pkg-plist
@@ -1,6 +1,7 @@
%%PRIVOXY_TOOLS%%bin/privoxy-log-parser.pl
%%PRIVOXY_TOOLS%%bin/privoxy-regression-test.pl
%%PRIVOXY_TOOLS%%bin/uagen.pl
+%%PRIVOXY_TOOLS%%bin/url-pattern-translator.pl
sbin/privoxy
man/man1/privoxy.1.gz
etc/privoxy/default.action