aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile5
-rw-r--r--Mk/bsd.port.mk7
2 files changed, 3 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index eb3e6443b95c..4c061017d559 100644
--- a/Makefile
+++ b/Makefile
@@ -106,8 +106,6 @@ ${INDEXDIR}/${INDEXFILE}:
@${INDEX_ECHO_1ST} "Generating ${INDEXFILE} - please wait.."; \
if [ "${INDEX_PRISTINE}" != "" ]; then \
export LOCALBASE=/nonexistentlocal; \
- export X11BASE=/nonexistentx; \
- export USE_NONDEFAULT_X11BASE=1; \
fi; \
tmpdir=`/usr/bin/mktemp -d -t index` || exit 1; \
trap "rm -rf $${tmpdir}; exit 1" 1 2 3 5 10 13 15; \
@@ -140,8 +138,7 @@ ${INDEXDIR}/${INDEXFILE}:
sort -t '|' +1 -2 | \
sed -e 's../.g' > ${INDEXDIR}/${INDEXFILE}.tmp; \
if [ "${INDEX_PRISTINE}" != "" ]; then \
- sed -e "s,$${LOCALBASE},/usr/local," -e "s,$${X11BASE},/usr/X11R6," \
- ${INDEXDIR}/${INDEXFILE}.tmp > ${INDEXDIR}/${INDEXFILE}; \
+ sed -e "s,$${LOCALBASE},/usr/local," ${INDEXDIR}/${INDEXFILE}.tmp > ${INDEXDIR}/${INDEXFILE}; \
else \
mv ${INDEXDIR}/${INDEXFILE}.tmp ${INDEXDIR}/${INDEXFILE}; \
fi; \
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c9a54d20eb48..a968852a140d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1396,14 +1396,11 @@ ETCDIR?= ${PREFIX}/etc/${PORTNAME}
IGNORE= cannot be installed: bad X_WINDOW_SYSTEM setting; valid value is 'xorg'
.endif
-.if ${OSVERSION} < 602000
-.if ${X11BASE} != ${LOCALBASE} && !defined(USE_NONDEFAULT_X11BASE)
+.if ${X11BASE} != ${LOCALBASE}
.BEGIN:
- @${ECHO_MSG} "On FreeBSD before 6.2 ports system unfortunately can not set default X11BASE by itself so please help it a bit by setting X11BASE=\$${LOCALBASE} in make.conf."
- @${ECHO_MSG} "On the other hand, if you do wish to use non-default X11BASE, please set variable USE_NONDEFAULT_X11BASE."
+ @${ECHO_MSG} "X11BASE is now deprecated. Unset X11BASE in make.conf and try again."
@${FALSE}
.endif
-.endif
.if defined(USE_XORG) || defined(XORG_CAT)
.include "${PORTSDIR}/Mk/bsd.xorg.mk"