aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/transmission-cli/Makefile20
-rw-r--r--net-p2p/transmission-cli/distinfo6
-rw-r--r--net-p2p/transmission-gtk2/Makefile5
-rw-r--r--net-p2p/transmission-gtk2/pkg-plist3
-rw-r--r--net-p2p/transmission/Makefile2
5 files changed, 18 insertions, 18 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index 009a915434ba..2d006995d1d0 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= transmission
-PORTVERSION= 1.93
+PORTVERSION= 2.03
PORTREVISION?= 0
CATEGORIES?= net-p2p
MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
@@ -20,15 +20,18 @@ SLAVEPORT?=
LIB_DEPENDS?= ${GEN_LIB_DEPENDS}
# General dependencies
-GEN_LIB_DEPENDS=curl.6:${PORTSDIR}/ftp/curl
+GEN_LIB_DEPENDS=curl.6:${PORTSDIR}/ftp/curl \
+ event-1.4.3:${PORTSDIR}/devel/libevent
GEN_RUN_DEPENDS=${LOCALBASE}/share/transmission/web/index.html:${PORTSDIR}/www/transmission-web
USE_GMAKE= yes
USE_GNOME?= pkgconfig
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS=--with-ssl=${OPENSSLBASE} \
- --with-zlib=/usr \
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
+CONFIGURE_ARGS=--with-zlib=/usr \
--disable-libappindicator \
--disable-gconf2 \
${EXTRA_CONF_ARGS}
@@ -43,14 +46,12 @@ MAN1?= transmissioncli.1
EXTRA_PATCHES= ${PATCHDIR}/disable-web
.endif
-USE_BZIP2= yes
+USE_XZ= yes
DOCS= AUTHORS COPYING NEWS README
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
general-patch:
- @${REINPLACE_CMD} -e 's|SUBDIRS = . sample.*|SUBDIRS = .|g' \
- ${WRKSRC}/third-party/libevent/Makefile.in
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g'
.if ${SLAVEPORT}!="gtk2"
@@ -59,10 +60,9 @@ general-patch:
.endif
@${REINPLACE_CMD} -e \
's|_pthread_flags=".*"|_pthread_flags="${PTHREAD_LIBS}"|g ; \
- s|libevent_source=system|libevent_source=bundled|g' \
+ s|rt_clock_gettime=yes|rt_clock_gettime=no|g ; \
+ s|" == "|" = "|g ; s|$$with_ssl.*/usr;|${OPENSSLBASE};|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-lrt||g' \
- ${WRKSRC}/third-party/libevent/configure
@${REINPLACE_CMD} -e 's|doc \\| \\|g' \
${WRKSRC}/Makefile.in
diff --git a/net-p2p/transmission-cli/distinfo b/net-p2p/transmission-cli/distinfo
index 5e3fe50add2d..e729e24e6877 100644
--- a/net-p2p/transmission-cli/distinfo
+++ b/net-p2p/transmission-cli/distinfo
@@ -1,3 +1,3 @@
-MD5 (transmission-1.93.tar.bz2) = f68358d03e46bec5704bbaa894990152
-SHA256 (transmission-1.93.tar.bz2) = e9b7b1fb9aad2808ee27b163dba8647f738c23513201864fa9944010b8d71670
-SIZE (transmission-1.93.tar.bz2) = 4381746
+MD5 (transmission-2.03.tar.xz) = ac5ed307a2ad89687a8ca82c9454cbbe
+SHA256 (transmission-2.03.tar.xz) = 9fa04bd1d484a856e74f245e5e9592f923cc22fe90009812c70db01e7bd256af
+SIZE (transmission-2.03.tar.xz) = 2421780
diff --git a/net-p2p/transmission-gtk2/Makefile b/net-p2p/transmission-gtk2/Makefile
index 94eeef2e6588..34fde83a28b1 100644
--- a/net-p2p/transmission-gtk2/Makefile
+++ b/net-p2p/transmission-gtk2/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 0
PKGNAMESUFFIX= -gtk2
MAINTAINER= mezz@FreeBSD.org
@@ -25,9 +25,6 @@ SLAVEPORT= gtk2
USE_GNOME= gnometarget gnomehack gtk20 desktopfileutils intlhack
USE_GETTEXT= yes
INSTALLS_ICONS= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
EXTRA_CONF_ARGS=--disable-cli \
--disable-daemon \
diff --git a/net-p2p/transmission-gtk2/pkg-plist b/net-p2p/transmission-gtk2/pkg-plist
index c6e81273fa62..2e037830b7c7 100644
--- a/net-p2p/transmission-gtk2/pkg-plist
+++ b/net-p2p/transmission-gtk2/pkg-plist
@@ -39,6 +39,7 @@ share/locale/fo/LC_MESSAGES/transmission.mo
share/locale/fr/LC_MESSAGES/transmission.mo
share/locale/ga/LC_MESSAGES/transmission.mo
share/locale/gl/LC_MESSAGES/transmission.mo
+share/locale/gv/LC_MESSAGES/transmission.mo
share/locale/he/LC_MESSAGES/transmission.mo
share/locale/hi/LC_MESSAGES/transmission.mo
share/locale/hr/LC_MESSAGES/transmission.mo
@@ -91,6 +92,8 @@ share/pixmaps/transmission.png
@dirrmtry share/locale/ku
@dirrmtry share/locale/kk/LC_MESSAGES
@dirrmtry share/locale/kk
+@dirrmtry share/locale/gv/LC_MESSAGES
+@dirrmtry share/locale/gv
@dirrmtry share/locale/fo/LC_MESSAGES
@dirrmtry share/locale/fo
@dirrmtry share/locale/fil/LC_MESSAGES
diff --git a/net-p2p/transmission/Makefile b/net-p2p/transmission/Makefile
index 46ea89f45315..a5bd0c2131f7 100644
--- a/net-p2p/transmission/Makefile
+++ b/net-p2p/transmission/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= transmission
-PORTVERSION= 1.93
+PORTVERSION= 2.03
CATEGORIES= net-p2p
MASTER_SITES= # empty
DISTFILES= # empty