aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--editors/Makefile1
-rw-r--r--editors/semi-xemacs21-mule/Makefile66
3 files changed, 67 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index ddff16d6ab4f..1eead2af8e27 100644
--- a/MOVED
+++ b/MOVED
@@ -4152,4 +4152,3 @@ devel/xlslib||2013-03-09|Has expired: Broken for more than 6 month
mail/firetray||2013-03-09|Has expired: Broken for more than 6 month
vietnamese/vnterm||2013-03-09|Has expired: Broken for more than 6 month
graphics/vid||2013-03-09|Has expired: Broken for more than 6 month
-editors/semi-xemacs21-mule||2013-03-10|Has expired: No more public distfiles
diff --git a/editors/Makefile b/editors/Makefile
index 96ff4ba6fd66..8883398220d9 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -250,6 +250,7 @@
SUBDIR += semi
SUBDIR += semi-emacs21
SUBDIR += semi-emacs22
+ SUBDIR += semi-xemacs21-mule
SUBDIR += setedit
SUBDIR += slime
SUBDIR += softmaker-office
diff --git a/editors/semi-xemacs21-mule/Makefile b/editors/semi-xemacs21-mule/Makefile
new file mode 100644
index 000000000000..5e823e22aaee
--- /dev/null
+++ b/editors/semi-xemacs21-mule/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: semi for xemacs21-mule
+# Date created: 25 July 1999
+# Whom: Shigeyuki FUKUSHIMA <shige@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= SEMI, Library of MIME feature for GNU Emacs for xemacs21-mule
+
+# This is a slave port.
+PORTCLASS= slave
+
+MASTERDIR= ${.CURDIR}/../../editors/semi
+
+DEPRECATED= No more public distfiles
+EXPIRATION_DATE= 2012-10-20
+
+# emacs port setup
+USE_EMACS= yes
+EMACS_PORT_NAME= xemacs21-mule
+EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
+# packages-subdirectories which this port requires
+EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
+
+SCRIPTS_ENV= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+PLIST_SUB= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+
+# how to make and install
+ALL_TARGET= package
+INSTALL_TARGET= install-package
+
+# RUN_DEPENDS port name's suffix is '-common'.
+HAS_COMMON_PORT= YES
+
+# whether emacs has mule feature
+HAS_MULE= YES
+
+# whether building info files by emacs or makeinfo
+BUILD_INFO_BY_EMACS= YES
+# texinfo packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/xemacs-packages/lisp/texinfo/texinfmt.el:${PORTSDIR}/editors/xemacs-packages
+
+# package info manifest
+MANIFEST= MANIFEST.semi
+
+# xemacs package
+XEMACS_PKGNAME= semi
+XEMACS_PKGVER= 1.14
+#XEMACS_PKGVER!= grep version ${.CURDIR}/../semi-emacs/files/_pkg.el | \
+# sed 's/.*:version \([0-9.]*\).*/\1/'
+XEMACS_PKG_TARBALL= ${XEMACS_PKGNAME}-${XEMACS_PKGVER}-pkg.tar.gz
+XEMACS_PKG_CONTENTS= pkginfo/${MANIFEST} lisp/${XEMACS_PKGNAME} \
+ info/mime-ui-en.info info/mime-ui-ja.info \
+ man/${XEMACS_PKGNAME}
+
+# package documents
+SEMIDOCDIR= ${EMACS_PACKAGESDIR}/lisp/semi
+
+xemacs-package: install
+ @${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
+ @(cd ${LOCALBASE}/${EMACS_PACKAGESDIR} ;\
+ ${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
+ )
+
+.include "${MASTERDIR}/Makefile"