aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/dropbox-api-command/Makefile36
-rw-r--r--net/dropbox-api-command/distinfo2
-rw-r--r--net/dropbox-api-command/pkg-descr5
4 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 1704dac71f2c..3207cd391683 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -121,6 +121,7 @@
SUBDIR += dimes
SUBDIR += diradmin
SUBDIR += dosdetector
+ SUBDIR += dropbox-api-command
SUBDIR += dtcp
SUBDIR += dtcpclient
SUBDIR += e169-stats
diff --git a/net/dropbox-api-command/Makefile b/net/dropbox-api-command/Makefile
new file mode 100644
index 000000000000..959c1b9f279b
--- /dev/null
+++ b/net/dropbox-api-command/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: dropbox-api-command
+# Date created: 2011-07-14
+# Whom: Lung-Pin Chang <changlp@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dropbox-api-command
+PORTVERSION= 20110512
+CATEGORIES= net
+MASTER_SITES= https://github.com/s-aska/${PORTNAME}/raw/${GITCOMMIT}/
+DISTNAME= dropbox-api
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= changlp@cs.nctu.edu.tw
+COMMENT= Dropbox API wrapper command
+
+RUN_DEPENDS= p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ p5-Encode>=0:${PORTSDIR}/converters/p5-Encode \
+ p5-Encode-Locale>=0:${PORTSDIR}/converters/p5-Encode-Locale \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-Net-Dropbox-API>=0:${PORTSDIR}/net/p5-Net-Dropbox-API \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class
+
+GITCOMMIT= 1cf7c825f2897db5d101e3cc53c9a5a4607235ee
+
+USE_PERL5_RUN= YES
+NO_BUILD= YES
+FETCH_ARGS= -pRr
+PLIST_FILES= bin/dropbox-api
+
+do-install:
+ ${INSTALL_SCRIPT} ${DISTDIR}/dropbox-api ${PREFIX}/bin/dropbox-api
+
+.include <bsd.port.mk>
diff --git a/net/dropbox-api-command/distinfo b/net/dropbox-api-command/distinfo
new file mode 100644
index 000000000000..82b346ffcdbb
--- /dev/null
+++ b/net/dropbox-api-command/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dropbox-api) = 8ab7488e73ca553d7a9f593905394b493910d1b3d7a7b0bbd7a684e56aea1a59
+SIZE (dropbox-api) = 19327
diff --git a/net/dropbox-api-command/pkg-descr b/net/dropbox-api-command/pkg-descr
new file mode 100644
index 000000000000..21f007df2391
--- /dev/null
+++ b/net/dropbox-api-command/pkg-descr
@@ -0,0 +1,5 @@
+Dropbox's API commands from the shell.
+
+Including sub-commands like sync, find, etc.
+
+WWW: http://doc.7kai.org/Product/DropboxAPICommand/README