aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/mail-notification/Makefile7
-rw-r--r--mail/mail-notification/distinfo4
-rw-r--r--mail/mail-notification/pkg-descr22
-rw-r--r--mail/mail-notification/pkg-plist53
4 files changed, 37 insertions, 49 deletions
diff --git a/mail/mail-notification/Makefile b/mail/mail-notification/Makefile
index eba56bc0d653..c20ed31ddb08 100644
--- a/mail/mail-notification/Makefile
+++ b/mail/mail-notification/Makefile
@@ -6,17 +6,16 @@
#
PORTNAME= mail-notification
-PORTVERSION= 0.3.4
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= mailnotify
MAINTAINER= jylefort@brutele.be
-COMMENT= A mail notification for the GNOME 2.0 system tray
+COMMENT= A mail notification for freedesktop.org-compliant system trays
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui
+USE_GNOME= gnomeprefix gnomehack eel2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/mail/mail-notification/distinfo b/mail/mail-notification/distinfo
index 0d5c71992090..a9ee9830c48d 100644
--- a/mail/mail-notification/distinfo
+++ b/mail/mail-notification/distinfo
@@ -1,2 +1,2 @@
-MD5 (mail-notification-0.3.4.tar.gz) = 9819fe9b6c2da167c80400299db109f4
-SIZE (mail-notification-0.3.4.tar.gz) = 177374
+MD5 (mail-notification-0.4.0.tar.gz) = b145c3d4167bad1ade778a57d26930bb
+SIZE (mail-notification-0.4.0.tar.gz) = 216554
diff --git a/mail/mail-notification/pkg-descr b/mail/mail-notification/pkg-descr
index d25d85339c1d..55837340787b 100644
--- a/mail/mail-notification/pkg-descr
+++ b/mail/mail-notification/pkg-descr
@@ -1,15 +1,17 @@
-Mail Notification is an icon for the GNOME Notification Area that
-informs users if they have new mail.
+Mail Notification is a status icon (aka tray icon) that informs you if
+you have new mail.
-Features:
+It works with system trays implementing the freedesktop.org System
+Tray Specification, such as the GNOME Panel Notification Area, the
+Xfce Notification Area and the KDE System Tray.
- * multiple folder support
- * mbox, MH, Maildir and Sylpheed support
- * POP3 support (if the GNet library is available)
- * automatic folder format detection
- * responsive UI (multi-threaded application)
- * HIG-compliant user interface
- * themeable stock icons
+Mail Notification features include:
+
+ - multiple mailbox support
+ - mbox, MH, Maildir, Sylpheed and POP3 support
+ - automatic detection of mailbox format
+ - automatic notification
+ - HIG compliance
WWW: http://www.nongnu.org/mailnotify/
diff --git a/mail/mail-notification/pkg-plist b/mail/mail-notification/pkg-plist
index 4dd3c9bd1183..f5363e971658 100644
--- a/mail/mail-notification/pkg-plist
+++ b/mail/mail-notification/pkg-plist
@@ -1,48 +1,35 @@
bin/mail-notification
-etc/gconf/gconf.xml.defaults/apps/mail-notification/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/mail-notification/commands/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/mail-notification/commands/new-mail/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/mail-notification/commands/clicked/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/mail-notification/local/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/mail-notification/local/delay/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/mail-notification/remote/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/mail-notification/remote/delay/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands/new-mail/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands/clicked/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/local/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/local/delay/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/remote/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/remote/delay/%gconf.xml
+@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/mail-notification.schemas > /dev/null || /usr/bin/true
etc/gconf/schemas/mail-notification.schemas
+@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/mail-notification.schemas > /dev/null || /usr/bin/true
share/gnome/applications/mail-notification.desktop
+share/gnome/help/mail-notification/C/documentation-license.xml
+share/gnome/help/mail-notification/C/figures/mail-error.png
+share/gnome/help/mail-notification/C/figures/mail.png
+share/gnome/help/mail-notification/C/figures/no-mail-error.png
+share/gnome/help/mail-notification/C/figures/no-mail.png
+share/gnome/help/mail-notification/C/mail-notification.xml
+share/gnome/help/mail-notification/C/software-license.xml
share/gnome/mail-notification/ui/about-icon.png
-share/gnome/mail-notification/ui/add-pop3.glade
share/gnome/mail-notification/ui/dialog.glade
share/gnome/mail-notification/ui/logo.png
+share/gnome/mail-notification/ui/mail-error.png
share/gnome/mail-notification/ui/mail.png
+share/gnome/mail-notification/ui/mailbox-properties.glade
share/gnome/mail-notification/ui/menu.glade
+share/gnome/mail-notification/ui/no-mail-error.png
share/gnome/mail-notification/ui/no-mail.png
share/gnome/mail-notification/ui/preferences-icon.png
share/gnome/mail-notification/ui/preferences.glade
+share/gnome/mail-notification/ui/unsupported.png
+share/gnome/omf/mail-notification/mail-notification-C.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/mail-notification/mail-notification-C.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/mail-notification/mail-notification-C.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/mail-notification.png
share/locale/fr/LC_MESSAGES/mail-notification.mo
-@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/commands/new-mail
-@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/commands/clicked
-@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/commands
-@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/local/delay
-@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/local
-@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/remote/delay
-@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification/remote
-@dirrm etc/gconf/gconf.xml.defaults/apps/mail-notification
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands/new-mail
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands/clicked
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/commands
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/local/delay
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/local
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/remote/delay
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification/remote
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mail-notification
+@dirrm share/gnome/help/mail-notification/C/figures
+@dirrm share/gnome/help/mail-notification/C
+@dirrm share/gnome/help/mail-notification
@dirrm share/gnome/mail-notification/ui
@dirrm share/gnome/mail-notification
+@dirrm share/gnome/omf/mail-notification