aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/libspf/Makefile4
-rw-r--r--mail/mu/Makefile5
-rw-r--r--math/nlopt/Makefile2
-rw-r--r--multimedia/kodi/Makefile7
-rw-r--r--multimedia/kodi/files/patch-freebsd13
-rw-r--r--multimedia/libcec/Makefile6
-rw-r--r--multimedia/libva-intel-driver/Makefile6
-rw-r--r--net-im/tox/Makefile9
-rw-r--r--net-p2p/twister/Makefile8
-rw-r--r--net/afpfs-ng/Makefile5
-rw-r--r--net/bmon/Makefile4
-rw-r--r--net/freeradius2/Makefile19
-rw-r--r--net/isc-dhcp41-server/Makefile4
-rw-r--r--net/libnfs/Makefile6
-rw-r--r--net/libsocket++/Makefile4
-rw-r--r--net/ntopng/Makefile4
-rw-r--r--net/openggsn/Makefile6
-rw-r--r--net/rabbitmq-c/Makefile4
-rw-r--r--net/tigervnc/Makefile5
-rw-r--r--net/torsocks/Makefile4
-rw-r--r--print/fontforge/Makefile9
-rw-r--r--print/panda/Makefile4
22 files changed, 39 insertions, 99 deletions
diff --git a/mail/libspf/Makefile b/mail/libspf/Makefile
index 3f399932d3ff..928e6675abf2 100644
--- a/mail/libspf/Makefile
+++ b/mail/libspf/Makefile
@@ -18,9 +18,7 @@ MAKE_JOBS_UNSAFE=yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= libtool tar:bzip2
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= -a -c -f
+USES= autoreconf libtool tar:bzip2
USE_LDCONFIG= yes
PORTDOCS= *
diff --git a/mail/mu/Makefile b/mail/mu/Makefile
index eb401ae3eab5..aa04db4b8a47 100644
--- a/mail/mu/Makefile
+++ b/mail/mu/Makefile
@@ -20,10 +20,9 @@ GH_PROJECT= ${PORTNAME}
GH_TAGNAME= ${PORTVERSION:S/^/v/}
GH_COMMIT= 7888ba3
-USES= gmake libtool makeinfo pkgconfig
+USES= autoreconf gmake libtool makeinfo pkgconfig
USE_GNOME= glib20
-USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
-AUTOMAKE_ARGS= --add-missing
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules --disable-gtk
INSTALL_TARGET= install-strip
diff --git a/math/nlopt/Makefile b/math/nlopt/Makefile
index cf0c78faf9f3..0640008746f7 100644
--- a/math/nlopt/Makefile
+++ b/math/nlopt/Makefile
@@ -20,12 +20,12 @@ BUILD_DEPENDS= swig3.0:${PORTSDIR}/devel/swig30 \
${PYTHON_PKGNAMEPREFIX}numpy>=1.9.1:${PORTSDIR}/math/py-numpy
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.1:${PORTSDIR}/math/py-numpy
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig3.0"
USES= autoreconf compiler:features libtool pathfix \
pkgconfig python:2
-USE_AUTOTOOLS= libtoolize
USE_LDCONFIG= yes
PATHFIX_MAKEFILEIN= Makefile.am
diff --git a/multimedia/kodi/Makefile b/multimedia/kodi/Makefile
index b26a9989cb08..0fbf6112faef 100644
--- a/multimedia/kodi/Makefile
+++ b/multimedia/kodi/Makefile
@@ -61,8 +61,8 @@ GH_ACCOUNT= xbmc
GH_PROJECT= ffmpeg
GH_TAGNAME= 2.4.6-Helix
-USES= gettext gmake iconv:wchar_t libtool:build pkgconfig python:2
-USE_AUTOTOOLS= autoconf:env automake:env
+USES= autoreconf:build gettext gmake iconv:wchar_t libtool \
+ pkgconfig python:2
GNU_CONFIGURE= yes
USE_XORG= xt xmu xtst xrandr
USE_GL= glu
@@ -172,9 +172,8 @@ post-patch:
${WRKSRC}/xbmc/Makefile.in \
${WRKSRC}/tools/TexturePacker/Makefile.in
${REINPLACE_CMD} 's;which swig;&2.0;' ${WRKSRC}/codegenerator.mk
- ${REINPLACE_CMD} '/^autopoint/d' ${WRKSRC}/lib/cpluff/autogen.sh
-run-autotools:
+pre-configure:
cd ${WRKSRC} && ${SH} ./bootstrap
post-install:
diff --git a/multimedia/kodi/files/patch-freebsd b/multimedia/kodi/files/patch-freebsd
index f05a739f382a..aa32687770f6 100644
--- a/multimedia/kodi/files/patch-freebsd
+++ b/multimedia/kodi/files/patch-freebsd
@@ -1,16 +1,3 @@
-diff --git lib/cpluff/autogen.sh lib/cpluff/autogen.sh
-index ee0a418..efd5291 100755
---- lib/cpluff/autogen.sh
-+++ lib/cpluff/autogen.sh
-@@ -15,7 +15,7 @@ fi
-
- # Generate files in top level directory
- cd "$basedir"
--autopoint
-+#autopoint
- rm -f ABOUT-NLS
- test -d auxliary || mkdir auxliary
- libtoolize --automake -f
diff --git tools/depends/target/ffmpeg/Makefile tools/depends/target/ffmpeg/Makefile
index 0e08dcf..e94d78f 100644
--- tools/depends/target/ffmpeg/Makefile
diff --git a/multimedia/libcec/Makefile b/multimedia/libcec/Makefile
index 2e949830b66f..0a40fc27c692 100644
--- a/multimedia/libcec/Makefile
+++ b/multimedia/libcec/Makefile
@@ -17,12 +17,10 @@ GH_ACCOUNT= Pulse-Eight
GH_COMMIT= 2a80b46
GH_TAGNAME= ${PORTNAME}-${PORTVERSION}-repack
-USES= alias pathfix pkgconfig libtool
+GNU_CONFIGURE= yes
+USES= alias autoreconf pathfix pkgconfig libtool
PATHFIX_MAKEFILEIN=Makefile.am
USE_XORG= x11 xproto xrandr
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
-ACLOCAL_ARGS= -I.
-AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/multimedia/libva-intel-driver/Makefile b/multimedia/libva-intel-driver/Makefile
index 3fb0718edc4a..c82b656e2949 100644
--- a/multimedia/libva-intel-driver/Makefile
+++ b/multimedia/libva-intel-driver/Makefile
@@ -15,11 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libva.so:${PORTSDIR}/multimedia/libva
BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
-USES= compiler:c11 gmake libtool pkgconfig tar:bzip2
+GNU_CONFIGURE= yes
+USES= autoreconf compiler:c11 gmake libtool pkgconfig tar:bzip2
USE_GL= gl
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
-ACLOCAL_ARGS= -I.
-AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
CPPFLAGS+= -isystem${LOCALBASE}/include
diff --git a/net-im/tox/Makefile b/net-im/tox/Makefile
index 0bb36c467c84..2415ce87b5f9 100644
--- a/net-im/tox/Makefile
+++ b/net-im/tox/Makefile
@@ -21,10 +21,9 @@ GH_ACCOUNT= irungentoo
GH_PROJECT= ${PORTNAME}
GH_TAGNAME= a47fad1
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= -a -c -f
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-tests
-USES= libtool openal:soft pathfix pkgconfig
+USES= autoreconf libtool openal:soft pathfix pkgconfig
USE_SDL= yes
USE_LDCONFIG= yes
PATHFIX_MAKEFILEIN= Makefile.am
@@ -66,8 +65,8 @@ PID_DIR= /var/run/tox-bootstrapd
PKGMESSAGE= ${PKGDIR}/pkg-message.daemon
.endif
-pre-configure:
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/configure.ac
+post-patch:
+ @${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/configure.ac
post-install:
.if ${PORT_OPTIONS:MDAEMON}
diff --git a/net-p2p/twister/Makefile b/net-p2p/twister/Makefile
index f60e042db21b..d1635785bb9b 100644
--- a/net-p2p/twister/Makefile
+++ b/net-p2p/twister/Makefile
@@ -27,9 +27,8 @@ GH_TAGNAME= v${PORTVERSION}
USE_BDB= yes
WANT_BDB_VER= 48
USE_OPENSSL= yes
-USES= gmake iconv
+USES= autoreconf gmake iconv libtool
-USE_AUTOTOOLS= libtoolize:env aclocal:env autoconf:env autoheader:env automake:env
GNU_CONFIGURE= yes
CONFIGURE_WRKSRC=${WRKSRC}/libtorrent
CONFIGURE_ARGS= --with-libiconv \
@@ -52,10 +51,9 @@ PORTDOCS= README.md
WITH_OPENSSL_PORT= yes
.endif
-pre-configure:
- ${REINPLACE_CMD} -e 's|%%PORTVERSION%%|${PORTVERSION}|' \
+post-patch:
+ @${REINPLACE_CMD} 's|%%PORTVERSION%%|${PORTVERSION}|' \
${WRKSRC}/share/genbuild.sh
- (cd ${CONFIGURE_WRKSRC} && ./autotool.sh)
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/twisterd ${STAGEDIR}${PREFIX}/bin
diff --git a/net/afpfs-ng/Makefile b/net/afpfs-ng/Makefile
index 92f29ca5db0c..c698a83bbf67 100644
--- a/net/afpfs-ng/Makefile
+++ b/net/afpfs-ng/Makefile
@@ -12,10 +12,9 @@ COMMENT= Apple Filing Protocol client library
LICENSE= GPLv2
+GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake iconv libtool tar:bzip2 readline
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
-AUTOMAKE_ARGS= --add-missing --copy --force
+USES= autoreconf gmake iconv libtool readline tar:bzip2
USE_LDCONFIG= yes
CFLAGS+= -Wno-return-type
diff --git a/net/bmon/Makefile b/net/bmon/Makefile
index 9ce9fff230a8..3d61cc8469d6 100644
--- a/net/bmon/Makefile
+++ b/net/bmon/Makefile
@@ -20,10 +20,8 @@ GH_ACCOUNT= tgraf
GH_COMMIT= ad62e66
GH_TAGNAME= v${PORTVERSION}
-USES= ncurses pkgconfig:build
-USE_AUTOTOOLS= libtoolize autoheader automake aclocal
-AUTOMAKE_ARGS+= --add-missing
GNU_CONFIGURE= yes
+USES= autoreconf ncurses pkgconfig:build
OPTIONS_DEFINE= DOCS
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index 7125490c4bff..20122717af44 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -28,9 +28,9 @@ CONFLICTS_INSTALL= gnu-radius-[0-9].* openradius-[0-9].* radiusd-cistron-[0-9].*
USE_RC_SUBR= radiusd
-USES= gmake libtool shebangfix tar:bzip2 libtool autoreconf
+GNU_CONFIGURE= yes
+USES= autoreconf gmake libtool shebangfix tar:bzip2
SHEBANG_FILES= scripts/radsqlrelay src/modules/rlm_counter/rad_counter
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader
USE_OPENSSL= yes
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= ${CPPFLAGS}
@@ -309,14 +309,14 @@ CONFIGURE_ARGS+=--with-openssl-libraries=${OPENSSLLIB}
post-patch:
# never try to find execinfo.h (needed until we can enable/disable backtrace
- @${REINPLACE_CMD} -e '/execinfo.h/d' ${WRKSRC}/configure \
- ${WRKSRC}/configure.in
+ @${REINPLACE_CMD} '/execinfo.h/d' ${WRKSRC}/configure.in
# Patch raddb/certs/Makefile for the full path to the openssl binary (using
# ports OpenSSL if installed)
@${REINPLACE_CMD} -E \
-e "s:^([[:space:]])+openssl:\1${OPENSSLBASE}/bin/openssl:g" \
${WRKSRC}/raddb/certs/Makefile
# If we're using Heimdal from base, alter the LIBS variable
+# XXX Should patch configure.in instead of configure because it is regenerated
.if ${PORT_OPTIONS:MHEIMDAL} && empty(PORT_OPTIONS:MHEIMDAL_PORT)
@${REINPLACE_CMD} -e 's|LIBS|KRB5LIBS|g' ${WRKSRC}/src/modules/rlm_krb5/configure
@${REINPLACE_CMD} -e 's|-lkrb5|$$(${KRB5_CONFIG})|g' \
@@ -331,17 +331,6 @@ post-patch:
@${REINPLACE_CMD} -Ee 's:^(.+rc\.radiusd.+)$$:#\1:g' \
${WRKSRC}/scripts/Makefile
-pre-configure:
-# Force the rebuild of some configures from configure.in, as we're patching
-# the configure.in
-# NOTE: ${WRKSRC}/configure is rebuilt automatically once autoconf is
-# added to USE_AUTOTOOLS
- @cd ${WRKSRC}/src/modules/rlm_ldap && ${AUTOCONF} -I ${WRKSRC}
- @cd ${WRKSRC}/src/modules/rlm_sql/drivers/rlm_sql_mysql \
- && ${AUTOCONF} -I ${WRKSRC}
- @cd ${WRKSRC}/src/modules/rlm_perl && ${AUTOCONF} -I ${WRKSRC}
- @cd ${WRKSRC}/src/modules/rlm_python && ${AUTOCONF} -I ${WRKSRC}
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}-${PORTVERSION}/*.so
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/rlm_* \
diff --git a/net/isc-dhcp41-server/Makefile b/net/isc-dhcp41-server/Makefile
index 6baa57a96618..a2e36c230e25 100644
--- a/net/isc-dhcp41-server/Makefile
+++ b/net/isc-dhcp41-server/Makefile
@@ -96,11 +96,9 @@ PLIST_SUB+= SCHEMA_DIR="${SCHEMA_DIR:S,^${PREFIX}/,,}" LDAP=""
PORTDOCS+= README.ldap LICENSE.ldap
LDAP_SCRIPT= ${WRKDIR}/${LDAPPATCHDIST}/dhcpd-conf-to-ldap
LDAP_SCHEMA= ${WRKDIR}/${LDAPPATCHDIST}/dhcp.schema
-USES+= perl5
+USES+= autoreconf perl5
USE_PERL5= run
USE_OPENLDAP= yes
-USE_AUTOTOOLS= aclocal libtoolize autoconf autoheader automake
-AUTOMAKE_ARGS= --foreign --add-missing --copy
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/libnfs/Makefile b/net/libnfs/Makefile
index 898663c5bcaa..547e62588cb3 100644
--- a/net/libnfs/Makefile
+++ b/net/libnfs/Makefile
@@ -14,10 +14,8 @@ LICENSE= LGPL21 GPLv3
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pkgconfig gmake libtool
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
-ACLOCAL_ARGS= -I.
-AUTOMAKE_ARGS= --add-missing
+GNU_CONFIGURE= yes
+USES= autoreconf gmake libtool pkgconfig
USE_LDCONFIG= yes
post-patch:
diff --git a/net/libsocket++/Makefile b/net/libsocket++/Makefile
index ca5c30e3ac02..26ed93c4a80b 100644
--- a/net/libsocket++/Makefile
+++ b/net/libsocket++/Makefile
@@ -18,9 +18,7 @@ OPTIONS_DEFINE= DOCS
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= libtool makeinfo
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
-AUTOMAKE_ARGS= -a -c
+USES= autoreconf libtool makeinfo
INFO= socket++
diff --git a/net/ntopng/Makefile b/net/ntopng/Makefile
index 7b1adc67133f..ba986bfc0e81 100644
--- a/net/ntopng/Makefile
+++ b/net/ntopng/Makefile
@@ -20,11 +20,11 @@ LIB_DEPENDS= librrd.so:${PORTSDIR}/databases/rrdtool \
libndpi.so:${PORTSDIR}/net/ndpi \
libzmq.so:${PORTSDIR}/net/libzmq3
-USE_AUTOTOOLS= autoheader aclocal libtoolize
+GNU_CONFIGURE= yes
USE_SQLITE= yes
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USES= cpe gmake libtool pathfix pkgconfig tar:tgz
+USES= autoreconf cpe gmake libtool pathfix pkgconfig tar:tgz
SUB_FILES= ntopng-geoipupdate.sh
CPE_VENDOR= ntop
diff --git a/net/openggsn/Makefile b/net/openggsn/Makefile
index 51640bcd61bf..4ca675e028fd 100644
--- a/net/openggsn/Makefile
+++ b/net/openggsn/Makefile
@@ -12,10 +12,8 @@ COMMENT= Implementation of the Gateway GPRS Support Node element
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake libtool
-
-USE_AUTOTOOLS= aclocal autoconf automake libtoolize autoheader
-AUTOMAKE_ARGS= --gnu --add-missing --copy
+GNU_CONFIGURE= yes
+USES= autoreconf gmake libtool
post-patch:
${REINPLACE_CMD} -e 's|pkgconfigdir.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g' \
diff --git a/net/rabbitmq-c/Makefile b/net/rabbitmq-c/Makefile
index c5653232429f..a75ecb4cb9ce 100644
--- a/net/rabbitmq-c/Makefile
+++ b/net/rabbitmq-c/Makefile
@@ -25,10 +25,8 @@ CONFLICTS= rabbitmq-c-devel-[0-9]*
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake libtool python tar:bzip2
+USES= autoreconf gmake libtool python tar:bzip2
USE_LDCONFIG= yes
-USE_AUTOTOOLS= aclocal autoconf automake autoheader libtoolize
-AUTOMAKE_ARGS= -i --add-missing
OPTIONS_DEFINE= 64BIT POPT
64BIT_DESC= Produce 64-bit library
diff --git a/net/tigervnc/Makefile b/net/tigervnc/Makefile
index fc3e92916d4b..d6f8a06fd89e 100644
--- a/net/tigervnc/Makefile
+++ b/net/tigervnc/Makefile
@@ -24,9 +24,8 @@ CONFLICTS= tridiavnc-[0-9]* \
tightvnc-[0-9]* \
vnc-[0-9]*
-USES= cmake cpe gmake libtool pkgconfig python
+USES= autoreconf:build cmake cpe gmake libtool pkgconfig python
USE_GL= gl
-USE_AUTOTOOLS= autoconf:env automake:env libtoolize:env
USE_LDCONFIG= yes
USE_OPENSSL= yes
@@ -132,7 +131,7 @@ post-patch:
@cd ${WRKSRC}/unix/xserver/ && ${PATCH} -p1 < ${WRKSRC}/unix/xserver${TIGERVNC_XORG_PATCH_VER}.patch
post-configure:
- @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ${AUTORECONF} -fiv
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ${LOCALBASE}/bin/autoreconf -fiv
@cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
post-build:
diff --git a/net/torsocks/Makefile b/net/torsocks/Makefile
index ec9a901db07b..b4019e2f5456 100644
--- a/net/torsocks/Makefile
+++ b/net/torsocks/Makefile
@@ -17,9 +17,7 @@ GH_ACCOUNT= dgoulet
GH_PROJECT= torsocks
GH_TAGNAME= 96f7a0d
-USE_AUTOTOOLS= aclocal autoconf libtoolize
-ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
-
+GNU_CONFIGURE= yes
USES= autoreconf gmake libtool
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index ccaf3eccadfd..0bde5060580a 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -30,7 +30,6 @@ GH_COMMIT= 53e171b
USES= autoreconf:build desktop-file-utils execinfo gettext gmake iconv libtool pkgconfig python shared-mime-info
USE_XORG= x11 xi ice xkbui
USE_GNOME= glib20 gtk20 libxml2 pango
-USE_AUTOTOOLS= libtoolize
CONFIGURE_ARGS= --enable-tile-path --enable-gtk2-use
CPPFLAGS+= -I${LOCALBASE}/include
@@ -67,12 +66,6 @@ CONFIGURE_ARGS+= --enable-freetype-debugger=${WRKDIR}/freetype-${FREETYPE_VERSIO
CONFIGURE_ARGS+= --disable-freetype-debugger
.endif
-# Although USE_AUTOTOOLS=libtoolize is set above, I do not want to have the ports
-# system run libtoolize, I run it in pre-configure. fontforge's bootstrap normally
-# runs it and if it run later on, it causes the build process to fail.
-run-autotools-libtoolize:
- @${TRUE}
-
# This is to get around calling fontforge's bootstrap script, as that script fails
# if git isn't installed on a system DESPITE there being a --skip-git argument that
# can be passed into it. autoreconf is called here because I want to run it without
@@ -80,7 +73,7 @@ run-autotools-libtoolize:
pre-configure:
(cd ${WRKSRC} && \
${SH} -c '. ./bootstrap.conf ; \
- ${LIBTOOLIZE} -q ; \
+ ${LOCALBASE}/bin/libtoolize -i -c -q ; \
gnulib-tool --aux-dir=config --m4-base=m4 --libtool --symlink --import $${gnulib_modules}' ; \
export LIBTOOLIZE=true ; ${LOCALBASE}/bin/autoreconf -s -i)
diff --git a/print/panda/Makefile b/print/panda/Makefile
index fe49d6e28bd7..a334faad967a 100644
--- a/print/panda/Makefile
+++ b/print/panda/Makefile
@@ -24,10 +24,8 @@ CONFIGURE_ARGS= --enable-berkeley-db
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
LIBS+= -L${BDB_LIB_DIR} -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= autoreconf gmake libtool pathfix pkgconfig tar:bzip2
PATHFIX_MAKEFILEIN= Makefile.am
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= -a -c -f
USE_BDB= yes
USE_LDCONFIG= yes