aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING20
-rw-r--r--databases/innotop/Makefile4
-rw-r--r--multimedia/zoneminder/Makefile2
-rw-r--r--net-mgmt/netdot/Makefile2
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile2
-rw-r--r--ports-mgmt/tinderbox/Makefile4
-rw-r--r--sysutils/watchmen/Makefile3
-rw-r--r--www/MT/Makefile3
8 files changed, 31 insertions, 9 deletions
diff --git a/UPDATING b/UPDATING
index 2a3c071170b7..ad5a0edb33bd 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,26 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20121228:
+ AFFECTS: users of databases/innotop, multimedia/zoneminder
+ net-mgmt/netdot, ports-mgmt/tinderbox, ports-mgmt/tinderbox-devel
+ sysutils/watchmen, www/MT
+
+ The above mentioned ports were converted to depend on
+ databases/p5-DBD-mysql. That will cause messages like
+
+ ===> p5-DBD-mysql-4.021 conflicts with installed package(s):
+ p5-DBD-mysql55-4.021
+
+ To prevent this run one of the following commands to fix the
+ dependencies.
+
+ # portmaster -o databases/p5-DBD-mysql databases/p5-DBD-mysql55
+ or
+ # portupgrade -fo databases/p5-DBD-mysql databases/p5-DBD-mysql55
+ or
+ # pkg set -o databases/p5-DBD-mysql55:databases/p5-DBD-mysql
+
20121220:
AFFECTS: users of lang/ghc
AUTHOR: haskell@FreeBSD.org
diff --git a/databases/innotop/Makefile b/databases/innotop/Makefile
index f06187295427..0bc992b28133 100644
--- a/databases/innotop/Makefile
+++ b/databases/innotop/Makefile
@@ -16,10 +16,10 @@ COMMENT= A MySQL and InnoDB monitoring program
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= p5-DBD-mysql${MYSQL_VER}>=0:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER} \
+BUILD_DEPENDS= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-DBI>=1.46:${PORTSDIR}/databases/p5-DBI \
p5-Term-ReadKey>=2.10:${PORTSDIR}/devel/p5-Term-ReadKey
-RUN_DEPENDS= p5-DBD-mysql${MYSQL_VER}>=0:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER} \
+RUN_DEPENDS= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-DBI>=1.46:${PORTSDIR}/databases/p5-DBI \
p5-Term-ReadKey>=2.10:${PORTSDIR}/devel/p5-Term-ReadKey
diff --git a/multimedia/zoneminder/Makefile b/multimedia/zoneminder/Makefile
index b7d30bbff939..c271dce5bc9f 100644
--- a/multimedia/zoneminder/Makefile
+++ b/multimedia/zoneminder/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
avutil.1:${PORTSDIR}/multimedia/ffmpeg
BUILD_DEPENDS= ${LOCALBASE}/bin/php-config:${PORTSDIR}/lang/php5-extensions \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
- p5-DBD-mysql${MYSQL_VER}>=0:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER} \
+ p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
diff --git a/net-mgmt/netdot/Makefile b/net-mgmt/netdot/Makefile
index 0b1f60562d59..218c5b82c8bd 100644
--- a/net-mgmt/netdot/Makefile
+++ b/net-mgmt/netdot/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= p5-libapreq2>=0:${PORTSDIR}/www/p5-libapreq2 \
p5-Apache-AuthCookie>=0:${PORTSDIR}/www/p5-Apache-AuthCookie \
p5-Apache2-SiteControl>=1.0:${PORTSDIR}/www/p5-Apache2-SiteControl \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
- p5-DBD-mysql${MYSQL_VER}>=0:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER} \
+ p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-SQL-Translator>=0.07:${PORTSDIR}/databases/p5-SQL-Translator \
p5-Class-DBI>=3.0.17:${PORTSDIR}/databases/p5-Class-DBI \
p5-Class-DBI-AbstractSearch>=0:${PORTSDIR}/databases/p5-Class-DBI-AbstractSearch \
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 8526c7a94a20..515dcf710807 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -68,7 +68,7 @@ RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/mysql.php:${PORTSDIR}/database
USE_PHP+= mysql
.endif
USE_MYSQL= yes
-RUN_DEPENDS+= p5-DBD-mysql${MYSQL_VER}>=0:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
+RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.if !defined(WITHOUT_APACHE) && defined(WITH_WEBUI)
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 535db3ab00c8..a3844db2340a 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -6,7 +6,7 @@
PORTNAME= tinderbox
PORTVERSION= 3.4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/ \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
@@ -66,7 +66,7 @@ RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/mysql.php:${PORTSDIR}/database
USE_PHP+= mysql
.endif
USE_MYSQL= yes
-RUN_DEPENDS+= p5-DBD-mysql${MYSQL_VER}>=0:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
+RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.if defined(WITH_CVSUP)
diff --git a/sysutils/watchmen/Makefile b/sysutils/watchmen/Makefile
index 909c85fac678..74d1117c98c1 100644
--- a/sysutils/watchmen/Makefile
+++ b/sysutils/watchmen/Makefile
@@ -7,6 +7,7 @@
PORTNAME= watchmen
PORTVERSION= 0.07
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= GOOGLE_CODE
@@ -43,7 +44,7 @@ RUN_DEPENDS+= p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
-RUN_DEPENDS+= p5-DBD-mysql${MYSQL_VER}>=0:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
+RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.if ${PORT_OPTIONS:MPGSQL}
diff --git a/www/MT/Makefile b/www/MT/Makefile
index 650b4b18b52f..e6c233b0d19e 100644
--- a/www/MT/Makefile
+++ b/www/MT/Makefile
@@ -7,6 +7,7 @@
PORTNAME= MT
PORTVERSION= 5.14
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES?= http://www.movabletype.org/downloads/stable/
DISTNAME?= MTOS-${PORTVERSION}-en
@@ -42,7 +43,7 @@ CGIDIR= www/cgi-bin/mt
.if defined(WITH_MYSQL)
DB_DIR?= ${BASEDIR}/var/db/mysql/blog
-RUN_DEPENDS+= p5-DBD-mysql${MYSQL_VER}>=1:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
+RUN_DEPENDS+= p5-DBD-mysql>=1:${PORTSDIR}/databases/p5-DBD-mysql
USE_MYSQL= yes
.else
DB_DIR?= ${PREFIX}/${CGIDIR}/db