aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/billardgl/Makefile49
-rw-r--r--games/billardgl/distinfo5
-rw-r--r--games/billardgl/files/patch-Makefile25
-rw-r--r--games/billardgl/files/patch-bmp.cpp21
-rw-r--r--games/billardgl/pkg-descr6
6 files changed, 107 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 21397dd9c12c..5131f6177bb3 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -78,6 +78,7 @@
SUBDIR += battalion
SUBDIR += battletanks
SUBDIR += belooted
+ SUBDIR += billardgl
SUBDIR += biloba
SUBDIR += biniax2
SUBDIR += biorythm
diff --git a/games/billardgl/Makefile b/games/billardgl/Makefile
new file mode 100644
index 000000000000..710cf1181a48
--- /dev/null
+++ b/games/billardgl/Makefile
@@ -0,0 +1,49 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= billardgl
+PORTVERSION= 1.75
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/BillardGL%20${PORTVERSION}
+DISTNAME= BillardGL-${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= OpenGL pool billiard simulation
+
+LICENSE= GPLv2 # from website
+
+WRKSRC_SUBDIR= src
+
+USES= dos2unix
+DOS2UNIX_FILES= Makefile bmp.cpp
+USE_GL= gl glu glut
+USE_XORG= x11 xext xmu xi
+
+PORTDOCS= README
+PORTDATA= *
+PLIST_FILES= bin/billardgl \
+ share/pixmaps/billardgl.bmp
+
+DESKTOP_ENTRIES="${PORTNAME}" \
+ "" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.bmp" \
+ "${PORTNAME}" \
+ "Game;Simulation;" \
+ ""
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/BillardGL/|${DATADIR}/|' ${WRKSRC}/Namen.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/BillardGL ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "Texturen lang" ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Texturen/1/dreizehn.bmp ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.bmp
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/billardgl/distinfo b/games/billardgl/distinfo
new file mode 100644
index 000000000000..0a72064f2df9
--- /dev/null
+++ b/games/billardgl/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1492081157
+SHA256 (BillardGL-1.75.tar.gz) = 9b865b1254aa30125480ec7ea2ce00d91524db066a524b78492545782856df96
+SIZE (BillardGL-1.75.tar.gz) = 736295
+SHA256 (billardgl.png) = a79b27cffca343ddb8f57cd6880acc6c60daf82959919868932a296f57be286e
+SIZE (billardgl.png) = 3212
diff --git a/games/billardgl/files/patch-Makefile b/games/billardgl/files/patch-Makefile
new file mode 100644
index 000000000000..0df769d0fef7
--- /dev/null
+++ b/games/billardgl/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig 2002-04-29 11:26:46 UTC
++++ Makefile
+@@ -5,14 +5,14 @@
+
+ ####### Compiler, tools and options
+
+-CC = gcc
+-CXX = g++
+-CFLAGS = -pipe -Wall -W -DNO_DEBUG -g
+-CXXFLAGS= -pipe -Wall -W -DNO_DEBUG -g
+-INCPATH = -I/usr/X11R6/include
+-LINK = g++
+-LFLAGS =
+-LIBS = -L/usr/X11R6/lib -lGL -lGLU -lglut -lXmu -lXext -lX11 -lm -lXi
++CC ?= gcc
++CXX ?= g++
++CFLAGS += -Wall -W -DNO_DEBUG
++CXXFLAGS+= -Wall -W -DNO_DEBUG
++INCPATH = -I${LOCALBASE}/include
++LINK ?= ${CXX}
++LFLAGS += ${LDFLAGS}
++LIBS += -L${LOCALBASE}/lib -lGL -lGLU -lglut -lXmu -lXext -lX11 -lm -lXi
+
+ ## -lqgl -lGLU
+
diff --git a/games/billardgl/files/patch-bmp.cpp b/games/billardgl/files/patch-bmp.cpp
new file mode 100644
index 000000000000..442c42c38ae8
--- /dev/null
+++ b/games/billardgl/files/patch-bmp.cpp
@@ -0,0 +1,21 @@
+--- bmp.cpp.orig 2002-04-22 10:31:24 UTC
++++ bmp.cpp
+@@ -4,14 +4,16 @@
+ // Modified by Volker Blanz, 25.4.2001
+ //
+
+-#include <iostream.h>
+-#include <fstream.h>
++#include <iostream>
++#include <fstream>
+ #include <stdio.h>
+ #include <string.h>
+ #include "LA.h"
+ #include "Namen.h"
+ #include "bmp.h"
+
++using namespace std;
++
+ // from ioutil:
+
+ WORDX readWord(FILE *f) {
diff --git a/games/billardgl/pkg-descr b/games/billardgl/pkg-descr
new file mode 100644
index 000000000000..293ba6ddc7db
--- /dev/null
+++ b/games/billardgl/pkg-descr
@@ -0,0 +1,6 @@
+BillardGL is an OpenGL pool billiard simulation, which was developed
+within the scope of our course "Computergraphics" at the University
+of Freiburg (Germany). BillardGL is puplished under the GPL and is
+available for download for Windows and Linux.
+
+WWW: http://www.billardgl.de/index-en.html