aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/ftpcopy/Makefile21
-rw-r--r--ftp/ftpcopy/distinfo1
-rw-r--r--ftp/ftpcopy/files/patch-aa21
-rw-r--r--ftp/ftpcopy/pkg-comment1
-rw-r--r--ftp/ftpcopy/pkg-descr13
-rw-r--r--ftp/ftpcopy/pkg-plist5
7 files changed, 63 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 3b6170bf2e53..ed7975b04829 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -6,6 +6,7 @@
SUBDIR += cftp
SUBDIR += curl
SUBDIR += downloader
+ SUBDIR += ftpcopy
SUBDIR += ftpfind
SUBDIR += ftplocate
SUBDIR += ftpmirror
diff --git a/ftp/ftpcopy/Makefile b/ftp/ftpcopy/Makefile
new file mode 100644
index 000000000000..5af4937e1097
--- /dev/null
+++ b/ftp/ftpcopy/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: ftpcopy
+# Date created: 5 June 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftpcopy
+PORTVERSION= 0.2.2
+CATEGORIES= ftp
+MASTER_SITES= http://www.ohse.de/uwe/releases/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/ftpcopy
+ cd ${WRKSRC} && \
+ ${INSTALL_PROGRAM} ftpcopy ftpls ${PREFIX}/bin && \
+ ${INSTALL_DATA} NEWS README ${PREFIX}/share/ftpcopy
+
+.include <bsd.port.mk>
diff --git a/ftp/ftpcopy/distinfo b/ftp/ftpcopy/distinfo
new file mode 100644
index 000000000000..ee6e80876e67
--- /dev/null
+++ b/ftp/ftpcopy/distinfo
@@ -0,0 +1 @@
+MD5 (ftpcopy-0.2.2.tar.gz) = 2b4a61167b561bcf19553229bdb7f2ad
diff --git a/ftp/ftpcopy/files/patch-aa b/ftp/ftpcopy/files/patch-aa
new file mode 100644
index 000000000000..516a8e883925
--- /dev/null
+++ b/ftp/ftpcopy/files/patch-aa
@@ -0,0 +1,21 @@
+--- Makefile.orig Wed Jul 5 19:14:15 2000
++++ Makefile Wed Jul 5 19:14:57 2000
+@@ -1,6 +1,6 @@
+ VERSION=0.2.2
+ PACKAGE=ftpcopy
+-prefix=/usr/local
++prefix=$(PREFIX)
+
+ PACKAGE_VERSION=$(PACKAGE)-$(VERSION)
+ HEADERS= ftpparse.h ftplib.h urlparse.h timeoutio.h
+@@ -8,8 +8,8 @@
+ EXTRA_DIST= README $(man_MANS) NEWS ChangeLog install.list
+ INCLUDES=-I. -DPACKAGE_VERSION=\"$(PACKAGE)-$(VERSION)\" -DPACKAGE=\"$(PACKAGE)\" -DVERSION=\"$(VERSION)\"
+ EXTRA_DIST+=premake.defs premake.pl Makefile.pre premake.rules
+-TAR=tar
+-CC=gcc
++TAR?=tar
++CC?=gcc
+ LINK=./link.sh
+ COMPILE=./compile.sh
+ AR=ar
diff --git a/ftp/ftpcopy/pkg-comment b/ftp/ftpcopy/pkg-comment
new file mode 100644
index 000000000000..c18256d96859
--- /dev/null
+++ b/ftp/ftpcopy/pkg-comment
@@ -0,0 +1 @@
+Two command line ftp tools
diff --git a/ftp/ftpcopy/pkg-descr b/ftp/ftpcopy/pkg-descr
new file mode 100644
index 000000000000..3e17be87351b
--- /dev/null
+++ b/ftp/ftpcopy/pkg-descr
@@ -0,0 +1,13 @@
+Two command line ftp tools.
+
+ftpcopy is a simply FTP client written to copy files or directories
+(recursively) from a FTP server. It's main purpose is to mirror FTP sites which
+support the EPLF directory listing format, although it also supports the
+traditional listing format (/bin/ls).
+
+ftpls is a FTP client which generates directory listings, either in plain text
+or HTML.
+
+The tools only support passive mode FTP.
+
+WWW: http://www.ohse.de/uwe/software/ftpcopy.html
diff --git a/ftp/ftpcopy/pkg-plist b/ftp/ftpcopy/pkg-plist
new file mode 100644
index 000000000000..5252e383b066
--- /dev/null
+++ b/ftp/ftpcopy/pkg-plist
@@ -0,0 +1,5 @@
+bin/ftpcopy
+bin/ftpls
+share/ftpcopy/NEWS
+share/ftpcopy/README
+@dirrm share/ftpcopy