aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-metaruby/Makefile38
-rw-r--r--devel/ruby-metaruby/distinfo1
-rw-r--r--devel/ruby-metaruby/pkg-comment1
-rw-r--r--devel/ruby-metaruby/pkg-descr5
-rw-r--r--devel/ruby-metaruby/pkg-plist11
6 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c672987aba80..70ace17825a5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -363,6 +363,7 @@
SUBDIR += ruby-intl
SUBDIR += ruby-libglade
SUBDIR += ruby-locale
+ SUBDIR += ruby-metaruby
SUBDIR += ruby-mmap
SUBDIR += ruby-mutexm
SUBDIR += ruby-optparse
diff --git a/devel/ruby-metaruby/Makefile b/devel/ruby-metaruby/Makefile
new file mode 100644
index 000000000000..9dd575d4659c
--- /dev/null
+++ b/devel/ruby-metaruby/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: MetaRuby
+# Date created: 8 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= metaruby
+PORTVERSION= 0.5
+CATEGORIES= devel ruby
+MASTER_SITES= http://hostname.2y.net/~matju/MetaRuby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= MetaRuby-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= ChangeLog Overview TODO
+
+post-patch:
+ ${RUBY} -i -ne '%r|^\$$: <<| or print' ${WRKSRC}/samples/*
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/* ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/samples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-metaruby/distinfo b/devel/ruby-metaruby/distinfo
new file mode 100644
index 000000000000..4ecddaf3634d
--- /dev/null
+++ b/devel/ruby-metaruby/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/MetaRuby-0.5.tar.gz) = c081e043aed5159e34a4a1be9e43bf03
diff --git a/devel/ruby-metaruby/pkg-comment b/devel/ruby-metaruby/pkg-comment
new file mode 100644
index 000000000000..a962f38bcd82
--- /dev/null
+++ b/devel/ruby-metaruby/pkg-comment
@@ -0,0 +1 @@
+A reimplementations of some Ruby parts in Ruby, Perl's tie equivalent
diff --git a/devel/ruby-metaruby/pkg-descr b/devel/ruby-metaruby/pkg-descr
new file mode 100644
index 000000000000..ff8ac8bd676e
--- /dev/null
+++ b/devel/ruby-metaruby/pkg-descr
@@ -0,0 +1,5 @@
+MetaRuby is a reimplementations of some Ruby parts in Ruby; equivalent
+of Perl's tie command.
+
+Author: matju (Mathieu Bouchard) <matju@cam.org>
+WWW: http://hostname.2y.net/~matju/MetaRuby/
diff --git a/devel/ruby-metaruby/pkg-plist b/devel/ruby-metaruby/pkg-plist
new file mode 100644
index 000000000000..20349f4745c7
--- /dev/null
+++ b/devel/ruby-metaruby/pkg-plist
@@ -0,0 +1,11 @@
+%%RUBY_SITELIBDIR%%/ArrayMixin.rb
+%%RUBY_SITELIBDIR%%/HashMixin.rb
+%%RUBY_SITELIBDIR%%/ListMixin.rb
+%%RUBY_SITELIBDIR%%/StringMixin.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/metaruby/BitArray.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/metaruby/ProcAsArray.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/metaruby
+%%PORTDOCS%%%%RUBY_DOCDIR%%/metaruby/ChangeLog
+%%PORTDOCS%%%%RUBY_DOCDIR%%/metaruby/Overview
+%%PORTDOCS%%%%RUBY_DOCDIR%%/metaruby/TODO
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/metaruby