aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/tg_owt/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-im/tg_owt/Makefile b/net-im/tg_owt/Makefile
index 0a21d1acb672..1b7e67f9c63d 100644
--- a/net-im/tg_owt/Makefile
+++ b/net-im/tg_owt/Makefile
@@ -17,8 +17,8 @@ BUILD_DEPENDS= alsa-lib>0:audio/alsa-lib \
yasm:devel/yasm
LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
libjpeg.so:graphics/jpeg-turbo \
- libusrsctp.so:net/libusrsctp \
- libopus.so:audio/opus
+ libopus.so:audio/opus \
+ libusrsctp.so:net/libusrsctp
USES= cmake pkgconfig
USE_GITHUB= yes
@@ -29,9 +29,15 @@ GH_TAGNAME= a198773
GH_TUPLE= webmproject:libvpx:5b63f0f:libvpx/src/third_party/libvpx/source/libvpx \
HenryHu:libyuv:ad89006:libyuv/src/third_party/libyuv
+CMAKE_OFF= BUILD_SHARED_LIBS
+
# Disable DCHECKs, otherwise video calls will crash.
CXXFLAGS+= -DNDEBUG
-CMAKE_OFF= BUILD_SHARED_LIBS
+.include <bsd.port.options.mk>
+
+.if ${SSL_DEFAULT} == "base" && ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085
+BROKEN= This port requires OpenSSL 1.1.0. Try DEFAULT_VERSIONS+=ssl=[openssl|libressl*]
+.endif
.include <bsd.port.mk>