aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/asmutils/Makefile89
1 files changed, 42 insertions, 47 deletions
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index fdf7a3dc85fb..4025be187d47 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -12,26 +12,16 @@ COMMENT= Set of Unix utilities written in x86 assembly language
LICENSE= GPLv2
+ONLY_FOR_ARCHS= i386
+
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USES= gmake
USE_GCC= any
MAKE_ARGS= OS="${OPSYS:tu}" KERNEL="${OSREL:S/.//g}" CC="${CC}" LD="${LD}"
-ONLY_FOR_ARCHS= i386
-
-# Stripping binaries will break installation
-STRIP= #
-
-PORTDOCS= *
-PLIST_FILES= ${BINS:S/^/bin\/asmutils\//:S/bonus\///} \
- ${LINKS:S/^/bin\/asmutils\//} ${LIBS:S/^/lib\/asmutils\//}
-PLIST_DIRS= lib/asmutils bin/asmutils
-
-OPTIONS_DEFINE= DOCS
-
# This will play merry hell with portlint(1)
-BINS= bonus/asmutils basename cal cat chmod chown chroot cmp cp \
+BINARIES= bonus/asmutils basename cal cat chmod chown chroot cmp cp \
cpuinfo cut date dc dd deflate dirname du echo env \
bonus/execve extname factor fromdos ftpd getty grep head \
hexdump host hostname httpd id idea init kill kldload less \
@@ -45,44 +35,49 @@ BINS= bonus/asmutils basename cal cat chmod chown chroot cmp cp \
LINKS= arch cpuspeed domainname false halt inflate kldstat kldunload \
mkfifo more poweroff regs rmdir size sln todos umount usleep
-LIBS= libc.so.0 libcrypto.so.0 libm.so.0
+LIBRARIES= libc.so.0 libcrypto.so.0 libm.so.0
+
+PLIST_FILES= ${BINARIES:S/^/bin\/asmutils\//:S/bonus\///} \
+ ${LINKS:S/^/bin\/asmutils\//} ${LIBRARIES:S/^/lib\/asmutils\//}
+PLIST_DIRS= bin/asmutils lib/asmutils
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e \
- 's|^static ||' ${WRKSRC}/lib/libm.c
+ @${REINPLACE_CMD} -e 's,^static ,,' ${WRKSRC}/lib/libm.c
+
+# Stripping binaries will break installation
+STRIP= #
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/bin/asmutils
-.for bin in ${BINS}
- (cd ${WRKSRC}/src && ${INSTALL_SCRIPT} ${bin} \
- ${STAGEDIR}${PREFIX}/bin/asmutils)
-.endfor
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/asmutils
-.for lib in ${LIBS}
- (cd ${WRKSRC}/lib && ${INSTALL_DATA} ${lib} \
- ${STAGEDIR}${PREFIX}/lib/asmutils)
-.endfor
- (cd ${STAGEDIR}${PREFIX}/bin/asmutils \
- && ${LN} -sf uname arch \
- && ${LN} -sf cpuinfo cpuspeed \
- && ${LN} -sf hostname domainname \
- && ${LN} -sf true false \
- && ${LN} -sf reboot halt \
- && ${LN} -sf deflate inflate \
- && ${LN} -sf kldload kldstat \
- && ${LN} -sf kldload kldunload \
- && ${LN} -sf mknod mkfifo \
- && ${LN} -sf less more \
- && ${LN} -sf reboot poweroff \
- && ${LN} -sf execve regs \
- && ${LN} -sf mkdir rmdir \
- && ${LN} -sf nm size \
- && ${LN} -sf ln sln \
- && ${LN} -sf fromdos todos \
- && ${LN} -sf mount umount \
- && ${LN} -sf sleep usleep)
+ @${MKDIR} ${STAGEDIR}${PREFIX}/bin/asmutils \
+ ${STAGEDIR}${PREFIX}/lib/asmutils
+ ${INSTALL_PROGRAM} ${BINARIES:S,^,${WRKSRC}/src/,} \
+ ${STAGEDIR}${PREFIX}/bin/asmutils
+ ${INSTALL_PROGRAM} ${LIBRARIES:S,^,${WRKSRC}/lib/,} \
+ ${STAGEDIR}${PREFIX}/lib/asmutils
+ (cd ${STAGEDIR}${PREFIX}/bin/asmutils && \
+ ${LN} -sf uname arch && \
+ ${LN} -sf cpuinfo cpuspeed && \
+ ${LN} -sf hostname domainname && \
+ ${LN} -sf true false && \
+ ${LN} -sf reboot halt && \
+ ${LN} -sf deflate inflate && \
+ ${LN} -sf kldload kldstat && \
+ ${LN} -sf kldload kldunload && \
+ ${LN} -sf mknod mkfifo && \
+ ${LN} -sf less more && \
+ ${LN} -sf reboot poweroff && \
+ ${LN} -sf execve regs && \
+ ${LN} -sf mkdir rmdir && \
+ ${LN} -sf nm size && \
+ ${LN} -sf ln sln && \
+ ${LN} -sf fromdos todos && \
+ ${LN} -sf mount umount && \
+ ${LN} -sf sleep usleep)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC}/doc && ${INSTALL_DATA} [^i]* ${STAGEDIR}${DOCSDIR})
- (cd ${STAGEDIR}${DOCSDIR} && ${LN} -sf Asmutils-HOWTO.html index.html)
+ ${INSTALL_DATA} ${WRKSRC}/doc/[^i]* ${STAGEDIR}${DOCSDIR}
+ ${LN} -sf Asmutils-HOWTO.html ${STAGEDIR}/${DOCSDIR}/index.html
.include <bsd.port.mk>