aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ports-mgmt/pkg-orphan/Makefile28
-rw-r--r--ports-mgmt/pkg-orphan/distinfo3
-rw-r--r--ports-mgmt/pkg-orphan/pkg-descr22
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/pkg-orphan/Makefile28
-rw-r--r--sysutils/pkg-orphan/distinfo3
-rw-r--r--sysutils/pkg-orphan/pkg-descr22
7 files changed, 107 insertions, 0 deletions
diff --git a/ports-mgmt/pkg-orphan/Makefile b/ports-mgmt/pkg-orphan/Makefile
new file mode 100644
index 000000000000..9e10f61004b3
--- /dev/null
+++ b/ports-mgmt/pkg-orphan/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pkg-orphan
+# Date created: 26 November 2005
+# Whom: Victor Semionov <semionov@mail.bg>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkg-orphan
+PORTVERSION= 0.1.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= semionov@mail.bg
+COMMENT= A console utility for managing unreferenced FreeBSD packages
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+MAN1= pkg-orphan.1
+
+PLIST_FILES= sbin/pkg-orphan
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pkg-orphan.pl ${PREFIX}/sbin/pkg-orphan
+ ${INSTALL_MAN} ${WRKSRC}/pkg-orphan.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/pkg-orphan/distinfo b/ports-mgmt/pkg-orphan/distinfo
new file mode 100644
index 000000000000..fe03e47d625a
--- /dev/null
+++ b/ports-mgmt/pkg-orphan/distinfo
@@ -0,0 +1,3 @@
+MD5 (pkg-orphan-0.1.0.tar.gz) = 94840a050d9d9c772e8219fbf3635dcd
+SHA256 (pkg-orphan-0.1.0.tar.gz) = ec20adc491e6cc93dcd8f210f19dc6a4c2508263998cb23cfd78ff4985c96e78
+SIZE (pkg-orphan-0.1.0.tar.gz) = 5867
diff --git a/ports-mgmt/pkg-orphan/pkg-descr b/ports-mgmt/pkg-orphan/pkg-descr
new file mode 100644
index 000000000000..035a14c4198b
--- /dev/null
+++ b/ports-mgmt/pkg-orphan/pkg-descr
@@ -0,0 +1,22 @@
+pkg-orphan is a console utility for managing orphan, i.e. unreferenced FreeBSD
+packages. It finds all or selected orphans and lets the user choose which ones
+to remove and which ones to keep. It maintains a keep-list file, so previously
+kept packages will be skipped automatically. In batch mode, all packages, not
+present in the keep-list are either deleted or kept in the list.
+
+Since orphan packages are usually much fewer than non-orphan ones, it can be
+useful for quickly finding and deleting unused packages, even on a system with
+hundreds of them installed.
+
+Features:
+ - interactive and batch modes
+ - maintains a kept package list, to avoid asking for the same package again
+ - can delete packages recursively, but without deleting shared dependencies or
+ previously kept packages
+ - the keep-list file does not contain package versions, so upgrades generally
+ don't require editing of the file
+
+WWW: http://sourceforge.net/projects/pkg-orphan/
+
+- Victor Semionov
+semionov@mail.bg
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 6982a669c04b..a8b7229a90fd 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -397,6 +397,7 @@
SUBDIR += pib
SUBDIR += pidof
SUBDIR += pipemeter
+ SUBDIR += pkg-orphan
SUBDIR += pkg_cutleaves
SUBDIR += pkg_install
SUBDIR += pkg_install-devel
diff --git a/sysutils/pkg-orphan/Makefile b/sysutils/pkg-orphan/Makefile
new file mode 100644
index 000000000000..9e10f61004b3
--- /dev/null
+++ b/sysutils/pkg-orphan/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pkg-orphan
+# Date created: 26 November 2005
+# Whom: Victor Semionov <semionov@mail.bg>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkg-orphan
+PORTVERSION= 0.1.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= semionov@mail.bg
+COMMENT= A console utility for managing unreferenced FreeBSD packages
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+MAN1= pkg-orphan.1
+
+PLIST_FILES= sbin/pkg-orphan
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pkg-orphan.pl ${PREFIX}/sbin/pkg-orphan
+ ${INSTALL_MAN} ${WRKSRC}/pkg-orphan.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/pkg-orphan/distinfo b/sysutils/pkg-orphan/distinfo
new file mode 100644
index 000000000000..fe03e47d625a
--- /dev/null
+++ b/sysutils/pkg-orphan/distinfo
@@ -0,0 +1,3 @@
+MD5 (pkg-orphan-0.1.0.tar.gz) = 94840a050d9d9c772e8219fbf3635dcd
+SHA256 (pkg-orphan-0.1.0.tar.gz) = ec20adc491e6cc93dcd8f210f19dc6a4c2508263998cb23cfd78ff4985c96e78
+SIZE (pkg-orphan-0.1.0.tar.gz) = 5867
diff --git a/sysutils/pkg-orphan/pkg-descr b/sysutils/pkg-orphan/pkg-descr
new file mode 100644
index 000000000000..035a14c4198b
--- /dev/null
+++ b/sysutils/pkg-orphan/pkg-descr
@@ -0,0 +1,22 @@
+pkg-orphan is a console utility for managing orphan, i.e. unreferenced FreeBSD
+packages. It finds all or selected orphans and lets the user choose which ones
+to remove and which ones to keep. It maintains a keep-list file, so previously
+kept packages will be skipped automatically. In batch mode, all packages, not
+present in the keep-list are either deleted or kept in the list.
+
+Since orphan packages are usually much fewer than non-orphan ones, it can be
+useful for quickly finding and deleting unused packages, even on a system with
+hundreds of them installed.
+
+Features:
+ - interactive and batch modes
+ - maintains a kept package list, to avoid asking for the same package again
+ - can delete packages recursively, but without deleting shared dependencies or
+ previously kept packages
+ - the keep-list file does not contain package versions, so upgrades generally
+ don't require editing of the file
+
+WWW: http://sourceforge.net/projects/pkg-orphan/
+
+- Victor Semionov
+semionov@mail.bg