aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Algorithm-Dependency/Makefile40
-rw-r--r--devel/p5-Algorithm-Dependency/distinfo3
-rw-r--r--devel/p5-Algorithm-Dependency/pkg-descr15
-rw-r--r--devel/p5-Algorithm-Dependency/pkg-plist13
5 files changed, 72 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index aa85e06a1eaf..13035f01bcfd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -667,6 +667,7 @@
SUBDIR += p5-Algorithm-Bucketizer
SUBDIR += p5-Algorithm-ChooseSubsets
SUBDIR += p5-Algorithm-Cluster
+ SUBDIR += p5-Algorithm-Dependency
SUBDIR += p5-Algorithm-Diff
SUBDIR += p5-Algorithm-Evolutionary
SUBDIR += p5-Algorithm-Interval2Prefix
diff --git a/devel/p5-Algorithm-Dependency/Makefile b/devel/p5-Algorithm-Dependency/Makefile
new file mode 100644
index 000000000000..6b5be8296159
--- /dev/null
+++ b/devel/p5-Algorithm-Dependency/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Algorithm-Dependency
+# Date created: 20 Nov 2005
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-Dependency
+PORTVERSION= 1.101
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Base class for implementing various dependency trees
+
+BUILD_DEPENDS= ${SITE_PERL}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
+ ${SITE_PERL}/Test/ClassAPI.pm:${PORTSDIR}/devel/p5-Test-ClassAPI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Algorithm::Dependency.3 \
+ Algorithm::Dependency::Item.3 \
+ Algorithm::Dependency::Ordered.3 \
+ Algorithm::Dependency::Source.3 \
+ Algorithm::Dependency::Source::File.3 \
+ Algorithm::Dependency::Source::HoA.3 \
+ Algorithm::Dependency::Weight.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+IGNORE= requires perl 5.6 or above
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Algorithm-Dependency/distinfo b/devel/p5-Algorithm-Dependency/distinfo
new file mode 100644
index 000000000000..23ad64b37c70
--- /dev/null
+++ b/devel/p5-Algorithm-Dependency/distinfo
@@ -0,0 +1,3 @@
+MD5 (Algorithm-Dependency-1.101.tar.gz) = d6187a17fa90cbf4d1c513ea2c500269
+SHA256 (Algorithm-Dependency-1.101.tar.gz) = 59f6a32ccc50c242424ea01128be285428162c103bfafa16d876d17ecd60653d
+SIZE (Algorithm-Dependency-1.101.tar.gz) = 42872
diff --git a/devel/p5-Algorithm-Dependency/pkg-descr b/devel/p5-Algorithm-Dependency/pkg-descr
new file mode 100644
index 000000000000..2b44acb5e819
--- /dev/null
+++ b/devel/p5-Algorithm-Dependency/pkg-descr
@@ -0,0 +1,15 @@
+Algorithm::Dependency is a framework for creating simple read-only
+dependency heirachies, where you have a set of items that rely on other
+items in the set, and require actions on them as well.
+
+Despite the most visible of these being software installation systems like
+the CPAN installer, or debian apt-get, they are usefull in other
+situations. This module intentionally uses implementation-neutral words,
+to avoid confusion.
+
+WWW: http://search.cpan.org/dist/Algorithm-Dependency
+Author: Adam Kennedy <cpan@ali.as>
+
+--
+Aaron Dalton
+aaron@FreeBSD.org
diff --git a/devel/p5-Algorithm-Dependency/pkg-plist b/devel/p5-Algorithm-Dependency/pkg-plist
new file mode 100644
index 000000000000..e142306a86a1
--- /dev/null
+++ b/devel/p5-Algorithm-Dependency/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/Algorithm/Dependency.pm
+%%SITE_PERL%%/Algorithm/Dependency/Item.pm
+%%SITE_PERL%%/Algorithm/Dependency/Ordered.pm
+%%SITE_PERL%%/Algorithm/Dependency/Source.pm
+%%SITE_PERL%%/Algorithm/Dependency/Source/File.pm
+%%SITE_PERL%%/Algorithm/Dependency/Source/HoA.pm
+%%SITE_PERL%%/Algorithm/Dependency/Weight.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Dependency/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Dependency
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Algorithm/Dependency/Source
+@dirrm %%SITE_PERL%%/Algorithm/Dependency
+@unexec rmdir %D/%%SITE_PERL%%/Algorithm 2>/dev/null || true