aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Random-MT-Auto/Makefile31
-rw-r--r--math/p5-Math-Random-MT-Auto/distinfo3
-rw-r--r--math/p5-Math-Random-MT-Auto/pkg-descr13
-rw-r--r--math/p5-Math-Random-MT-Auto/pkg-plist14
5 files changed, 62 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 389e00bbde86..83a2530d9e33 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -197,6 +197,7 @@
SUBDIR += p5-Math-Pari
SUBDIR += p5-Math-Random
SUBDIR += p5-Math-Random-MT
+ SUBDIR += p5-Math-Random-MT-Auto
SUBDIR += p5-Math-RandomOrg
SUBDIR += p5-Math-Round
SUBDIR += p5-Math-Round-Var
diff --git a/math/p5-Math-Random-MT-Auto/Makefile b/math/p5-Math-Random-MT-Auto/Makefile
new file mode 100644
index 000000000000..1970564859e4
--- /dev/null
+++ b/math/p5-Math-Random-MT-Auto/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Math-Random-MT-Auto
+# Date created: 2006-07-21
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Random-MT-Auto
+PORTVERSION= 5.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Auto-seeded Mersenne Twister PRNGs
+
+RUN_DEPENDS= ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/Object/InsideOut.pm:${PORTSDIR}/devel/p5-Object-InsideOut
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::Random::MT::Auto.3 Math::Random::MT::Auto::Range.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800 # Inherited from p5-Object-InsideOut
+IGNORE= requires perl 5.8 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Random-MT-Auto/distinfo b/math/p5-Math-Random-MT-Auto/distinfo
new file mode 100644
index 000000000000..3975331111de
--- /dev/null
+++ b/math/p5-Math-Random-MT-Auto/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Random-MT-Auto-5.02.tar.gz) = 1eeccd3a864a0ce486998d31b77ecdfa
+SHA256 (Math-Random-MT-Auto-5.02.tar.gz) = b7a6e0c72f14ef7c530a6697fc119bce63830a7e011eac758020e184f0e070a1
+SIZE (Math-Random-MT-Auto-5.02.tar.gz) = 123773
diff --git a/math/p5-Math-Random-MT-Auto/pkg-descr b/math/p5-Math-Random-MT-Auto/pkg-descr
new file mode 100644
index 000000000000..dfcec58a9baf
--- /dev/null
+++ b/math/p5-Math-Random-MT-Auto/pkg-descr
@@ -0,0 +1,13 @@
+The Mersenne Twister is a fast pseudorandom number generator (PRNG)
+that is capable of providing large volumes (> 10^6004) of "high
+quality" pseudorandom data to applications that may exhaust available
+"truly" random data sources or system-provided PRNGs such as rand.
+
+This module provides PRNGs that are based on the Mersenne Twister.
+There is a functional interface to a single, standalone PRNG, and an
+OO interface (based on the inside-out object model as implemented by
+the Object::InsideOut module) for generating multiple PRNG objects.
+The PRNGs are self-seeding, automatically acquiring a (19968-bit)
+random seed from user-selectable sources.
+
+WWW: http://search.cpan.org/dist/Math-Random-MT-Auto/
diff --git a/math/p5-Math-Random-MT-Auto/pkg-plist b/math/p5-Math-Random-MT-Auto/pkg-plist
new file mode 100644
index 000000000000..5cd7c7ef96b3
--- /dev/null
+++ b/math/p5-Math-Random-MT-Auto/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/MT/Auto.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/MT/Auto/Range.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/MT/Auto/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/MT/Auto/Auto.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/MT/Auto/Auto.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/MT/Auto
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/MT
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/MT/Auto
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/MT
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math