aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/esmtp/Makefile62
-rw-r--r--mail/esmtp/distinfo1
-rw-r--r--mail/esmtp/files/patch-esmtprc.513
-rw-r--r--mail/esmtp/files/patch-lexer.c12
-rw-r--r--mail/esmtp/pkg-descr16
-rw-r--r--mail/esmtp/pkg-plist4
7 files changed, 109 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index bc619db357e7..a751ea8b2bb9 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -51,6 +51,7 @@
SUBDIR += emh-emacs20
SUBDIR += emh-xemacs21-mule
SUBDIR += emil
+ SUBDIR += esmtp
SUBDIR += evolution
SUBDIR += exact
SUBDIR += exim
diff --git a/mail/esmtp/Makefile b/mail/esmtp/Makefile
new file mode 100644
index 000000000000..b5362212a11b
--- /dev/null
+++ b/mail/esmtp/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: esmtp
+# Date created: 12.07.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= esmtp
+PORTVERSION= 0.4.1
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Relay-only Mail Transfer Agent with sendmail compatible syntax
+
+LIB_DEPENDS= esmtp.6:${PORTSDIR}/mail/libesmtp
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG= yes
+USE_OPENSSL= yes
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+DOC_FILES= README
+MAN1= esmtp.1
+MAN5= esmtprc.5
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|/usr/bin|${LOCALBASE}/bin|g' \
+ ${WRKSRC}/sample.esmtprc
+ @${REINPLACE_CMD} -e \
+ 's|sendmail(1)|sendmail(8)|g ; \
+ s|/etc|${PREFIX}/etc|g' \
+ ${WRKSRC}/${PORTNAME}.1
+ @${REINPLACE_CMD} -e \
+ 's|/etc|${PREFIX}/etc|g' \
+ ${WRKSRC}/parser.c ${WRKSRC}/parser.y
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/esmtprc.5 ${PREFIX}/man/man5
+ ${INSTALL_DATA} ${WRKSRC}/sample.esmtprc \
+ ${PREFIX}/etc/esmtprc.sample
+ @${ECHO} "------------------------------------------------------------"
+ @${ECHO} "Sample of configuration file placed at"
+ @${ECHO} "${PREFIX}/etc/esmtprc.sample"
+ @${ECHO} "------------------------------------------------------------"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/esmtp/distinfo b/mail/esmtp/distinfo
new file mode 100644
index 000000000000..218ddc5a0c50
--- /dev/null
+++ b/mail/esmtp/distinfo
@@ -0,0 +1 @@
+MD5 (esmtp-0.4.1.tar.bz2) = 57b124dc6b2fffac4d2a7283a1a7f771
diff --git a/mail/esmtp/files/patch-esmtprc.5 b/mail/esmtp/files/patch-esmtprc.5
new file mode 100644
index 000000000000..03e77453bde0
--- /dev/null
+++ b/mail/esmtp/files/patch-esmtprc.5
@@ -0,0 +1,13 @@
+--- esmtprc.5.orig Tue Jul 15 07:57:07 2003
++++ esmtprc.5 Tue Jul 15 07:58:05 2003
+@@ -96,8 +96,8 @@
+ place a %T. The mail message's \fBFrom\fR address will be inserted where you
+ place an %F.
+
+-Some common MDAs are "/usr/bin/procmail -d %T",
+-"/usr/bin/deliver" and "/usr/lib/mail.local %T".
++Some common MDAs are "/usr/local/bin/procmail -d %T"
++and "/usr/libexec/mail.local %T".
+
+ .SH SEE ALSO
+ esmtp(1)
diff --git a/mail/esmtp/files/patch-lexer.c b/mail/esmtp/files/patch-lexer.c
new file mode 100644
index 000000000000..1b0f2d1935e3
--- /dev/null
+++ b/mail/esmtp/files/patch-lexer.c
@@ -0,0 +1,12 @@
+--- lexer.c.orig Sat Jul 12 09:26:44 2003
++++ lexer.c Sat Jul 12 09:27:04 2003
+@@ -20,7 +20,9 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <stdlib.h>
++#ifdef HAVE_STDINT_H
+ #include <stdint.h> /* May break IA64 test-noansi-r */
++#endif
+
+ /* end standard C headers. */
+
diff --git a/mail/esmtp/pkg-descr b/mail/esmtp/pkg-descr
new file mode 100644
index 000000000000..54bca43a7030
--- /dev/null
+++ b/mail/esmtp/pkg-descr
@@ -0,0 +1,16 @@
+esmtp is a user configurable relay-only Mail Transfer Agent
+(MTA) with a sendmail compatible syntax. It's based on libESMTP
+supporting the AUTH (including the CRAM-MD5 and NTLM SASL
+mechanisms) and the StartTLS SMTP extensions.
+
+These are the esmtp features:
+
+ * fully sendmail command line compatible,
+ * supports the AUTH SMTP extension, with the CRAM-MD5 and
+ * NTLM SASL mechanisms,
+ * support the StartTLS SMTP extension,
+ * requires no administration privileges,
+ * individual user configuration,
+ * does not receive mail, expand aliases or manage a queue.
+
+WWW: http://esmtp.sourceforge.net
diff --git a/mail/esmtp/pkg-plist b/mail/esmtp/pkg-plist
new file mode 100644
index 000000000000..91f4b9c225eb
--- /dev/null
+++ b/mail/esmtp/pkg-plist
@@ -0,0 +1,4 @@
+bin/esmtp
+etc/esmtprc.sample
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%