aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-actioncable50/Makefile26
-rw-r--r--www/rubygem-actioncable50/distinfo3
-rw-r--r--www/rubygem-actioncable50/pkg-descr11
4 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index edf760135af1..609207000cc8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1912,6 +1912,7 @@
SUBDIR += ruby-aws
SUBDIR += rubygem-ace-rails-ap
SUBDIR += rubygem-actioncable5
+ SUBDIR += rubygem-actioncable50
SUBDIR += rubygem-actionpack4
SUBDIR += rubygem-actionpack5
SUBDIR += rubygem-actionpack50
diff --git a/www/rubygem-actioncable50/Makefile b/www/rubygem-actioncable50/Makefile
new file mode 100644
index 000000000000..4719f935e8ee
--- /dev/null
+++ b/www/rubygem-actioncable50/Makefile
@@ -0,0 +1,26 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= actioncable
+PORTVERSION= 5.0.2
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 50
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Integrated WebSockets for Rails
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-actionpack50>=${PORTVERSION}:www/rubygem-actionpack50 \
+ rubygem-nio4r>=1.2:devel/rubygem-nio4r \
+ rubygem-websocket-driver>=0.6.1:www/rubygem-websocket-driver
+
+PORTSCOUT= limit:^5\.0\.
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-actioncable50/distinfo b/www/rubygem-actioncable50/distinfo
new file mode 100644
index 000000000000..b2678f8ece09
--- /dev/null
+++ b/www/rubygem-actioncable50/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488463113
+SHA256 (rubygem/actioncable-5.0.2.gem) = bec943d44cc3c91b1be7ed9dd0a750e89668035089905f8b357eafb7019402e0
+SIZE (rubygem/actioncable-5.0.2.gem) = 42496
diff --git a/www/rubygem-actioncable50/pkg-descr b/www/rubygem-actioncable50/pkg-descr
new file mode 100644
index 000000000000..22f58d2222cf
--- /dev/null
+++ b/www/rubygem-actioncable50/pkg-descr
@@ -0,0 +1,11 @@
+Action Cable – Integrated WebSockets for Rails
+
+Action Cable seamlessly integrates WebSockets with the rest of your Rails
+application. It allows for real-time features to be written in Ruby in the same
+style and form as the rest of your Rails application, while still being
+performant and scalable. It's a full-stack offering that provides both a
+client-side JavaScript framework and a server-side Ruby framework. You have
+access to your full domain model written with Active Record or your ORM of
+choice.
+
+WWW: http://rubyonrails.org/