aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/py-django-mailbox/Makefile20
-rw-r--r--mail/py-django-mailbox/distinfo3
-rw-r--r--mail/py-django-mailbox/pkg-descr9
4 files changed, 33 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index d363047af7b5..3ae3696d80a1 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -487,6 +487,7 @@
SUBDIR += py-alot
SUBDIR += py-authheaders
SUBDIR += py-authres
+ SUBDIR += py-django-mailbox
SUBDIR += py-django-mailman3
SUBDIR += py-dkimpy
SUBDIR += py-email-validator
diff --git a/mail/py-django-mailbox/Makefile b/mail/py-django-mailbox/Makefile
new file mode 100644
index 000000000000..78b8dc6cd689
--- /dev/null
+++ b/mail/py-django-mailbox/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= django-mailbox
+PORTVERSION= 4.8.2
+CATEGORIES= mail
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gettoknowmi@yahoo.com
+COMMENT= Easily ingest messages from POP3, IMAP, or local mailboxes
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.6.1:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.4+,run
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/py-django-mailbox/distinfo b/mail/py-django-mailbox/distinfo
new file mode 100644
index 000000000000..c556bb39a4f7
--- /dev/null
+++ b/mail/py-django-mailbox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1617293873
+SHA256 (django-mailbox-4.8.2.tar.gz) = c5e00ab266593f5e27486eaa45f97b367d0bd57b5105dcb8c97a5cb6008c9cde
+SIZE (django-mailbox-4.8.2.tar.gz) = 2976691
diff --git a/mail/py-django-mailbox/pkg-descr b/mail/py-django-mailbox/pkg-descr
new file mode 100644
index 000000000000..a24ea8d8b625
--- /dev/null
+++ b/mail/py-django-mailbox/pkg-descr
@@ -0,0 +1,9 @@
+Easily ingest messages from POP3, IMAP, or local mailboxes
+into your Django application.
+
+This app allows you to either ingest e-mail content from common e-mail services
+(as long as the service provides POP3 or IMAP support), or directly receive
+e-mail messages from stdin (for locally processing messages
+from Postfix or Exim4).
+
+WWW: https://github.com/coddingtonbear/django-mailbox/