aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--net-p2p/gnunet/Makefile150
-rw-r--r--net-p2p/gnunet/distinfo4
-rw-r--r--net-p2p/gnunet/files/patch-src__include__platform.h10
-rw-r--r--net-p2p/gnunet/pkg-descr2
-rw-r--r--net-p2p/gnunet/pkg-plist587
7 files changed, 386 insertions, 369 deletions
diff --git a/GIDs b/GIDs
index 59049d3cfc9f..2612b6dfeaec 100644
--- a/GIDs
+++ b/GIDs
@@ -232,4 +232,5 @@ _neubot:*:953:
hadoop:*:955:
pandora:*:956:
razorback:*:957:
+gnunet:*:958:
nobody:*:65534:
diff --git a/UIDs b/UIDs
index f5e030d0a424..dbd36ea2b8eb 100644
--- a/UIDs
+++ b/UIDs
@@ -236,4 +236,5 @@ oops:*:954:65534::0:0:oops user:/nonexistent:/usr/sbin/nologin
hadoop:*:955:955::0:0:hadoop user:/nonexistent:/usr/sbin/nologin
pandora:*:956:956::0:0:Pandora FMS user:/usr/local/etc/pandora/home:/usr/sbin/nologin
razorback:*:957:957::0:0:Razorback user:/var/run/razorback:/usr/sbin/nologin
+gnunet:*:958:958::0:0:GNUnet daemon:/var/lib/gnunet:/usr/sbin/nologin
nobody:*:65534:65534::0:0:Unprivileged user:/nonexistent:/usr/sbin/nologin
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index 0c32f5ab7178..8cfd07b004e4 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -7,70 +7,94 @@
#
PORTNAME= gnunet
-PORTVERSION= 0.8.1b
-PORTREVISION= 13
-CATEGORIES= net-p2p ipv6
-MASTER_SITES= GNU \
- http://gnunet.org/download/
-DISTNAME= GNUnet-${PORTVERSION}
+DISTVERSION= 0.9.2
+CATEGORIES= net-p2p ipv6 security
+MASTER_SITES= GNU
MAINTAINER= bf@FreeBSD.org
COMMENT= An anonymous, distributed, reputation-based network
-LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns \
- cares.2:${PORTSDIR}/dns/c-ares \
- curl.6:${PORTSDIR}/ftp/curl \
- guile.21:${PORTSDIR}/lang/guile \
- esmtp.7:${PORTSDIR}/mail/libesmtp \
- gmp.10:${PORTSDIR}/math/gmp \
- gcrypt.18:${PORTSDIR}/security/libgcrypt \
- extractor.3:${PORTSDIR}/textproc/libextractor \
- microhttpd.23:${PORTSDIR}/www/libmicrohttpd
+LICENSE= GPLv3
-DEPRECATED= BROKEN for more than 6 month
-EXPIRATION_DATE= 2012-05-27
+LIB_DEPENDS= unistring:${PORTSDIR}/devel/libunistring \
+ curl:${PORTSDIR}/ftp/curl \
+ glpk:${PORTSDIR}/math/glpk \
+ gmp:${PORTSDIR}/math/gmp \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
+ extractor:${PORTSDIR}/textproc/libextractor
-BROKEN= does not configure
+OPTIONS= HTTP "Enable HTTP transport via libmicrohttpd" off \
+ MYSQL "Use MySQL for the datastore and datacache" off \
+ NLS "Enable Native Language support" on \
+ PGSQL "Use PostgreSQL for the datastore and datacache" off \
+ SQLITE "Use SQLite for the datastore and datacache" on
-OPTIONS= MYSQL "Enable MySQL support" on \
- PGSQL "Enable PostgreSQL support" off \
- SQLITE "Enable SQLite support" off
-
-USE_GNOME= gnomehack libglade2
-USE_GETTEXT= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= libltdl libtool
-CONFIGURE_ARGS= --with-dialog=no \
- --with-cdialog=no \
- --with-qt=no \
- --with-daemon-home-dir=${DBDIR} \
- --with-daemon-config-dir=${PREFIX}/etc
+USE_GMAKE= yes
+USE_ICONV= yes
USE_LDCONFIG= yes
-PLIST_SUB= DBDIR="${DBDIR}"
+CONFIGURE_ARGS = --with-daemon-home-dir=${GNUNET_DAEMON_DIR} \
+ --with-daemon-config-dir=${PREFIX}/etc \
+ --with-extractor=${LOCALBASE} \
+ --with-libcurl=${LOCALBASE} \
+ --with-libgcrypt-prefix=${LOCALBASE} \
+ --with-libunistring-prefix=${LOCALBASE} \
+ --with-ltdl-include=${LOCALBASE}/include \
+ --with-ltdl-lib=${LOCALBASE}/lib
-MAN1= gnunet-auto-share.1 gnunet-chat.1 gnunet-directory.1 \
- gnunet-download.1 gnunet-insert.1 gnunet-peer-info.1 \
- gnunet-pseudonym.1 gnunet-search.1 gnunet-setup.1 \
- gnunet-stats.1 gnunet-tbench.1 gnunet-testbed.1 \
- gnunet-tracekit.1 gnunet-transport-check.1 gnunet-unindex.1 \
- gnunet-update.1 gnunet-vpn.1 gnunetd.1
-MAN5= gnunet.conf.5 gnunetd.conf.5
+GROUPS = gnunet
+USERS= gnunet
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+MAN1= gnunet-arm.1 gnunet-directory.1 gnunet-download.1 \
+ gnunet-download-manager.1 gnunet-fs.1 gnunet-nat-server.1 \
+ gnunet-peerinfo.1 gnunet-pseudonym.1 gnunet-publish.1 \
+ gnunet-search.1 gnunet-statistics.1 gnunet-transport.1 \
+ gnunet-unindex.1 gnunet-vpn.1
-DBDIR= /var/db/${PORTNAME}
+GNUNET_DAEMON_DIR?= /var/lib/gnunet
+PLIST_SUB= GNUNET_DAEMON_DIR=${GNUNET_DAEMON_DIR}
+SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_MYSQL)
-CONFIGURE_ARGS+= --without-mysql
-PLIST_SUB+= MYSQL="@comment "
+.if !defined(NOPORTDOCS)
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+PORTEXAMPLES= gnunet_janitor.py gnunet_pyexpect.py hostlist.cgi hostlist.php report.sh
+.endif
+
+.if defined(WITH_HTTP)
+BROKEN = WITH_HTTP requires libmicrohttpd 0.9.18 or higher
+LIB_DEPENDS+= microhttpd:${PORTSDIR}/www/libmicrohttpd
+CONFIGURE_ARGS+= --with-microhttpd=${LOCALBASE}
+PLIST_SUB+= HTTP=""
.else
+CONFIGURE_ARGS+= --without-microhttpd
+PLIST_SUB+= HTTP="@comment "
+.endif
+
+.if defined(WITH_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
PLIST_SUB+= MYSQL=""
+.else
+.if !(defined(WITH_PGSQL) || defined(WITH_SQLITE))
+IGNORE = define at least one of WITH_MYSQL, WITH_PGSQL, and WITH_SQLITE
+.endif
+CONFIGURE_ARGS+= --without-mysql
+PLIST_SUB+= MYSQL="@comment "
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.if defined(WITH_PGSQL)
@@ -78,7 +102,6 @@ USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
PLIST_SUB+= PGSQL=""
.else
-
CONFIGURE_ARGS+= --without-postgres
PLIST_SUB+= PGSQL="@comment "
.endif
@@ -93,29 +116,34 @@ PLIST_SUB+= SQLITE="@comment "
.endif
post-patch:
-.for i in configure src/applications/sqstore_postgres/postgres.c
- @${REINPLACE_CMD} -e 's|postgresql/||g' ${WRKSRC}/${i}
-.endfor
-.for i in src/util/crypto/Makefile.in
- @${REINPLACE_CMD} -e 's|)[[:space:]]-O3|)|g' ${WRKSRC}/${i}
-.endfor
+ @${REINPLACE_CMD} -e 's|postgresql/||g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/src/datacache/plugin_datacache_postgres.c \
+ ${WRKSRC}/src/datastore/plugin_datastore_postgres.c
+ @${REINPLACE_CMD} \
+ -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/pkgconfig/Makefile.in
post-install:
- @${MKDIR} ${DBDIR}
-.for i in gnunet.conf gnunetd.conf
- ${INSTALL_DATA} ${WRKSRC}/contrib/${i} ${PREFIX}/etc/${i}-dist
-.endfor
+ @${PRINTF} "%s\n%s\n" "[PATHS]" "SERVICEHOME = ${GNUNET_DAEMON_DIR}" \
+ > ${PREFIX}/etc/gnunet.conf.sample
+.if !exists(${PREFIX}/etc/gnunet.conf)
+ @${CP} ${PREFIX}/etc/gnunet.conf.sample ${PREFIX}/etc/gnunet.conf
+.endif
+.if !exists(${GNUNET_DAEMON_DIR})
+ @${INSTALL} -d -o gnunet -g gnunet -m 700 ${GNUNET_DAEMON_DIR}
+.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/contrib/timeout_watchdog ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for i in AUTHORS ChangeLog HACKING README UPDATING
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
+ @cd ${WRKSRC}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/contrib/*.cgi ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/contrib/*.php ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/contrib/*.sh ${EXAMPLESDIR}
+ @cd ${WRKSRC}/contrib; ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
.endif
+ @${ECHO_CMD} ""
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD} ""
.include <bsd.port.post.mk>
diff --git a/net-p2p/gnunet/distinfo b/net-p2p/gnunet/distinfo
index 62692bd49b79..e1b270a55db9 100644
--- a/net-p2p/gnunet/distinfo
+++ b/net-p2p/gnunet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (GNUnet-0.8.1b.tar.gz) = 7c854d2ef5ee592193bb04d8746a8b0ffc20f568674145a1f9a2e8f2bbced64c
-SIZE (GNUnet-0.8.1b.tar.gz) = 2366646
+SHA256 (gnunet-0.9.2.tar.gz) = 24f5f1cb93782c22bd61ffdc9d99b7cfb2532dc4b6fb7d3468931e5a10eb47e9
+SIZE (gnunet-0.9.2.tar.gz) = 6239795
diff --git a/net-p2p/gnunet/files/patch-src__include__platform.h b/net-p2p/gnunet/files/patch-src__include__platform.h
deleted file mode 100644
index f10dbcd587bf..000000000000
--- a/net-p2p/gnunet/files/patch-src__include__platform.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/include/platform.h.orig 2009-10-01 07:11:14.000000000 +0900
-+++ src/include/platform.h 2010-01-05 00:27:09.000000000 +0900
-@@ -189,6 +189,7 @@
- #endif
-
- #ifdef FREEBSD
-+typedef int error_t;
- #define __BYTE_ORDER BYTE_ORDER
- #define __BIG_ENDIAN BIG_ENDIAN
- #endif
diff --git a/net-p2p/gnunet/pkg-descr b/net-p2p/gnunet/pkg-descr
index e79703470809..20a26790620b 100644
--- a/net-p2p/gnunet/pkg-descr
+++ b/net-p2p/gnunet/pkg-descr
@@ -11,4 +11,4 @@ While our goals are similar to projects like Freenet, Gnutella, MojoNation
and others, we hope to provide a superior combination of features for users
that value security more than efficiency.
-WWW: http://gnunet.org/
+WWW: https://gnunet.org/
diff --git a/net-p2p/gnunet/pkg-plist b/net-p2p/gnunet/pkg-plist
index 07be59a6ff28..4c987c7f1a7e 100644
--- a/net-p2p/gnunet/pkg-plist
+++ b/net-p2p/gnunet/pkg-plist
@@ -1,310 +1,307 @@
-bin/gnunet-auto-share
-bin/gnunet-chat
+bin/gnunet-arm
+bin/gnunet-core-list-connections
+bin/gnunet-daemon-hostlist
+bin/gnunet-daemon-topology
+bin/gnunet-dht-get
+bin/gnunet-dht-put
bin/gnunet-directory
bin/gnunet-download
-bin/gnunet-insert
-bin/gnunet-peer-info
+bin/gnunet-download-manager.scm
+bin/gnunet-fs
+bin/gnunet-helper-fs-publish
+bin/gnunet-nat-server
+bin/gnunet-peerinfo
bin/gnunet-pseudonym
+bin/gnunet-publish
+bin/gnunet-resolver
bin/gnunet-search
-bin/gnunet-setup
-bin/gnunet-stats
-bin/gnunet-tbench
-bin/gnunet-tracekit
-bin/gnunet-transport-check
+bin/gnunet-service-arm
+bin/gnunet-service-ats
+bin/gnunet-service-core
+bin/gnunet-service-datastore
+bin/gnunet-service-dht
+bin/gnunet-service-fs
+bin/gnunet-service-mesh
+bin/gnunet-service-namestore
+bin/gnunet-service-nse
+bin/gnunet-service-peerinfo
+bin/gnunet-service-resolver
+bin/gnunet-service-statistics
+bin/gnunet-service-template
+bin/gnunet-service-transport
+bin/gnunet-statistics
+bin/gnunet-template
+bin/gnunet-testing
+bin/gnunet-transport
+bin/gnunet-transport-certificate-creation
bin/gnunet-unindex
-bin/gnunet-update
-bin/gnunetd
-etc/gnunet.conf-dist
-etc/gnunetd.conf-dist
-include/GNUnet/gnunet_bootstrap_service.h
-include/GNUnet/gnunet_chat_lib.h
-include/GNUnet/gnunet_collection_lib.h
-include/GNUnet/gnunet_core.h
-include/GNUnet/gnunet_datastore_service.h
-include/GNUnet/gnunet_dhtlog_service.h
-include/GNUnet/gnunet_directories.h
-include/GNUnet/gnunet_dstore_service.h
-include/GNUnet/gnunet_dv_dht_lib.h
-include/GNUnet/gnunet_dv_dht_service.h
-include/GNUnet/gnunet_dv_service.h
-include/GNUnet/gnunet_ecrs_lib.h
-include/GNUnet/gnunet_fragmentation_service.h
-include/GNUnet/gnunet_fs_lib.h
-include/GNUnet/gnunet_fsui_lib.h
-include/GNUnet/gnunet_getoption_lib.h
-include/GNUnet/gnunet_identity_lib.h
-include/GNUnet/gnunet_identity_service.h
-include/GNUnet/gnunet_kvstore_service.h
-include/GNUnet/gnunet_mysql.h
-include/GNUnet/gnunet_namespace_lib.h
-include/GNUnet/gnunet_pingpong_service.h
-include/GNUnet/gnunet_protocols.h
-include/GNUnet/gnunet_remote_lib.h
-include/GNUnet/gnunet_rpc_lib.h
-include/GNUnet/gnunet_rpc_service.h
-include/GNUnet/gnunet_session_service.h
-include/GNUnet/gnunet_setup_lib.h
-include/GNUnet/gnunet_sqstore_service.h
-include/GNUnet/gnunet_state_service.h
-include/GNUnet/gnunet_stats_lib.h
-include/GNUnet/gnunet_stats_service.h
-include/GNUnet/gnunet_testing_lib.h
-include/GNUnet/gnunet_topology_service.h
-include/GNUnet/gnunet_tracekit_lib.h
-include/GNUnet/gnunet_traffic_lib.h
-include/GNUnet/gnunet_traffic_service.h
-include/GNUnet/gnunet_transport.h
-include/GNUnet/gnunet_transport_service.h
-include/GNUnet/gnunet_upnp_service.h
-include/GNUnet/gnunet_uritrack_lib.h
-include/GNUnet/gnunet_util.h
-include/GNUnet/gnunet_util_boot.h
-include/GNUnet/gnunet_util_common.h
-include/GNUnet/gnunet_util_config.h
-include/GNUnet/gnunet_util_containers.h
-include/GNUnet/gnunet_util_core.h
-include/GNUnet/gnunet_util_cron.h
-include/GNUnet/gnunet_util_crypto.h
-include/GNUnet/gnunet_util_disk.h
-include/GNUnet/gnunet_util_error.h
-include/GNUnet/gnunet_util_error_loggers.h
-include/GNUnet/gnunet_util_getopt.h
-include/GNUnet/gnunet_util_network.h
-include/GNUnet/gnunet_util_network_client.h
-include/GNUnet/gnunet_util_os.h
-include/GNUnet/gnunet_util_pseudonym.h
-include/GNUnet/gnunet_util_string.h
-include/GNUnet/gnunet_util_threads.h
-lib/GNUnet/libgnunetmodule_advertising.a
-lib/GNUnet/libgnunetmodule_advertising.la
-lib/GNUnet/libgnunetmodule_advertising.so
-lib/GNUnet/libgnunetmodule_bootstrap.a
-lib/GNUnet/libgnunetmodule_bootstrap.la
-lib/GNUnet/libgnunetmodule_bootstrap.so
-lib/GNUnet/libgnunetmodule_chat.a
-lib/GNUnet/libgnunetmodule_chat.la
-lib/GNUnet/libgnunetmodule_chat.so
-lib/GNUnet/libgnunetmodule_datastore.a
-lib/GNUnet/libgnunetmodule_datastore.la
-lib/GNUnet/libgnunetmodule_datastore.so
-%%MYSQL%%lib/GNUnet/libgnunetmodule_dhtlog_mysql.a
-%%MYSQL%%lib/GNUnet/libgnunetmodule_dhtlog_mysql.la
-%%MYSQL%%lib/GNUnet/libgnunetmodule_dhtlog_mysql.so
-%%MYSQL%%lib/GNUnet/libgnunetmodule_dstore_mysql.a
-%%MYSQL%%lib/GNUnet/libgnunetmodule_dstore_mysql.la
-%%MYSQL%%lib/GNUnet/libgnunetmodule_dstore_mysql.so
-%%SQLITE%%lib/GNUnet/libgnunetmodule_dstore_sqlite.a
-%%SQLITE%%lib/GNUnet/libgnunetmodule_dstore_sqlite.la
-%%SQLITE%%lib/GNUnet/libgnunetmodule_dstore_sqlite.so
-lib/GNUnet/libgnunetmodule_dv.a
-lib/GNUnet/libgnunetmodule_dv.la
-lib/GNUnet/libgnunetmodule_dv.so
-lib/GNUnet/libgnunetmodule_dv_dht.a
-lib/GNUnet/libgnunetmodule_dv_dht.la
-lib/GNUnet/libgnunetmodule_dv_dht.so
-lib/GNUnet/libgnunetmodule_dv_tbench.a
-lib/GNUnet/libgnunetmodule_dv_tbench.la
-lib/GNUnet/libgnunetmodule_dv_tbench.so
-lib/GNUnet/libgnunetmodule_fragmentation.a
-lib/GNUnet/libgnunetmodule_fragmentation.la
-lib/GNUnet/libgnunetmodule_fragmentation.so
-lib/GNUnet/libgnunetmodule_fs.a
-lib/GNUnet/libgnunetmodule_fs.la
-lib/GNUnet/libgnunetmodule_fs.so
-lib/GNUnet/libgnunetmodule_getoption.a
-lib/GNUnet/libgnunetmodule_getoption.la
-lib/GNUnet/libgnunetmodule_getoption.so
-lib/GNUnet/libgnunetmodule_hostlist.a
-lib/GNUnet/libgnunetmodule_hostlist.la
-lib/GNUnet/libgnunetmodule_hostlist.so
-lib/GNUnet/libgnunetmodule_identity.a
-lib/GNUnet/libgnunetmodule_identity.la
-lib/GNUnet/libgnunetmodule_identity.so
-%%SQLITE%%lib/GNUnet/libgnunetmodule_kvstore_sqlite.a
-%%SQLITE%%lib/GNUnet/libgnunetmodule_kvstore_sqlite.la
-%%SQLITE%%lib/GNUnet/libgnunetmodule_kvstore_sqlite.so
-lib/GNUnet/libgnunetmodule_pingpong.a
-lib/GNUnet/libgnunetmodule_pingpong.la
-lib/GNUnet/libgnunetmodule_pingpong.so
-lib/GNUnet/libgnunetmodule_rpc.a
-lib/GNUnet/libgnunetmodule_rpc.la
-lib/GNUnet/libgnunetmodule_rpc.so
-lib/GNUnet/libgnunetmodule_session.a
-lib/GNUnet/libgnunetmodule_session.la
-lib/GNUnet/libgnunetmodule_session.so
-%%MYSQL%%lib/GNUnet/libgnunetmodule_sqstore_mysql.a
-%%MYSQL%%lib/GNUnet/libgnunetmodule_sqstore_mysql.la
-%%MYSQL%%lib/GNUnet/libgnunetmodule_sqstore_mysql.so
-%%PGSQL%%lib/GNUnet/libgnunetmodule_sqstore_postgres.a
-%%PGSQL%%lib/GNUnet/libgnunetmodule_sqstore_postgres.la
-%%PGSQL%%lib/GNUnet/libgnunetmodule_sqstore_postgres.so
-%%SQLITE%%lib/GNUnet/libgnunetmodule_sqstore_sqlite.a
-%%SQLITE%%lib/GNUnet/libgnunetmodule_sqstore_sqlite.la
-%%SQLITE%%lib/GNUnet/libgnunetmodule_sqstore_sqlite.so
-lib/GNUnet/libgnunetmodule_state.a
-lib/GNUnet/libgnunetmodule_state.la
-lib/GNUnet/libgnunetmodule_state.so
-lib/GNUnet/libgnunetmodule_stats.a
-lib/GNUnet/libgnunetmodule_stats.la
-lib/GNUnet/libgnunetmodule_stats.so
-lib/GNUnet/libgnunetmodule_tbench.a
-lib/GNUnet/libgnunetmodule_tbench.la
-lib/GNUnet/libgnunetmodule_tbench.so
-lib/GNUnet/libgnunetmodule_template.a
-lib/GNUnet/libgnunetmodule_template.la
-lib/GNUnet/libgnunetmodule_template.so
-lib/GNUnet/libgnunetmodule_topology_default.a
-lib/GNUnet/libgnunetmodule_topology_default.la
-lib/GNUnet/libgnunetmodule_topology_default.so
-lib/GNUnet/libgnunetmodule_tracekit.a
-lib/GNUnet/libgnunetmodule_tracekit.la
-lib/GNUnet/libgnunetmodule_tracekit.so
-lib/GNUnet/libgnunetmodule_traffic.a
-lib/GNUnet/libgnunetmodule_traffic.la
-lib/GNUnet/libgnunetmodule_traffic.so
-lib/GNUnet/libgnunetmodule_transport.a
-lib/GNUnet/libgnunetmodule_transport.la
-lib/GNUnet/libgnunetmodule_transport.so
-lib/GNUnet/libgnunetmodule_upnp.a
-lib/GNUnet/libgnunetmodule_upnp.la
-lib/GNUnet/libgnunetmodule_upnp.so
-lib/GNUnet/libgnunetsetup_gtk.a
-lib/GNUnet/libgnunetsetup_gtk.la
-lib/GNUnet/libgnunetsetup_gtk.so
-lib/GNUnet/libgnunetsetup_text.a
-lib/GNUnet/libgnunetsetup_text.la
-lib/GNUnet/libgnunetsetup_text.so
-lib/GNUnet/libgnunettransport_http.a
-lib/GNUnet/libgnunettransport_http.la
-lib/GNUnet/libgnunettransport_http.so
-lib/GNUnet/libgnunettransport_nat.a
-lib/GNUnet/libgnunettransport_nat.la
-lib/GNUnet/libgnunettransport_nat.so
-lib/GNUnet/libgnunettransport_smtp.a
-lib/GNUnet/libgnunettransport_smtp.la
-lib/GNUnet/libgnunettransport_smtp.so
-lib/GNUnet/libgnunettransport_tcp.a
-lib/GNUnet/libgnunettransport_tcp.la
-lib/GNUnet/libgnunettransport_tcp.so
-lib/GNUnet/libgnunettransport_udp.a
-lib/GNUnet/libgnunettransport_udp.la
-lib/GNUnet/libgnunettransport_udp.so
-lib/libgnunetchatapi.a
-lib/libgnunetchatapi.la
-lib/libgnunetchatapi.so
-lib/libgnunetchatapi.so.0
-lib/libgnunetcollection.a
-lib/libgnunetcollection.la
-lib/libgnunetcollection.so
-lib/libgnunetcollection.so.0
+bin/mockup-service
+bin/timeout_watchdog
+etc/gnunet.conf.sample
+@exec if [ ! -f %B/gnunet.conf ] ; then cp -p %D/%F %B/gnunet.conf ; fi
+@unexec if cmp -s %D/%F %B/gnunet.conf ; then rm -f %B/gnunet.conf ; fi
+include/gnunet/block_dns.h
+include/gnunet/block_fs.h
+include/gnunet/block_gns.h
+include/gnunet/gauger.h
+include/gnunet/gettext.h
+include/gnunet/gnunet_applications.h
+include/gnunet/gnunet_arm_service.h
+include/gnunet/gnunet_ats_service.h
+include/gnunet/gnunet_bandwidth_lib.h
+include/gnunet/gnunet_bio_lib.h
+include/gnunet/gnunet_block_lib.h
+include/gnunet/gnunet_block_plugin.h
+include/gnunet/gnunet_chat_service.h
+include/gnunet/gnunet_client_lib.h
+include/gnunet/gnunet_common.h
+include/gnunet/gnunet_config.h
+include/gnunet/gnunet_configuration_lib.h
+include/gnunet/gnunet_connection_lib.h
+include/gnunet/gnunet_constants.h
+include/gnunet/gnunet_container_lib.h
+include/gnunet/gnunet_core_service.h
+include/gnunet/gnunet_crypto_lib.h
+include/gnunet/gnunet_datacache_lib.h
+include/gnunet/gnunet_datacache_plugin.h
+include/gnunet/gnunet_datastore_plugin.h
+include/gnunet/gnunet_datastore_service.h
+include/gnunet/gnunet_dht_service.h
+include/gnunet/gnunet_directories.h
+include/gnunet/gnunet_disk_lib.h
+include/gnunet/gnunet_dns_service.h
+include/gnunet/gnunet_dnsparser_lib.h
+include/gnunet/gnunet_dv_service.h
+include/gnunet/gnunet_fragmentation_lib.h
+include/gnunet/gnunet_fs_service.h
+include/gnunet/gnunet_getopt_lib.h
+include/gnunet/gnunet_gns_service.h
+include/gnunet/gnunet_hello_lib.h
+include/gnunet/gnunet_helper_lib.h
+include/gnunet/gnunet_load_lib.h
+include/gnunet/gnunet_mesh_service.h
+include/gnunet/gnunet_namestore_plugin.h
+include/gnunet/gnunet_namestore_service.h
+include/gnunet/gnunet_nat_lib.h
+include/gnunet/gnunet_network_lib.h
+include/gnunet/gnunet_nse_service.h
+include/gnunet/gnunet_os_lib.h
+include/gnunet/gnunet_peer_lib.h
+include/gnunet/gnunet_peerinfo_service.h
+include/gnunet/gnunet_plugin_lib.h
+include/gnunet/gnunet_program_lib.h
+include/gnunet/gnunet_protocols.h
+include/gnunet/gnunet_pseudonym_lib.h
+include/gnunet/gnunet_resolver_service.h
+include/gnunet/gnunet_scheduler_lib.h
+include/gnunet/gnunet_server_lib.h
+include/gnunet/gnunet_service_lib.h
+include/gnunet/gnunet_signal_lib.h
+include/gnunet/gnunet_signatures.h
+include/gnunet/gnunet_statistics_service.h
+include/gnunet/gnunet_stream_lib.h
+include/gnunet/gnunet_strings_lib.h
+include/gnunet/gnunet_testing_lib.h
+include/gnunet/gnunet_time_lib.h
+include/gnunet/gnunet_transport_plugin.h
+include/gnunet/gnunet_transport_service.h
+include/gnunet/gnunet_tun_lib.h
+include/gnunet/gnunet_util_lib.h
+include/gnunet/gnunet_vpn_service.h
+include/gnunet/platform.h
+include/gnunet/plibc.h
+lib/gnunet/libgnunet_plugin_block_dht.a
+lib/gnunet/libgnunet_plugin_block_dht.la
+lib/gnunet/libgnunet_plugin_block_dht.so
+lib/gnunet/libgnunet_plugin_block_fs.a
+lib/gnunet/libgnunet_plugin_block_fs.la
+lib/gnunet/libgnunet_plugin_block_fs.so
+lib/gnunet/libgnunet_plugin_block_template.a
+lib/gnunet/libgnunet_plugin_block_template.la
+lib/gnunet/libgnunet_plugin_block_template.so
+lib/gnunet/libgnunet_plugin_block_test.a
+lib/gnunet/libgnunet_plugin_block_test.la
+lib/gnunet/libgnunet_plugin_block_test.so
+%%MYSQL%%lib/gnunet/libgnunet_plugin_datacache_mysql.a
+%%MYSQL%%lib/gnunet/libgnunet_plugin_datacache_mysql.la
+%%MYSQL%%lib/gnunet/libgnunet_plugin_datacache_mysql.so
+%%PGSQL%%lib/gnunet/libgnunet_plugin_datacache_postgres.a
+%%PGSQL%%lib/gnunet/libgnunet_plugin_datacache_postgres.la
+%%PGSQL%%lib/gnunet/libgnunet_plugin_datacache_postgres.so
+%%SQLITE%%lib/gnunet/libgnunet_plugin_datacache_sqlite.a
+%%SQLITE%%lib/gnunet/libgnunet_plugin_datacache_sqlite.la
+%%SQLITE%%lib/gnunet/libgnunet_plugin_datacache_sqlite.so
+lib/gnunet/libgnunet_plugin_datacache_template.a
+lib/gnunet/libgnunet_plugin_datacache_template.la
+lib/gnunet/libgnunet_plugin_datacache_template.so
+%%MYSQL%%lib/gnunet/libgnunet_plugin_datastore_mysql.a
+%%MYSQL%%lib/gnunet/libgnunet_plugin_datastore_mysql.la
+%%MYSQL%%lib/gnunet/libgnunet_plugin_datastore_mysql.so
+%%PGSQL%%lib/gnunet/libgnunet_plugin_datastore_postgres.a
+%%PGSQL%%lib/gnunet/libgnunet_plugin_datastore_postgres.la
+%%PGSQL%%lib/gnunet/libgnunet_plugin_datastore_postgres.so
+%%SQLITE%%lib/gnunet/libgnunet_plugin_datastore_sqlite.a
+%%SQLITE%%lib/gnunet/libgnunet_plugin_datastore_sqlite.la
+%%SQLITE%%lib/gnunet/libgnunet_plugin_datastore_sqlite.so
+lib/gnunet/libgnunet_plugin_datastore_template.a
+lib/gnunet/libgnunet_plugin_datastore_template.la
+lib/gnunet/libgnunet_plugin_datastore_template.so
+%%SQLITE%%lib/gnunet/libgnunet_plugin_namestore_sqlite.a
+%%SQLITE%%lib/gnunet/libgnunet_plugin_namestore_sqlite.la
+%%SQLITE%%lib/gnunet/libgnunet_plugin_namestore_sqlite.so
+lib/gnunet/libgnunet_plugin_test.a
+lib/gnunet/libgnunet_plugin_test.la
+lib/gnunet/libgnunet_plugin_test.so
+%%HTTP%%lib/gnunet/libgnunet_plugin_transport_http.a
+%%HTTP%%lib/gnunet/libgnunet_plugin_transport_http.la
+%%HTTP%%lib/gnunet/libgnunet_plugin_transport_http.so
+%%HTTP%%lib/gnunet/libgnunet_plugin_transport_https.a
+%%HTTP%%lib/gnunet/libgnunet_plugin_transport_https.la
+%%HTTP%%lib/gnunet/libgnunet_plugin_transport_https.so
+lib/gnunet/libgnunet_plugin_transport_tcp.a
+lib/gnunet/libgnunet_plugin_transport_tcp.la
+lib/gnunet/libgnunet_plugin_transport_tcp.so
+lib/gnunet/libgnunet_plugin_transport_template.a
+lib/gnunet/libgnunet_plugin_transport_template.la
+lib/gnunet/libgnunet_plugin_transport_template.so
+lib/gnunet/libgnunet_plugin_transport_udp.a
+lib/gnunet/libgnunet_plugin_transport_udp.la
+lib/gnunet/libgnunet_plugin_transport_udp.so
+lib/gnunet/libgnunet_plugin_transport_unix.a
+lib/gnunet/libgnunet_plugin_transport_unix.la
+lib/gnunet/libgnunet_plugin_transport_unix.so
+lib/libgnunetarm.a
+lib/libgnunetarm.la
+lib/libgnunetarm.so
+lib/libgnunetarm.so.1
+lib/libgnunetats.a
+lib/libgnunetats.la
+lib/libgnunetats.so
+lib/libgnunetats.so.1
+lib/libgnunetblock.a
+lib/libgnunetblock.la
+lib/libgnunetblock.so
+lib/libgnunetblock.so.0
lib/libgnunetcore.a
lib/libgnunetcore.la
lib/libgnunetcore.so
lib/libgnunetcore.so.0
-lib/libgnunetdvdhtapi.a
-lib/libgnunetdvdhtapi.la
-lib/libgnunetdvdhtapi.so
-lib/libgnunetdvdhtapi.so.0
-lib/libgnunetecrs.a
-lib/libgnunetecrs.la
-lib/libgnunetecrs.so
-lib/libgnunetecrs.so.0
-lib/libgnunetecrscore.a
-lib/libgnunetecrscore.la
-lib/libgnunetecrscore.so
-lib/libgnunetecrscore.so.0
+lib/libgnunetdatacache.a
+lib/libgnunetdatacache.la
+lib/libgnunetdatacache.so
+lib/libgnunetdatacache.so.0
+lib/libgnunetdatastore.a
+lib/libgnunetdatastore.la
+lib/libgnunetdatastore.so
+lib/libgnunetdatastore.so.1
+lib/libgnunetdht.a
+lib/libgnunetdht.la
+lib/libgnunetdht.so
+lib/libgnunetdht.so.1
+lib/libgnunetfragmentation.a
+lib/libgnunetfragmentation.la
+lib/libgnunetfragmentation.so
+lib/libgnunetfragmentation.so.0
lib/libgnunetfs.a
lib/libgnunetfs.la
lib/libgnunetfs.so
-lib/libgnunetfs.so.0
-lib/libgnunetfsui.a
-lib/libgnunetfsui.la
-lib/libgnunetfsui.so
-lib/libgnunetfsui.so.0
-lib/libgnunetgetoptionapi.a
-lib/libgnunetgetoptionapi.la
-lib/libgnunetgetoptionapi.so
-lib/libgnunetgetoptionapi.so.0
-lib/libgnunetidentityapi.a
-lib/libgnunetidentityapi.la
-lib/libgnunetidentityapi.so
-lib/libgnunetidentityapi.so.0
-lib/libgnunetip.a
-lib/libgnunetip.la
-lib/libgnunetip.so
-lib/libgnunetip.so.0
-%%MYSQL%%lib/libgnunetmysql.a
-%%MYSQL%%lib/libgnunetmysql.la
-%%MYSQL%%lib/libgnunetmysql.so
-%%MYSQL%%lib/libgnunetmysql.so.0
-lib/libgnunetnamespace.a
-lib/libgnunetnamespace.la
-lib/libgnunetnamespace.so
-lib/libgnunetnamespace.so.0
-lib/libgnunetremoteapi.a
-lib/libgnunetremoteapi.la
-lib/libgnunetremoteapi.so
-lib/libgnunetremoteapi.so.0
-lib/libgnunetrpcutil.a
-lib/libgnunetrpcutil.la
-lib/libgnunetrpcutil.so
-lib/libgnunetrpcutil.so.0
-lib/libgnunetsetup.a
-lib/libgnunetsetup.la
-lib/libgnunetsetup.so
-lib/libgnunetsetup.so.0
-lib/libgnunetstatsapi.a
-lib/libgnunetstatsapi.la
-lib/libgnunetstatsapi.so
-lib/libgnunetstatsapi.so.0
-lib/libgnunettestingapi.a
-lib/libgnunettestingapi.la
-lib/libgnunettestingapi.so
-lib/libgnunettestingapi.so.0
-lib/libgnunettracekitapi.a
-lib/libgnunettracekitapi.la
-lib/libgnunettracekitapi.so
-lib/libgnunettracekitapi.so.0
-lib/libgnunettrafficapi.a
-lib/libgnunettrafficapi.la
-lib/libgnunettrafficapi.so
-lib/libgnunettrafficapi.so.0
-lib/libgnuneturitrack.a
-lib/libgnuneturitrack.la
-lib/libgnuneturitrack.so
-lib/libgnuneturitrack.so.0
+lib/libgnunetfs.so.2
+lib/libgnunethello.a
+lib/libgnunethello.la
+lib/libgnunethello.so
+lib/libgnunethello.so.0
+lib/libgnunetmesh.a
+lib/libgnunetmesh.la
+lib/libgnunetmesh.so
+lib/libgnunetmesh.so.0
+lib/libgnunetnamestore.a
+lib/libgnunetnamestore.la
+lib/libgnunetnamestore.so
+lib/libgnunetnamestore.so.0
+lib/libgnunetnat.a
+lib/libgnunetnat.la
+lib/libgnunetnat.so
+lib/libgnunetnat.so.0
+lib/libgnunetnse.a
+lib/libgnunetnse.la
+lib/libgnunetnse.so
+lib/libgnunetnse.so.0
+lib/libgnunetpeerinfo.a
+lib/libgnunetpeerinfo.la
+lib/libgnunetpeerinfo.so
+lib/libgnunetpeerinfo.so.0
+lib/libgnunetstatistics.a
+lib/libgnunetstatistics.la
+lib/libgnunetstatistics.so
+lib/libgnunetstatistics.so.1
+lib/libgnunettesting.a
+lib/libgnunettesting.la
+lib/libgnunettesting.so
+lib/libgnunettesting.so.0
+lib/libgnunettransport.a
+lib/libgnunettransport.la
+lib/libgnunettransport.so
+lib/libgnunettransport.so.0
+lib/libgnunettransporttesting.a
+lib/libgnunettransporttesting.la
+lib/libgnunettransporttesting.so
+lib/libgnunettransporttesting.so.0
+lib/libgnunettun.a
+lib/libgnunettun.la
+lib/libgnunettun.so
+lib/libgnunettun.so.0
lib/libgnunetutil.a
lib/libgnunetutil.la
lib/libgnunetutil.so
-lib/libgnunetutil.so.3
-share/GNUnet/config-client.scm
-share/GNUnet/config-daemon.scm
-share/GNUnet/gnunet-lab-testing.conf
-share/GNUnet/gnunet-logo-color.png
-share/GNUnet/gnunet-setup.glade
-share/GNUnet/gnunet-testing.conf
-share/GNUnet/gnunetd.conf.skel
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/HACKING
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/UPDATING
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnmessage.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hostlist.cgi
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hostlist.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/junkinsert.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/junklookup.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/namespacehelper.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/report.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/visualize_stats.sh
-share/locale/de/LC_MESSAGES/GNUnet.mo
-share/locale/es/LC_MESSAGES/GNUnet.mo
-share/locale/sv/LC_MESSAGES/GNUnet.mo
-share/locale/vi/LC_MESSAGES/GNUnet.mo
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm share/GNUnet
-@dirrm lib/GNUnet
-@dirrm include/GNUnet
-@exec mkdir -p %%DBDIR%%
-@unexec rmdir %%DBDIR%% 2>/dev/null || true
+lib/libgnunetutil.so.7
+libdata/pkgconfig/gnunetarm.pc
+libdata/pkgconfig/gnunetblock.pc
+libdata/pkgconfig/gnunetcore.pc
+libdata/pkgconfig/gnunetdatacache.pc
+libdata/pkgconfig/gnunetdatastore.pc
+libdata/pkgconfig/gnunetdht.pc
+libdata/pkgconfig/gnunetdhtlog.pc
+libdata/pkgconfig/gnunetdv.pc
+libdata/pkgconfig/gnunetfragmentation.pc
+libdata/pkgconfig/gnunetfs.pc
+libdata/pkgconfig/gnunethello.pc
+libdata/pkgconfig/gnunetnat.pc
+libdata/pkgconfig/gnunetnse.pc
+libdata/pkgconfig/gnunetpeerinfo.pc
+libdata/pkgconfig/gnunetstatistics.pc
+libdata/pkgconfig/gnunettesting.pc
+libdata/pkgconfig/gnunettransport.pc
+libdata/pkgconfig/gnunetutil.pc
+%%DATADIR%%/config.d/arm.conf
+%%DATADIR%%/config.d/ats.conf
+%%DATADIR%%/config.d/core.conf
+%%DATADIR%%/config.d/datacache.conf
+%%DATADIR%%/config.d/datastore.conf
+%%DATADIR%%/config.d/dht.conf
+%%DATADIR%%/config.d/fs.conf
+%%DATADIR%%/config.d/hostlist.conf
+%%DATADIR%%/config.d/mesh.conf
+%%DATADIR%%/config.d/nat.conf
+%%DATADIR%%/config.d/nse.conf
+%%DATADIR%%/config.d/peerinfo.conf
+%%DATADIR%%/config.d/resolver.conf
+%%DATADIR%%/config.d/statistics.conf
+%%DATADIR%%/config.d/template.conf
+%%DATADIR%%/config.d/testing.conf
+%%DATADIR%%/config.d/topology.conf
+%%DATADIR%%/config.d/transport.conf
+%%DATADIR%%/config.d/util.conf
+%%DATADIR%%/gnunet-logo-color.png
+%%NLS%%share/locale/de/LC_MESSAGES/gnunet.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gnunet.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gnunet.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/gnunet.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnunet.mo
+@dirrm %%DATADIR%%/config.d
+@dirrm %%DATADIR%%
+@dirrm lib/gnunet
+@dirrm include/gnunet
+@exec if [ ! -d %%GNUNET_DAEMON_DIR%% ] ; then install -d -o gnunet -g gnunet -m 700 %%GNUNET_DAEMON_DIR%% ; fi
+@exec chown -R gnunet:gnunet %%GNUNET_DAEMON_DIR%%
+@exec chmod -R 700 %%GNUNET_DAEMON_DIR%%
+@dirrmtry %%GNUNET_DAEMON_DIR%%